mbox series

[v3,00/10] Summit SMB3xx driver & device-tree

Message ID 20200813213409.24222-1-digetx@gmail.com
Headers show
Series Summit SMB3xx driver & device-tree | expand

Message

Dmitry Osipenko Aug. 13, 2020, 9:33 p.m. UTC
We gathered existing patches, fixed and improved what we could and
final result is an working charging driver with device-tree support
for Nexus 7.

At this moment charging works with:
 - Nexus 7 2012 (grouper and tilapia)
 - Nexus 7 2013 (flo and deb)
 - ... and there are more devices equipped with these chargers.

Changelog:

v3: - The uint32 type now isn't specified for standard units in the SMB
      DT binding because standard units already have a type.
      Thanks to Rob Herring for the suggestion!

    - The battery binding changes are rebased on top of the new battery.yaml

    - The new battery temperature DT properties now have shorter names
      and use <min max> format. Thanks to Rob Herring for the suggestion!

    - Added new patch that adds SMB charger node to the new Nexus 7 2012
      device-tree which has been merged into v5.9 kernel.

v2: - Addressed v1 review comments from Rob Herring and Sebastian Reichel
      by moving out common battery properties from the charger node into the
      battery-cell node.

    - power_supply_register() of the SMB driver converted to resource-managed
      API variant.

    - Improved DT property names of the SMB binding by making them to follow
      the generic power-supply naming scheme (-microvolts at the end, etc).

David Heidelberg (7):
  dt-bindings: power: supply: Add device-tree binding for Summit SMB3xx
  power: supply: smb347-charger: Use resource-managed API
  power: supply: smb347-charger: Implement device-tree support
  power: supply: smb347-charger: Support SMB345 and SMB358
  power: supply: smb347-charger: Remove virtual smb347-battery
  ARM: dts: qcom: apq8064-nexus7: Add SMB345 battery charger
  ARM: tegra: nexus7: Add SMB347 battery charger

Dmitry Osipenko (3):
  dt-bindings: battery: Add temperature properties
  power: supply: Support battery temperature device-tree properties
  power: supply: smb347-charger: Replace mutex with IRQ disable/enable

 .../bindings/power/supply/battery.yaml        |  24 +
 .../power/supply/summit,smb347-charger.yaml   | 152 +++++
 .../boot/dts/qcom-apq8064-asus-nexus7-flo.dts |  24 +
 .../tegra30-asus-nexus7-grouper-common.dtsi   |  24 +-
 drivers/power/supply/Kconfig                  |   6 +-
 drivers/power/supply/power_supply_core.c      |  19 +
 drivers/power/supply/smb347-charger.c         | 565 +++++++++---------
 .../dt-bindings/power/summit,smb347-charger.h |  19 +
 include/linux/power_supply.h                  |   6 +
 9 files changed, 568 insertions(+), 271 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/power/supply/summit,smb347-charger.yaml
 create mode 100644 include/dt-bindings/power/summit,smb347-charger.h

Comments

Sebastian Reichel Aug. 26, 2020, 2:40 p.m. UTC | #1
Hi,

I queued patches 1-8 (so everything besides the DTS changes). I
would like to see some more cleanups and will send a separate
patchset for them in a jiffy. Please test them, since I do not
have the hardware.

-- Sebastian

On Fri, Aug 14, 2020 at 12:33:59AM +0300, Dmitry Osipenko wrote:
> We gathered existing patches, fixed and improved what we could and
> final result is an working charging driver with device-tree support
> for Nexus 7.
> 
> At this moment charging works with:
>  - Nexus 7 2012 (grouper and tilapia)
>  - Nexus 7 2013 (flo and deb)
>  - ... and there are more devices equipped with these chargers.
> 
> Changelog:
> 
> v3: - The uint32 type now isn't specified for standard units in the SMB
>       DT binding because standard units already have a type.
>       Thanks to Rob Herring for the suggestion!
> 
>     - The battery binding changes are rebased on top of the new battery.yaml
> 
>     - The new battery temperature DT properties now have shorter names
>       and use <min max> format. Thanks to Rob Herring for the suggestion!
> 
>     - Added new patch that adds SMB charger node to the new Nexus 7 2012
>       device-tree which has been merged into v5.9 kernel.
> 
> v2: - Addressed v1 review comments from Rob Herring and Sebastian Reichel
>       by moving out common battery properties from the charger node into the
>       battery-cell node.
> 
>     - power_supply_register() of the SMB driver converted to resource-managed
>       API variant.
> 
>     - Improved DT property names of the SMB binding by making them to follow
>       the generic power-supply naming scheme (-microvolts at the end, etc).
> 
> David Heidelberg (7):
>   dt-bindings: power: supply: Add device-tree binding for Summit SMB3xx
>   power: supply: smb347-charger: Use resource-managed API
>   power: supply: smb347-charger: Implement device-tree support
>   power: supply: smb347-charger: Support SMB345 and SMB358
>   power: supply: smb347-charger: Remove virtual smb347-battery
>   ARM: dts: qcom: apq8064-nexus7: Add SMB345 battery charger
>   ARM: tegra: nexus7: Add SMB347 battery charger
> 
> Dmitry Osipenko (3):
>   dt-bindings: battery: Add temperature properties
>   power: supply: Support battery temperature device-tree properties
>   power: supply: smb347-charger: Replace mutex with IRQ disable/enable
> 
>  .../bindings/power/supply/battery.yaml        |  24 +
>  .../power/supply/summit,smb347-charger.yaml   | 152 +++++
>  .../boot/dts/qcom-apq8064-asus-nexus7-flo.dts |  24 +
>  .../tegra30-asus-nexus7-grouper-common.dtsi   |  24 +-
>  drivers/power/supply/Kconfig                  |   6 +-
>  drivers/power/supply/power_supply_core.c      |  19 +
>  drivers/power/supply/smb347-charger.c         | 565 +++++++++---------
>  .../dt-bindings/power/summit,smb347-charger.h |  19 +
>  include/linux/power_supply.h                  |   6 +
>  9 files changed, 568 insertions(+), 271 deletions(-)
>  create mode 100644 Documentation/devicetree/bindings/power/supply/summit,smb347-charger.yaml
>  create mode 100644 include/dt-bindings/power/summit,smb347-charger.h
> 
> -- 
> 2.27.0
>