mbox series

[GIT,PULL] pwm: Changes for v6.10-rc1

Message ID ea6vevhosh66ghu724gpsvawqq3zggvruhhjsvbmasskhevmsq@lircam7wky64
State Accepted
Headers show
Series [GIT,PULL] pwm: Changes for v6.10-rc1 | expand

Pull-request

https://git.kernel.org/pub/scm/linux/kernel/git/ukleinek/linux.git tags/pwm/for-6.10-rc1

Message

Uwe Kleine-König May 14, 2024, 7:52 a.m. UTC
Hello Linus,

the following changes since commit 190f1f46ede17ca0d7153ac115d6518ec1be2ba3:

  MAINTAINERS: Update Uwe's email address, drop SIOX maintenance (2024-04-26 08:20:14 +0200)

are available in the Git repository at:

  https://git.kernel.org/pub/scm/linux/kernel/git/ukleinek/linux.git tags/pwm/for-6.10-rc1

for you to fetch changes up to 4817118f257e49b043f3d80f021a327b7e1d796f:

  pwm: pca9685: Drop explicit initialization of struct i2c_device_id::driver_data to 0 (2024-05-10 07:30:27 +0200)

----------------------------------------------------------------
pwm: Changes for v6.10-rc1

Apart for the normal updates for dt bindings, cleanups and support for
new device variants to existing drivers this completes the conversion to
pwmchip_alloc() which was started in the v6.9 development cycle.

Using pwmchip_alloc() is a precondition to the character device support
which allows easier and faster access to PWM devices. However there are
some issues I want to clean up before including it in mainline, so this
isn't contained here despite it was in next for some time.

Thanks to Alexandre Mergnat, Binbin Zhou, Dmitry Rokosov, George Stark,
Jerome Brunet and Varshini Rajendran for their contributions. Further
thanks go to AngeloGioacchino Del Regno, Conor Dooley, David Lechner,
Fabrice Gasnier, Florian Fainelli, Guenter Roeck, Gustavo A. R. Silva,
Krzysztof Kozlowski and Rob Herring for valuable patch review.

----------------------------------------------------------------

This is based on v6.9-rc5 because commit 141a8502214d ("pwm: bcm2835:
Drop open coded variant of devm_clk_rate_exclusive_get()") made the
build bots unhappy without commit 7f1dd39aedfc ("clk: Provide
!COMMON_CLK dummy for devm_clk_rate_exclusive_get()").

There are two commits touching drivers/hwmon. The driver modified here
provides a pwm device and it is converted to pwmchip_alloc() before
making pwmchip_alloc() mandatory. These two patches have Guenter's
blessing.

Please pull this for v6.10-rc1.

Thanks
Uwe

Alexandre Mergnat (1):
      dt-bindings: pwm: mediatek,pwm-disp: add compatible for mt8365 SoC

Binbin Zhou (6):
      dt-bindings: pwm: bcm2835: Do not require pwm-cells twice
      dt-bindings: pwm: google,cros-ec: Do not require pwm-cells twice
      dt-bindings: pwm: marvell,pxa: Do not require pwm-cells twice
      dt-bindings: pwm: mediatek,mt2712: Do not require pwm-cells twice
      dt-bindings: pwm: mediatek,pwm-disp: Do not require pwm-cells twice
      dt-bindings: pwm: snps,dw-apb-timers: Do not require pwm-cells twice

George Stark (3):
      pwm: meson: Drop unneeded check in .get_state()
      pwm: meson: Add check for error from clk_round_rate()
      pwm: meson: Use mul_u64_u64_div_u64() for frequency calculating

Jerome Brunet (1):
      pwm: meson: Add generic compatible for meson8 to sm1

Uwe Kleine-König (22):
      hwmon: (aspeed-g6-pwm-tacho): Make use of pwmchip_parent() accessor
      hwmon: (aspeed-g6-pwm-tacho): Make use of devm_pwmchip_alloc() function
      pwm: Ensure that pwm_chips are allocated using pwmchip_alloc()
      pwm: sti: Simplify probe function using devm functions
      pwm: sti: Improve error reporting using dev_err_probe()
      pwm: sti: Drop member from driver data that only carries a constant
      pwm: sti: Maintain all per-chip driver data in a single struct
      pwm: sti: Use devm_kcalloc() instead of calculating the size for devm_kzalloc()
      pwm: sti: Prefer local variable over pointer dereference
      pwm: Give some sysfs related variables and functions better names
      pwm: Move contents of sysfs.c into core.c
      pwm: Ensure a struct pwm has the same lifetime as its pwm_chip
      pwm: Add a struct device to struct pwm_chip
      pwm: Don't check pointer for being non-NULL after use
      pwm: Make pwmchip_[sg]et_drvdata() a wrapper around dev_set_drvdata()
      pwm: stm32: Add error messages in .probe()'s error paths
      pwm: stm32: Improve precision of calculation in .apply()
      pwm: stm32: Fix for settings using period > UINT32_MAX
      pwm: stm32: Calculate prescaler with a division instead of a loop
      pwm: bcm2835: Introduce a local variable for &pdev->dev
      pwm: bcm2835: Drop open coded variant of devm_clk_rate_exclusive_get()
      pwm: pca9685: Drop explicit initialization of struct i2c_device_id::driver_data to 0

Varshini Rajendran (1):
      dt-bindings: pwm: at91: Add sam9x7 compatible strings list

 .../devicetree/bindings/pwm/atmel,at91sam-pwm.yaml |   3 +
 .../bindings/pwm/google,cros-ec-pwm.yaml           |   1 -
 .../devicetree/bindings/pwm/marvell,pxa-pwm.yaml   |   1 -
 .../bindings/pwm/mediatek,mt2712-pwm.yaml          |   1 -
 .../devicetree/bindings/pwm/mediatek,pwm-disp.yaml |   2 +-
 .../devicetree/bindings/pwm/pwm-bcm2835.yaml       |   1 -
 .../bindings/pwm/snps,dw-apb-timers-pwm2.yaml      |   1 -
 drivers/hwmon/aspeed-g6-pwm-tach.c                 |  21 +-
 drivers/pwm/Kconfig                                |   4 -
 drivers/pwm/Makefile                               |   1 -
 drivers/pwm/core.c                                 | 606 +++++++++++++++++++--
 drivers/pwm/pwm-bcm2835.c                          |  30 +-
 drivers/pwm/pwm-meson.c                            | 213 +++++---
 drivers/pwm/pwm-pca9685.c                          |   4 +-
 drivers/pwm/pwm-sti.c                              | 161 ++----
 drivers/pwm/pwm-stm32.c                            |  60 +-
 drivers/pwm/sysfs.c                                | 545 ------------------
 include/linux/pwm.h                                |  36 +-
 18 files changed, 832 insertions(+), 859 deletions(-)
 delete mode 100644 drivers/pwm/sysfs.c

Comments

pr-tracker-bot@kernel.org May 14, 2024, 10:16 p.m. UTC | #1
The pull request you sent on Tue, 14 May 2024 09:52:22 +0200:

> https://git.kernel.org/pub/scm/linux/kernel/git/ukleinek/linux.git tags/pwm/for-6.10-rc1

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/9d81e2d5a9e4befa119e40742a60c366e15d76ce

Thank you!