mbox series

[v2,0/2] pwm: pwm-gpio: New driver

Message ID 20201211170432.6113-1-nicola.dilieto@gmail.com
Headers show
Series pwm: pwm-gpio: New driver | expand

Message

Nicola Di Lieto Dec. 11, 2020, 5:04 p.m. UTC
New version, implementing Uwe's suggestions.

Changes in v2:
- Synchronize pwm variables to ensure consistency
- Remove clamping of pwm period and duty cycle
- Rename "to_pwm_gpio" as "pwm_gpio_from_chip"
- Initialize pwm_gpio->chip.base to -1
- Swap order of hrtimer_cancel and pwmchip_remove
- Increase #pwm-cells to 3

Nicola Di Lieto (2):
  pwm: pwm-gpio: New driver
  pwm: pwm-gpio: Add DT bindings

 .../devicetree/bindings/pwm/pwm-gpio.yaml          |  42 +++++
 MAINTAINERS                                        |   7 +
 drivers/pwm/Kconfig                                |  10 ++
 drivers/pwm/Makefile                               |   1 +
 drivers/pwm/pwm-gpio.c                             | 188 +++++++++++++++++++++
 5 files changed, 248 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/pwm/pwm-gpio.yaml
 create mode 100644 drivers/pwm/pwm-gpio.c