mbox series

[v4,00/16] Cleanup IRQ type definitions

Message ID 20231122060406.14695-1-dlemoal@kernel.org
Headers show
Series Cleanup IRQ type definitions | expand

Message

Damien Le Moal Nov. 22, 2023, 6:03 a.m. UTC
The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
Bjorn (hence the patch authorship is given to him). The second patch
removes the redundant IRQ type definitions PCI_EPC_IRQ_XXX and replace
these with a direct use of the PCI_IRQ_XXX definitions. These 2 patches
have been sent and reviewed previously but were never applied. Hence the
resend with this new series version.

The remaining patches rename functions and correct comments etc to refer
to "intx" instead of "legacy".

Changes from v3:
 - Added tags to patch 2
 - Added patch 3 to 16

Changes from v2:
 - Modified PCI_IRQ_LEGACY comment in patch 1 as suggested by Serge
 - Fixed forgotten rename in patch 2

Changes from v1:
 - Updated first patch Signed-of tag and commit message as suggested by
   Bjorn.
 - Added review tags.

Bjorn Helgaas (1):
  PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX

Damien Le Moal (15):
  PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
  PCI: endpoint: Use INTX instead of legacy
  PCI: endpoint: Rename LEGACY to INTX in test function driver
  misc: pci_endpoint_test: Use INTX instead of LEGACY
  PCI: portdrv: Use PCI_IRQ_INTX
  PCI: dra7xx: Rename dra7xx_pcie_raise_legacy_irq()
  PCI: cadence: Use INTX instead of legacy
  PCI: dwc: Rename dw_pcie_ep_raise_legacy_irq()
  PCI: keystone: Use INTX instead of legacy
  PCI: dw-rockchip: Rename rockchip_pcie_legacy_int_handler()
  PCI: tegra194: Use INTX instead of legacy
  PCI: uniphier: Use INTX instead of legacy
  PCI: rockchip-ep: Use INTX instead of legacy
  PCI: rockchip-host: Rename rockchip_pcie_legacy_int_handler()
  PCI: xilinx-nwl: Use INTX instead of legacy

 drivers/misc/pci_endpoint_test.c              | 30 +++----
 .../pci/controller/cadence/pcie-cadence-ep.c  | 19 ++--
 drivers/pci/controller/cadence/pcie-cadence.h | 12 +--
 drivers/pci/controller/dwc/pci-dra7xx.c       | 10 +--
 drivers/pci/controller/dwc/pci-imx6.c         | 11 ++-
 drivers/pci/controller/dwc/pci-keystone.c     | 86 +++++++++----------
 .../pci/controller/dwc/pci-layerscape-ep.c    | 10 +--
 drivers/pci/controller/dwc/pcie-artpec6.c     |  8 +-
 .../pci/controller/dwc/pcie-designware-ep.c   |  8 +-
 .../pci/controller/dwc/pcie-designware-plat.c | 11 ++-
 drivers/pci/controller/dwc/pcie-designware.h  |  6 +-
 drivers/pci/controller/dwc/pcie-dw-rockchip.c |  4 +-
 drivers/pci/controller/dwc/pcie-keembay.c     | 13 ++-
 drivers/pci/controller/dwc/pcie-qcom-ep.c     |  8 +-
 drivers/pci/controller/dwc/pcie-rcar-gen4.c   |  9 +-
 drivers/pci/controller/dwc/pcie-tegra194.c    | 19 ++--
 drivers/pci/controller/dwc/pcie-uniphier-ep.c | 11 ++-
 drivers/pci/controller/dwc/pcie-uniphier.c    | 12 +--
 drivers/pci/controller/pcie-rcar-ep.c         |  7 +-
 drivers/pci/controller/pcie-rockchip-ep.c     | 23 +++--
 drivers/pci/controller/pcie-rockchip-host.c   |  4 +-
 drivers/pci/controller/pcie-xilinx-nwl.c      | 52 +++++------
 drivers/pci/endpoint/functions/pci-epf-mhi.c  |  2 +-
 drivers/pci/endpoint/functions/pci-epf-ntb.c  |  4 +-
 drivers/pci/endpoint/functions/pci-epf-test.c | 14 +--
 drivers/pci/endpoint/functions/pci-epf-vntb.c |  7 +-
 drivers/pci/endpoint/pci-epc-core.c           |  6 +-
 drivers/pci/pcie/portdrv.c                    |  8 +-
 include/linux/pci-epc.h                       | 11 +--
 include/linux/pci.h                           |  4 +-
 include/uapi/linux/pcitest.h                  |  3 +-
 31 files changed, 206 insertions(+), 226 deletions(-)

Comments

Damien Le Moal Nov. 30, 2023, 8:30 a.m. UTC | #1
On 11/22/23 15:03, Damien Le Moal wrote:
> The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
> Bjorn (hence the patch authorship is given to him). The second patch
> removes the redundant IRQ type definitions PCI_EPC_IRQ_XXX and replace
> these with a direct use of the PCI_IRQ_XXX definitions. These 2 patches
> have been sent and reviewed previously but were never applied. Hence the
> resend with this new series version.
> 
> The remaining patches rename functions and correct comments etc to refer
> to "intx" instead of "legacy".

Ping ?

Note that patch 6 can be dropped and we can do that sort of rename done in that
patch on 6.8-rc1 once the series is applied.

> 
> Changes from v3:
>  - Added tags to patch 2
>  - Added patch 3 to 16
> 
> Changes from v2:
>  - Modified PCI_IRQ_LEGACY comment in patch 1 as suggested by Serge
>  - Fixed forgotten rename in patch 2
> 
> Changes from v1:
>  - Updated first patch Signed-of tag and commit message as suggested by
>    Bjorn.
>  - Added review tags.
> 
> Bjorn Helgaas (1):
>   PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX
> 
> Damien Le Moal (15):
>   PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
>   PCI: endpoint: Use INTX instead of legacy
>   PCI: endpoint: Rename LEGACY to INTX in test function driver
>   misc: pci_endpoint_test: Use INTX instead of LEGACY
>   PCI: portdrv: Use PCI_IRQ_INTX
>   PCI: dra7xx: Rename dra7xx_pcie_raise_legacy_irq()
>   PCI: cadence: Use INTX instead of legacy
>   PCI: dwc: Rename dw_pcie_ep_raise_legacy_irq()
>   PCI: keystone: Use INTX instead of legacy
>   PCI: dw-rockchip: Rename rockchip_pcie_legacy_int_handler()
>   PCI: tegra194: Use INTX instead of legacy
>   PCI: uniphier: Use INTX instead of legacy
>   PCI: rockchip-ep: Use INTX instead of legacy
>   PCI: rockchip-host: Rename rockchip_pcie_legacy_int_handler()
>   PCI: xilinx-nwl: Use INTX instead of legacy
> 
>  drivers/misc/pci_endpoint_test.c              | 30 +++----
>  .../pci/controller/cadence/pcie-cadence-ep.c  | 19 ++--
>  drivers/pci/controller/cadence/pcie-cadence.h | 12 +--
>  drivers/pci/controller/dwc/pci-dra7xx.c       | 10 +--
>  drivers/pci/controller/dwc/pci-imx6.c         | 11 ++-
>  drivers/pci/controller/dwc/pci-keystone.c     | 86 +++++++++----------
>  .../pci/controller/dwc/pci-layerscape-ep.c    | 10 +--
>  drivers/pci/controller/dwc/pcie-artpec6.c     |  8 +-
>  .../pci/controller/dwc/pcie-designware-ep.c   |  8 +-
>  .../pci/controller/dwc/pcie-designware-plat.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-designware.h  |  6 +-
>  drivers/pci/controller/dwc/pcie-dw-rockchip.c |  4 +-
>  drivers/pci/controller/dwc/pcie-keembay.c     | 13 ++-
>  drivers/pci/controller/dwc/pcie-qcom-ep.c     |  8 +-
>  drivers/pci/controller/dwc/pcie-rcar-gen4.c   |  9 +-
>  drivers/pci/controller/dwc/pcie-tegra194.c    | 19 ++--
>  drivers/pci/controller/dwc/pcie-uniphier-ep.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-uniphier.c    | 12 +--
>  drivers/pci/controller/pcie-rcar-ep.c         |  7 +-
>  drivers/pci/controller/pcie-rockchip-ep.c     | 23 +++--
>  drivers/pci/controller/pcie-rockchip-host.c   |  4 +-
>  drivers/pci/controller/pcie-xilinx-nwl.c      | 52 +++++------
>  drivers/pci/endpoint/functions/pci-epf-mhi.c  |  2 +-
>  drivers/pci/endpoint/functions/pci-epf-ntb.c  |  4 +-
>  drivers/pci/endpoint/functions/pci-epf-test.c | 14 +--
>  drivers/pci/endpoint/functions/pci-epf-vntb.c |  7 +-
>  drivers/pci/endpoint/pci-epc-core.c           |  6 +-
>  drivers/pci/pcie/portdrv.c                    |  8 +-
>  include/linux/pci-epc.h                       | 11 +--
>  include/linux/pci.h                           |  4 +-
>  include/uapi/linux/pcitest.h                  |  3 +-
>  31 files changed, 206 insertions(+), 226 deletions(-)
>
Manivannan Sadhasivam Nov. 30, 2023, 8:40 a.m. UTC | #2
On Wed, Nov 22, 2023 at 03:03:50PM +0900, Damien Le Moal wrote:
> The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
> Bjorn (hence the patch authorship is given to him). The second patch
> removes the redundant IRQ type definitions PCI_EPC_IRQ_XXX and replace
> these with a direct use of the PCI_IRQ_XXX definitions. These 2 patches
> have been sent and reviewed previously but were never applied. Hence the
> resend with this new series version.
> 
> The remaining patches rename functions and correct comments etc to refer
> to "intx" instead of "legacy".
> 
> Changes from v3:
>  - Added tags to patch 2
>  - Added patch 3 to 16
> 
> Changes from v2:
>  - Modified PCI_IRQ_LEGACY comment in patch 1 as suggested by Serge
>  - Fixed forgotten rename in patch 2
> 
> Changes from v1:
>  - Updated first patch Signed-of tag and commit message as suggested by
>    Bjorn.
>  - Added review tags.
> 
> Bjorn Helgaas (1):
>   PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX
> 
> Damien Le Moal (15):
>   PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
>   PCI: endpoint: Use INTX instead of legacy
>   PCI: endpoint: Rename LEGACY to INTX in test function driver
>   misc: pci_endpoint_test: Use INTX instead of LEGACY
>   PCI: portdrv: Use PCI_IRQ_INTX
>   PCI: dra7xx: Rename dra7xx_pcie_raise_legacy_irq()
>   PCI: cadence: Use INTX instead of legacy
>   PCI: dwc: Rename dw_pcie_ep_raise_legacy_irq()
>   PCI: keystone: Use INTX instead of legacy
>   PCI: dw-rockchip: Rename rockchip_pcie_legacy_int_handler()
>   PCI: tegra194: Use INTX instead of legacy
>   PCI: uniphier: Use INTX instead of legacy
>   PCI: rockchip-ep: Use INTX instead of legacy
>   PCI: rockchip-host: Rename rockchip_pcie_legacy_int_handler()
>   PCI: xilinx-nwl: Use INTX instead of legacy
> 

For the series:

Acked-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>

- Mani

>  drivers/misc/pci_endpoint_test.c              | 30 +++----
>  .../pci/controller/cadence/pcie-cadence-ep.c  | 19 ++--
>  drivers/pci/controller/cadence/pcie-cadence.h | 12 +--
>  drivers/pci/controller/dwc/pci-dra7xx.c       | 10 +--
>  drivers/pci/controller/dwc/pci-imx6.c         | 11 ++-
>  drivers/pci/controller/dwc/pci-keystone.c     | 86 +++++++++----------
>  .../pci/controller/dwc/pci-layerscape-ep.c    | 10 +--
>  drivers/pci/controller/dwc/pcie-artpec6.c     |  8 +-
>  .../pci/controller/dwc/pcie-designware-ep.c   |  8 +-
>  .../pci/controller/dwc/pcie-designware-plat.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-designware.h  |  6 +-
>  drivers/pci/controller/dwc/pcie-dw-rockchip.c |  4 +-
>  drivers/pci/controller/dwc/pcie-keembay.c     | 13 ++-
>  drivers/pci/controller/dwc/pcie-qcom-ep.c     |  8 +-
>  drivers/pci/controller/dwc/pcie-rcar-gen4.c   |  9 +-
>  drivers/pci/controller/dwc/pcie-tegra194.c    | 19 ++--
>  drivers/pci/controller/dwc/pcie-uniphier-ep.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-uniphier.c    | 12 +--
>  drivers/pci/controller/pcie-rcar-ep.c         |  7 +-
>  drivers/pci/controller/pcie-rockchip-ep.c     | 23 +++--
>  drivers/pci/controller/pcie-rockchip-host.c   |  4 +-
>  drivers/pci/controller/pcie-xilinx-nwl.c      | 52 +++++------
>  drivers/pci/endpoint/functions/pci-epf-mhi.c  |  2 +-
>  drivers/pci/endpoint/functions/pci-epf-ntb.c  |  4 +-
>  drivers/pci/endpoint/functions/pci-epf-test.c | 14 +--
>  drivers/pci/endpoint/functions/pci-epf-vntb.c |  7 +-
>  drivers/pci/endpoint/pci-epc-core.c           |  6 +-
>  drivers/pci/pcie/portdrv.c                    |  8 +-
>  include/linux/pci-epc.h                       | 11 +--
>  include/linux/pci.h                           |  4 +-
>  include/uapi/linux/pcitest.h                  |  3 +-
>  31 files changed, 206 insertions(+), 226 deletions(-)
> 
> -- 
> 2.42.0
>
Bjorn Helgaas Dec. 1, 2023, 12:52 a.m. UTC | #3
On Wed, Nov 22, 2023 at 03:03:50PM +0900, Damien Le Moal wrote:
> The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
> Bjorn (hence the patch authorship is given to him). The second patch
> removes the redundant IRQ type definitions PCI_EPC_IRQ_XXX and replace
> these with a direct use of the PCI_IRQ_XXX definitions. These 2 patches
> have been sent and reviewed previously but were never applied. Hence the
> resend with this new series version.
> 
> The remaining patches rename functions and correct comments etc to refer
> to "intx" instead of "legacy".
> 
> Changes from v3:
>  - Added tags to patch 2
>  - Added patch 3 to 16
> 
> Changes from v2:
>  - Modified PCI_IRQ_LEGACY comment in patch 1 as suggested by Serge
>  - Fixed forgotten rename in patch 2
> 
> Changes from v1:
>  - Updated first patch Signed-of tag and commit message as suggested by
>    Bjorn.
>  - Added review tags.
> 
> Bjorn Helgaas (1):
>   PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX
> 
> Damien Le Moal (15):
>   PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
>   PCI: endpoint: Use INTX instead of legacy
>   PCI: endpoint: Rename LEGACY to INTX in test function driver
>   misc: pci_endpoint_test: Use INTX instead of LEGACY
>   PCI: portdrv: Use PCI_IRQ_INTX
>   PCI: dra7xx: Rename dra7xx_pcie_raise_legacy_irq()
>   PCI: cadence: Use INTX instead of legacy
>   PCI: dwc: Rename dw_pcie_ep_raise_legacy_irq()
>   PCI: keystone: Use INTX instead of legacy
>   PCI: dw-rockchip: Rename rockchip_pcie_legacy_int_handler()
>   PCI: tegra194: Use INTX instead of legacy
>   PCI: uniphier: Use INTX instead of legacy
>   PCI: rockchip-ep: Use INTX instead of legacy
>   PCI: rockchip-host: Rename rockchip_pcie_legacy_int_handler()
>   PCI: xilinx-nwl: Use INTX instead of legacy
> 
>  drivers/misc/pci_endpoint_test.c              | 30 +++----
>  .../pci/controller/cadence/pcie-cadence-ep.c  | 19 ++--
>  drivers/pci/controller/cadence/pcie-cadence.h | 12 +--
>  drivers/pci/controller/dwc/pci-dra7xx.c       | 10 +--
>  drivers/pci/controller/dwc/pci-imx6.c         | 11 ++-
>  drivers/pci/controller/dwc/pci-keystone.c     | 86 +++++++++----------
>  .../pci/controller/dwc/pci-layerscape-ep.c    | 10 +--
>  drivers/pci/controller/dwc/pcie-artpec6.c     |  8 +-
>  .../pci/controller/dwc/pcie-designware-ep.c   |  8 +-
>  .../pci/controller/dwc/pcie-designware-plat.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-designware.h  |  6 +-
>  drivers/pci/controller/dwc/pcie-dw-rockchip.c |  4 +-
>  drivers/pci/controller/dwc/pcie-keembay.c     | 13 ++-
>  drivers/pci/controller/dwc/pcie-qcom-ep.c     |  8 +-
>  drivers/pci/controller/dwc/pcie-rcar-gen4.c   |  9 +-
>  drivers/pci/controller/dwc/pcie-tegra194.c    | 19 ++--
>  drivers/pci/controller/dwc/pcie-uniphier-ep.c | 11 ++-
>  drivers/pci/controller/dwc/pcie-uniphier.c    | 12 +--
>  drivers/pci/controller/pcie-rcar-ep.c         |  7 +-
>  drivers/pci/controller/pcie-rockchip-ep.c     | 23 +++--
>  drivers/pci/controller/pcie-rockchip-host.c   |  4 +-
>  drivers/pci/controller/pcie-xilinx-nwl.c      | 52 +++++------
>  drivers/pci/endpoint/functions/pci-epf-mhi.c  |  2 +-
>  drivers/pci/endpoint/functions/pci-epf-ntb.c  |  4 +-
>  drivers/pci/endpoint/functions/pci-epf-test.c | 14 +--
>  drivers/pci/endpoint/functions/pci-epf-vntb.c |  7 +-
>  drivers/pci/endpoint/pci-epc-core.c           |  6 +-
>  drivers/pci/pcie/portdrv.c                    |  8 +-
>  include/linux/pci-epc.h                       | 11 +--
>  include/linux/pci.h                           |  4 +-
>  include/uapi/linux/pcitest.h                  |  3 +-
>  31 files changed, 206 insertions(+), 226 deletions(-)

Looks good to me, Damien.  Thanks for doing all this work.  I think
Lorenzo or Krzysztof will pick this up, and we'll get it into -next.

Bjorn
Damien Le Moal Dec. 18, 2023, 10:10 a.m. UTC | #4
On 2023/12/01 9:52, Bjorn Helgaas wrote:
> Looks good to me, Damien.  Thanks for doing all this work.  I think
> Lorenzo or Krzysztof will pick this up, and we'll get it into -next.

Ping ? I do not see this series queued anywhere. Did I miss it ?
Lorenzo Pieralisi Dec. 18, 2023, 3:54 p.m. UTC | #5
On Wed, 22 Nov 2023 15:03:50 +0900, Damien Le Moal wrote:
> The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
> Bjorn (hence the patch authorship is given to him). The second patch
> removes the redundant IRQ type definitions PCI_EPC_IRQ_XXX and replace
> these with a direct use of the PCI_IRQ_XXX definitions. These 2 patches
> have been sent and reviewed previously but were never applied. Hence the
> resend with this new series version.
> 
> [...]

Applied to irq-clean-up, thanks! It might take a while before
we merge it into -next but it is targeting v6.8 anyway.

[01/16] PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX
        https://git.kernel.org/pci/pci/c/58ff9c5acb4a
[02/16] PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
        https://git.kernel.org/pci/pci/c/74955cb8ccc3
[03/16] PCI: endpoint: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/8a608dac4bf6
[04/16] PCI: endpoint: Rename LEGACY to INTX in test function driver
        https://git.kernel.org/pci/pci/c/5b0fbadc0f87
[05/16] misc: pci_endpoint_test: Use INTX instead of LEGACY
        https://git.kernel.org/pci/pci/c/acd288666979
[06/16] PCI: portdrv: Use PCI_IRQ_INTX
        https://git.kernel.org/pci/pci/c/0e9149d9b864
[07/16] PCI: dra7xx: Rename dra7xx_pcie_raise_legacy_irq()
        https://git.kernel.org/pci/pci/c/a963ce0a542c
[08/16] PCI: cadence: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/29e3e6620ab1
[09/16] PCI: dwc: Rename dw_pcie_ep_raise_legacy_irq()
        https://git.kernel.org/pci/pci/c/6847fc7fa27d
[10/16] PCI: keystone: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/45b27ac543c0
[11/16] PCI: dw-rockchip: Rename rockchip_pcie_legacy_int_handler()
        https://git.kernel.org/pci/pci/c/50bdb9ef1dd1
[12/16] PCI: tegra194: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/08fc17974dec
[13/16] PCI: uniphier: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/b0908aed6eca
[14/16] PCI: rockchip-ep: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/8072efc6bbe1
[15/16] PCI: rockchip-host: Rename rockchip_pcie_legacy_int_handler()
        https://git.kernel.org/pci/pci/c/a00e643ea9ed
[16/16] PCI: xilinx-nwl: Use INTX instead of legacy
        https://git.kernel.org/pci/pci/c/07e681ce7bdb

Thanks,
Lorenzo