diff mbox series

[1/2] mtd: rawnand: Remove of_get_nand_on_flash_bbt() wrapper

Message ID 20220106131610.225661-1-tudor.ambarus@microchip.com
State Accepted
Delegated to: Miquel Raynal
Headers show
Series [1/2] mtd: rawnand: Remove of_get_nand_on_flash_bbt() wrapper | expand

Commit Message

Tudor Ambarus Jan. 6, 2022, 1:16 p.m. UTC
Remove the wrapper as it hides for no reason what we really want: find an
of_property. Removing the wrapper makes the code easier to read.

Signed-off-by: Tudor Ambarus <tudor.ambarus@microchip.com>
---
 drivers/mtd/nand/raw/nand_base.c | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

Comments

Miquel Raynal Jan. 23, 2022, 3:43 p.m. UTC | #1
Hi Tudor,

tudor.ambarus@microchip.com wrote on Thu, 6 Jan 2022 15:16:09 +0200:

> Remove the wrapper as it hides for no reason what we really want: find an
> of_property. Removing the wrapper makes the code easier to read.
> 
> Signed-off-by: Tudor Ambarus <tudor.ambarus@microchip.com>

Series applies to nand/next.

Thanks,
Miquèl
diff mbox series

Patch

diff --git a/drivers/mtd/nand/raw/nand_base.c b/drivers/mtd/nand/raw/nand_base.c
index 113a2e9f43b1..b8e7f1aae032 100644
--- a/drivers/mtd/nand/raw/nand_base.c
+++ b/drivers/mtd/nand/raw/nand_base.c
@@ -5287,11 +5287,6 @@  static int of_get_nand_bus_width(struct device_node *np)
 	}
 }
 
-static bool of_get_nand_on_flash_bbt(struct device_node *np)
-{
-	return of_property_read_bool(np, "nand-on-flash-bbt");
-}
-
 static int of_get_nand_secure_regions(struct nand_chip *chip)
 {
 	struct device_node *dn = nand_get_flash_node(chip);
@@ -5375,7 +5370,7 @@  static int rawnand_dt_init(struct nand_chip *chip)
 	if (of_property_read_bool(dn, "nand-is-boot-medium"))
 		chip->options |= NAND_IS_BOOT_MEDIUM;
 
-	if (of_get_nand_on_flash_bbt(dn))
+	if (of_property_read_bool(dn, "nand-on-flash-bbt"))
 		chip->bbt_options |= NAND_BBT_USE_FLASH;
 
 	of_get_nand_ecc_user_config(nand);