mbox series

[GIT,PULL] mtd: nand: Changes for 5.14

Message ID 20210623120125.1f02792e@xps13
State Not Applicable
Headers show
Series [GIT,PULL] mtd: nand: Changes for 5.14 | expand

Pull-request

git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/nand/for-5.14

Message

Miquel Raynal June 23, 2021, 10:01 a.m. UTC
Hi Richard,

This is the NAND PR for 5.14.

This PR includes patches from the memory bus tree after merge of an
immutable branch provided by Krzysztof Kozlowski; I hope this is the
right way to handle such situation.

There is also a known conflict with the devicetree tree which is trivial
to resolve:

	9b358af7c818 ("dt-bindings: mux: Convert mux controller
	bindings to schema") -> Updates all the files referencing the mux-controller.txt
	binding as the file name changed (s/txt/yaml/).

	6947ad674944 ("dt-bindings: mtd: Convert ti, am654-hbmc.txt to
	YAML schema")
	-> Converts one of these files to yaml, the reference to
	mux-controller.{txt,yaml} being dropped during the conversion.

It is then only needed to just take the ti,am654-hbmc yaml conversion
as it is.

Thanks,
Miquèl


The following changes since commit 6efb943b8616ec53a5e444193dccf1af9ad627b5:

  Linux 5.13-rc1 (2021-05-09 14:17:44 -0700)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/nand/for-5.14

for you to fetch changes up to c06dd49fd59a0abd6fa3d9fc5f6eb1776af4e5e4:

  mtd: rawnand: omap: Add larger page NAND chips support (2021-06-18 09:45:21 +0200)

----------------------------------------------------------------
Raw NAND core:
* Allow SDR timings to be nacked
* Bring support for NV-DDR timings which involved a number of small
  preparation changes to bring new helpers, properly introduce NV-DDR
  structures, fill them, differenciate them and pick the best timing set.
* Add the necessary infrastructure to parse the new gpio-cs property
  which aims at enlarging the number of available CS when a hardware
  controller is too constrained.
* Update dead URL
* Silence static checker warning in nand_setup_interface()
* BBT:
  - Fix corner case in bad block table handling
* onfi:
  - Use more recent ONFI specification wording
  - Use the BIT() macro when possible

Raw NAND controller drivers:
* Atmel:
  - Ensure the data interface is supported.
* Arasan:
  - Finer grain NV-DDR configuration
  - Rename the data interface register
  - Use the right DMA mask
  - Leverage additional GPIO CS
  - Ensure proper configuration for the asserted target
  - Add support for the NV-DDR interface
  - Fix a macro parameter
* brcmnand:
  - Convert bindings to json-schema
* OMAP:
  - Various fixes and style improvements
  - Add larger page NAND chips support
* PL35X:
  - New driver
* QCOM:
  - Avoid writing to obsolete register
  - Delete an unneeded bool conversion
  - Allow override of partition parser
* Marvell:
  - Minor documentation correction
  - Add missing clk_disable_unprepare() on error in marvell_nfc_resume()
* R852:
  - Use DEVICE_ATTR_RO() helper macro
* MTK:
  - Remove redundant dev_err call in mtk_ecc_probe()
* HISI504:
  - Remove redundant dev_err call in probe

SPI-NAND core:
* Light reorganisation for the introduction of a core resume handler
* Fix double counting of ECC stats

SPI-NAND manufacturer drivers:
* Macronix:
  - Add support for serial NAND flash

----------------------------------------------------------------
Baruch Siach (1):
      mtd: rawnand: qcom: allow override of partition parser

Dan Carpenter (1):
      mtd: rawnand: silence static checker warning in nand_setup_interface()

Doyle, Patrick (1):
      mtd: nand: bbt: Fix corner case in bad block table handling

Jaime Liao (1):
      mtd: spinand: macronix: Add support for serial NAND flash

Md Sadre Alam (1):
      mtd: rawnand: qcom: avoid writing to obsolete register

Miquel Raynal (55):
      mtd: rawnand: Add a helper to clarify the interface configuration
      mtd: rawnand: arasan: Check the proposed data interface is supported
      mtd: rawnand: atmel: Check the proposed data interface is supported
      mtd: rawnand: onfi: Use the BIT() macro when possible
      mtd: rawnand: Update dead URL
      mtd: rawnand: Use more recent ONFI specification wording
      mtd: rawnand: Clarify the NV-DDR entries in the ONFI structure
      mtd: rawnand: Add NV-DDR timings
      mtd: rawnand: Retrieve NV-DDR timing modes from the ONFI parameter page
      mtd: rawnand: Add an indirection on onfi_fill_interface_config()
      mtd: rawnand: Add onfi_fill_nvddr_interface_config() helper
      mtd: rawnand: Avoid accessing NV-DDR timings from legacy code
      mtd: rawnand: Access SDR and NV-DDR timings through a common macro
      mtd: rawnand: Handle the double bytes in NV-DDR mode
      mtd: rawnand: Add a helper to find the closest ONFI NV-DDR mode
      mtd: rawnand: Support enabling NV-DDR through SET_FEATURES
      mtd: rawnand: Allow SDR timings to be nacked
      mtd: rawnand: Choose the best timings, NV-DDR included
      MAINTAINERS: Add myself as co-maintainer of the Arasan NAND controller driver
      mtd: rawnand: arasan: Fix a macro parameter
      mtd: rawnand: arasan: Workaround a misbehaving prog type with NV-DDR
      mtd: rawnand: arasan: Support NV-DDR interface
      dt-binding: mtd: nand: Document the cs-gpios property
      mtd: rawnand: Move struct gpio_desc declaration to the top
      mtd: rawnand: Add a helper to parse the gpio-cs DT property
      mtd: rawnand: arasan: Ensure proper configuration for the asserted target
      mtd: rawnand: arasan: Leverage additional GPIO CS
      dt-binding: memory: pl353-smc: Rephrase the binding
      dt-binding: memory: pl353-smc: Document the range property
      dt-binding: memory: pl353-smc: Drop the partitioning section
      dt-binding: memory: pl353-smc: Describe the child reg property
      dt-binding: memory: pl353-smc: Fix the example syntax and style
      dt-binding: memory: pl353-smc: Drop unsupported nodes from the example
      dt-binding: memory: pl353-smc: Fix the NAND controller node in the example
      memory: pl353-smc: Fix style
      memory: pl353-smc: Rename goto labels
      memory: pl353-smc: Let lower level controller drivers handle inits
      memory: pl353-smc: Avoid useless acronyms in descriptions
      memory: pl353-smc: Declare variables following a reverse christmas tree order
      MAINTAINERS: Add PL353 SMC entry
      dt-binding: memory: pl353-smc: Convert to yaml
      Merge tag 'memory-controller-drv-pl353-5.14' into nand/next
      mtd: spinand: Fix double counting of ECC stats
      mtd: rawnand: arasan: Use the right DMA mask
      mtd: rawnand: onfi: Fix endianness when reading NV-DDR values
      mtd: rawnand: arasan: Rename the data interface register
      mtd: rawnand: arasan: Finer grain NV-DDR configuration
      MAINTAINERS: Add PL353 NAND controller entry
      dt-bindings: mtd: pl353-nand: Describe this hardware controller
      mtd: rawnand: pl353: Add support for the ARM PL353 SMC NAND controller
      mtd: rawnand: omap: Aggregate the HW configuration of the ELM
      mtd: rawnand: omap: Rename a macro
      mtd: rawnand: omap: Check return values
      mtd: rawnand: omap: Various style fixes
      mtd: rawnand: omap: Add larger page NAND chips support

Patrice Chotard (3):
      mtd: spinand: add spinand_read_cfg() helper
      mtd: spinand: Add spinand_init_flash() helper
      mtd: spinand: add SPI-NAND MTD resume handler

Rafał Miłecki (1):
      dt-bindings: mtd: brcmnand: convert to the json-schema

Souptick Joarder (1):
      mtd: rawnand: marvell: Minor documentation correction

Wei Li (1):
      mtd: rawnand: hisi504: Remove redundant dev_err call in probe

Yang Yingliang (1):
      mtd: rawnand: marvell: add missing clk_disable_unprepare() on error in marvell_nfc_resume()

Yu Kuai (1):
      mtd: rawnand: mtk: remove redundant dev_err call in mtk_ecc_probe()

Zhen Lei (2):
      mtd: rawnand: qcom: Delete an unneeded bool conversion
      mtd: rawnand: r852: use DEVICE_ATTR_RO() helper macro

 .../devicetree/bindings/memory-controllers/arm,pl353-smc.yaml      |  131 ++++
 Documentation/devicetree/bindings/memory-controllers/pl353-smc.txt |   47 --
 Documentation/devicetree/bindings/mtd/arm,pl353-nand-r2p1.yaml     |   53 ++
 Documentation/devicetree/bindings/mtd/brcm,brcmnand.txt            |  186 -----
 Documentation/devicetree/bindings/mtd/brcm,brcmnand.yaml           |  242 ++++++
 Documentation/devicetree/bindings/mtd/nand-controller.yaml         |   18 +-
 MAINTAINERS                                                        |   17 +
 drivers/memory/pl353-smc.c                                         |  314 +-------
 drivers/mtd/nand/bbt.c                                             |    2 +-
 drivers/mtd/nand/raw/Kconfig                                       |    8 +
 drivers/mtd/nand/raw/Makefile                                      |    1 +
 drivers/mtd/nand/raw/arasan-nand-controller.c                      |  341 ++++++--
 drivers/mtd/nand/raw/atmel/nand-controller.c                       |    7 +-
 drivers/mtd/nand/raw/cadence-nand-controller.c                     |    6 +-
 drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.h                         |    2 +-
 drivers/mtd/nand/raw/hisi504_nand.c                                |    4 +-
 drivers/mtd/nand/raw/internals.h                                   |    5 +
 drivers/mtd/nand/raw/marvell_nand.c                                |    6 +-
 drivers/mtd/nand/raw/mtk_ecc.c                                     |    4 +-
 drivers/mtd/nand/raw/nand_base.c                                   |  364 +++++++--
 drivers/mtd/nand/raw/nand_legacy.c                                 |    2 +-
 drivers/mtd/nand/raw/nand_onfi.c                                   |    5 +-
 drivers/mtd/nand/raw/nand_timings.c                                |  402 +++++++++-
 drivers/mtd/nand/raw/omap2.c                                       |  233 +++---
 drivers/mtd/nand/raw/omap_elm.c                                    |    2 +-
 drivers/mtd/nand/raw/pl35x-nand-controller.c                       | 1194 +++++++++++++++++++++++++++++
 drivers/mtd/nand/raw/qcom_nandc.c                                  |   23 +-
 drivers/mtd/nand/raw/r852.c                                        |    7 +-
 drivers/mtd/nand/spi/core.c                                        |  133 +++-
 drivers/mtd/nand/spi/macronix.c                                    |  112 +++
 include/linux/mtd/onfi.h                                           |   41 +-
 include/linux/mtd/rawnand.h                                        |  161 +++-
 include/linux/pl353-smc.h                                          |   30 -
 33 files changed, 3189 insertions(+), 914 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/memory-controllers/arm,pl353-smc.yaml
 delete mode 100644 Documentation/devicetree/bindings/memory-controllers/pl353-smc.txt
 create mode 100644 Documentation/devicetree/bindings/mtd/arm,pl353-nand-r2p1.yaml
 delete mode 100644 Documentation/devicetree/bindings/mtd/brcm,brcmnand.txt
 create mode 100644 Documentation/devicetree/bindings/mtd/brcm,brcmnand.yaml
 create mode 100644 drivers/mtd/nand/raw/pl35x-nand-controller.c
 delete mode 100644 include/linux/pl353-smc.h

Comments

Raghavendra, Vignesh June 25, 2021, 6:31 a.m. UTC | #1
Hi Miquel,

On 6/23/21 3:31 PM, Miquel Raynal wrote:
> Hi Richard,
> 
> This is the NAND PR for 5.14.
> 
> This PR includes patches from the memory bus tree after merge of an
> immutable branch provided by Krzysztof Kozlowski; I hope this is the
> right way to handle such situation.
> 
> There is also a known conflict with the devicetree tree which is trivial
> to resolve:
> 
> 	9b358af7c818 ("dt-bindings: mux: Convert mux controller
> 	bindings to schema") -> Updates all the files referencing the mux-controller.txt
> 	binding as the file name changed (s/txt/yaml/).


> 
> 	6947ad674944 ("dt-bindings: mtd: Convert ti, am654-hbmc.txt to
> 	YAML schema")
> 	-> Converts one of these files to yaml, the reference to
> 	mux-controller.{txt,yaml} being dropped during the conversion.
> 
> It is then only needed to just take the ti,am654-hbmc yaml conversion
> as it is.

This commit is in mtd/next and not in nand/next. So this PR should not
result in conflict on ti,am654-hbmc.txt.

[...]

Regards
Vignesh
Miquel Raynal June 25, 2021, 7:44 a.m. UTC | #2
Hi Vignesh,

Vignesh Raghavendra <vigneshr@ti.com> wrote on Fri, 25 Jun 2021
12:01:28 +0530:

> Hi Miquel,
> 
> On 6/23/21 3:31 PM, Miquel Raynal wrote:
> > Hi Richard,
> > 
> > This is the NAND PR for 5.14.
> > 
> > This PR includes patches from the memory bus tree after merge of an
> > immutable branch provided by Krzysztof Kozlowski; I hope this is the
> > right way to handle such situation.
> > 
> > There is also a known conflict with the devicetree tree which is trivial
> > to resolve:
> > 
> > 	9b358af7c818 ("dt-bindings: mux: Convert mux controller
> > 	bindings to schema") -> Updates all the files referencing the mux-controller.txt
> > 	binding as the file name changed (s/txt/yaml/).  
> 
> 
> > 
> > 	6947ad674944 ("dt-bindings: mtd: Convert ti, am654-hbmc.txt to
> > 	YAML schema")  
> > 	-> Converts one of these files to yaml, the reference to  
> > 	mux-controller.{txt,yaml} being dropped during the conversion.
> > 
> > It is then only needed to just take the ti,am654-hbmc yaml conversion
> > as it is.  
> 
> This commit is in mtd/next and not in nand/next. So this PR should not
> result in conflict on ti,am654-hbmc.txt.

Mmmh right, I mixed the two in my mind. At least the sentence is ready
for the final PR :)

Thanks,
Miquèl
Richard Weinberger June 30, 2021, 10:56 a.m. UTC | #3
On Wed, Jun 23, 2021 at 12:08 PM Miquel Raynal
<miquel.raynal@bootlin.com> wrote:
>
> Hi Richard,
>
> This is the NAND PR for 5.14.
>
> This PR includes patches from the memory bus tree after merge of an
> immutable branch provided by Krzysztof Kozlowski; I hope this is the
> right way to handle such situation.
>
> There is also a known conflict with the devicetree tree which is trivial
> to resolve:
>
>         9b358af7c818 ("dt-bindings: mux: Convert mux controller
>         bindings to schema") -> Updates all the files referencing the mux-controller.txt
>         binding as the file name changed (s/txt/yaml/).
>
>         6947ad674944 ("dt-bindings: mtd: Convert ti, am654-hbmc.txt to
>         YAML schema")
>         -> Converts one of these files to yaml, the reference to
>         mux-controller.{txt,yaml} being dropped during the conversion.
>
> It is then only needed to just take the ti,am654-hbmc yaml conversion
> as it is.
>
> Thanks,
> Miquèl
>
>
> The following changes since commit 6efb943b8616ec53a5e444193dccf1af9ad627b5:
>
>   Linux 5.13-rc1 (2021-05-09 14:17:44 -0700)
>
> are available in the Git repository at:
>
>   git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/nand/for-5.14
>
> for you to fetch changes up to c06dd49fd59a0abd6fa3d9fc5f6eb1776af4e5e4:
>
>   mtd: rawnand: omap: Add larger page NAND chips support (2021-06-18 09:45:21 +0200)

Pulled, thanks!