diff mbox series

[v1,3/3] i2c: designware: Fix indentation in the header

Message ID 20201208140337.33236-3-andriy.shevchenko@linux.intel.com
State Deferred
Headers show
Series [v1,1/3] i2c: designware: Switch header to use BIT() and GENMASK() | expand

Commit Message

Andy Shevchenko Dec. 8, 2020, 2:03 p.m. UTC
In couple of places the indentation makes harder to read the code.
Fix it to be sane.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 drivers/i2c/busses/i2c-designware-core.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Jarkko Nikula Dec. 9, 2020, 3:30 p.m. UTC | #1
On 12/8/20 4:03 PM, Andy Shevchenko wrote:
> In couple of places the indentation makes harder to read the code.
> Fix it to be sane.
> 
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
>   drivers/i2c/busses/i2c-designware-core.h | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/i2c/busses/i2c-designware-core.h b/drivers/i2c/busses/i2c-designware-core.h
> index 85307cfa7109..de00e62e8c7a 100644
> --- a/drivers/i2c/busses/i2c-designware-core.h
> +++ b/drivers/i2c/busses/i2c-designware-core.h
> @@ -115,7 +115,7 @@
>   
All 3 patches:

Acked-by: Jarkko Nikula <jarkko.nikula@linux.intel.com>
Wolfram Sang Dec. 9, 2020, 8:52 p.m. UTC | #2
> @@ -243,7 +243,7 @@ struct dw_i2c_dev {
>  	struct clk		*clk;
>  	struct clk		*pclk;
>  	struct reset_control	*rst;
> -	struct i2c_client		*slave;
> +	struct i2c_client	*slave;
>  	u32			(*get_clk_rate_khz) (struct dw_i2c_dev *dev);
>  	int			cmd_err;
>  	struct i2c_msg		*msgs;

What about using just a single space after the type? Won't need an
update ever again.
Andy Shevchenko Dec. 10, 2020, 9:46 a.m. UTC | #3
On Wed, Dec 09, 2020 at 09:52:42PM +0100, Wolfram Sang wrote:
> 
> > @@ -243,7 +243,7 @@ struct dw_i2c_dev {
> >  	struct clk		*clk;
> >  	struct clk		*pclk;
> >  	struct reset_control	*rst;
> > -	struct i2c_client		*slave;
> > +	struct i2c_client	*slave;
> >  	u32			(*get_clk_rate_khz) (struct dw_i2c_dev *dev);
> >  	int			cmd_err;
> >  	struct i2c_msg		*msgs;
> 
> What about using just a single space after the type? Won't need an
> update ever again.

Maybe, but this is really so minor patch, so if you are okay with other two
(that have more importance) drop this one.
diff mbox series

Patch

diff --git a/drivers/i2c/busses/i2c-designware-core.h b/drivers/i2c/busses/i2c-designware-core.h
index 85307cfa7109..de00e62e8c7a 100644
--- a/drivers/i2c/busses/i2c-designware-core.h
+++ b/drivers/i2c/busses/i2c-designware-core.h
@@ -115,7 +115,7 @@ 
 
 #define DW_IC_ERR_TX_ABRT	0x1
 
-#define DW_IC_TAR_10BITADDR_MASTER BIT(12)
+#define DW_IC_TAR_10BITADDR_MASTER	BIT(12)
 
 #define DW_IC_COMP_PARAM_1_SPEED_MODE_HIGH	(BIT(2) | BIT(3))
 #define DW_IC_COMP_PARAM_1_SPEED_MODE_MASK	GENMASK(3, 2)
@@ -243,7 +243,7 @@  struct dw_i2c_dev {
 	struct clk		*clk;
 	struct clk		*pclk;
 	struct reset_control	*rst;
-	struct i2c_client		*slave;
+	struct i2c_client	*slave;
 	u32			(*get_clk_rate_khz) (struct dw_i2c_dev *dev);
 	int			cmd_err;
 	struct i2c_msg		*msgs;