diff mbox series

[v2,1/2] gpiolib: improve coding style for local variables

Message ID 20211118132317.15898-1-brgl@bgdev.pl
State New
Headers show
Series [v2,1/2] gpiolib: improve coding style for local variables | expand

Commit Message

Bartosz Golaszewski Nov. 18, 2021, 1:23 p.m. UTC
Drop unneeded whitespaces and put the variables of the same type
together for consistency with the rest of the code.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
---
 drivers/gpio/gpiolib.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Andy Shevchenko Nov. 18, 2021, 3:44 p.m. UTC | #1
On Thu, Nov 18, 2021 at 02:23:16PM +0100, Bartosz Golaszewski wrote:
> Drop unneeded whitespaces and put the variables of the same type
> together for consistency with the rest of the code.

Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

> Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> ---
>  drivers/gpio/gpiolib.c | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index abfbf546d159..20d63028b85c 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -594,11 +594,10 @@ int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
>  			       struct lock_class_key *request_key)
>  {
>  	struct fwnode_handle *fwnode = gc->parent ? dev_fwnode(gc->parent) : NULL;
> -	unsigned long	flags;
> -	int		ret = 0;
> -	unsigned	i;
> -	int		base = gc->base;
> +	int ret = 0, base = gc->base;
>  	struct gpio_device *gdev;
> +	unsigned long flags;
> +	unsigned int i;
>  
>  	/*
>  	 * First: allocate and populate the internal stat container, and
> -- 
> 2.25.1
>
Johan Hovold Nov. 19, 2021, 7:57 a.m. UTC | #2
On Thu, Nov 18, 2021 at 02:23:16PM +0100, Bartosz Golaszewski wrote:
> Drop unneeded whitespaces and put the variables of the same type
> together for consistency with the rest of the code.
> 
> Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> ---
>  drivers/gpio/gpiolib.c | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index abfbf546d159..20d63028b85c 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -594,11 +594,10 @@ int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
>  			       struct lock_class_key *request_key)
>  {
>  	struct fwnode_handle *fwnode = gc->parent ? dev_fwnode(gc->parent) : NULL;
> -	unsigned long	flags;
> -	int		ret = 0;
> -	unsigned	i;
> -	int		base = gc->base;
> +	int ret = 0, base = gc->base;

This only makes the code harder to read for no good reason.

Keep declarations on separate lines, especially if also initialising.

Note that all but one function in this file initialises return value
variables on their own lines too (as they should).

>  	struct gpio_device *gdev;
> +	unsigned long flags;
> +	unsigned int i;

>  
>  	/*
>  	 * First: allocate and populate the internal stat container, and

Johan
diff mbox series

Patch

diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
index abfbf546d159..20d63028b85c 100644
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -594,11 +594,10 @@  int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
 			       struct lock_class_key *request_key)
 {
 	struct fwnode_handle *fwnode = gc->parent ? dev_fwnode(gc->parent) : NULL;
-	unsigned long	flags;
-	int		ret = 0;
-	unsigned	i;
-	int		base = gc->base;
+	int ret = 0, base = gc->base;
 	struct gpio_device *gdev;
+	unsigned long flags;
+	unsigned int i;
 
 	/*
 	 * First: allocate and populate the internal stat container, and