mbox series

[v1,0/9] pinctrl: apple: misc fixes from post-commit review

Message ID 20211113162944.22412-1-joey.gouly@arm.com
Headers show
Series pinctrl: apple: misc fixes from post-commit review | expand

Message

Joey Gouly Nov. 13, 2021, 4:29 p.m. UTC
Hi all,

Here's a series of small fixes that Andy made comments about, after the driver
was already in the pinctrl tree.

Most of the patches are only a few lines, apart from the first which is a
whitespace only change.

A branch can be found here:
    https://gitlab.arm.com/linux-arm/jg-open/-/tree/pinctrl_apple_fixes_v1

The branch is based on torvald's tree, with Sven's recent fix [1] cherry-picked.
(pinctrl fixes branch didn't have Sven's commit yet)

Thanks,
Joey

[1]
https://lore.kernel.org/linux-gpio/CACRpkdZJVRn9zAC8t=_X=29+kWw2QPKBHd9wiX9C3ms+gte40w@mail.gmail.com/T/

Joey Gouly (9):
  pinctrl: apple: fix some formatting issues
  pinctrl: apple: add missing bits.h header
  pinctrl: apple: handle regmap_read errors
  pinctrl: apple: make apple_gpio_get_direction more readable
  pinctrl: apple: give error label a specific name
  pinctrl: apple: remove gpio-controller check
  pinctrl: apple: don't set gpio_chip.of_node
  pinctrl: apple: use modulo rather than bitwise and
  pinctrl: apple: return an error if pinmux is missing in the DT

 drivers/pinctrl/pinctrl-apple-gpio.c | 103 ++++++++++++---------------
 1 file changed, 46 insertions(+), 57 deletions(-)

Comments

Andy Shevchenko Nov. 13, 2021, 7:21 p.m. UTC | #1
On Sat, Nov 13, 2021 at 6:30 PM Joey Gouly <joey.gouly@arm.com> wrote:
>
> Hi all,
>
> Here's a series of small fixes that Andy made comments about, after the driver
> was already in the pinctrl tree.
>
> Most of the patches are only a few lines, apart from the first which is a
> whitespace only change.
>
> A branch can be found here:
>     https://gitlab.arm.com/linux-arm/jg-open/-/tree/pinctrl_apple_fixes_v1
>
> The branch is based on torvald's tree, with Sven's recent fix [1] cherry-picked.
> (pinctrl fixes branch didn't have Sven's commit yet)

Thank you for doing this!

One suggestion here is to put the Suggested-by tag where it's applicable.
Side note: usually we still file a commit message body even if it
almost duplicates the subject line.

WRT patch 1, it seems to me it has a  lot of different style changes
at once. Perhaps split it more?

> Thanks,
> Joey
>
> [1]
> https://lore.kernel.org/linux-gpio/CACRpkdZJVRn9zAC8t=_X=29+kWw2QPKBHd9wiX9C3ms+gte40w@mail.gmail.com/T/
>
> Joey Gouly (9):
>   pinctrl: apple: fix some formatting issues
>   pinctrl: apple: add missing bits.h header
>   pinctrl: apple: handle regmap_read errors
>   pinctrl: apple: make apple_gpio_get_direction more readable
>   pinctrl: apple: give error label a specific name
>   pinctrl: apple: remove gpio-controller check
>   pinctrl: apple: don't set gpio_chip.of_node
>   pinctrl: apple: use modulo rather than bitwise and
>   pinctrl: apple: return an error if pinmux is missing in the DT
>
>  drivers/pinctrl/pinctrl-apple-gpio.c | 103 ++++++++++++---------------
>  1 file changed, 46 insertions(+), 57 deletions(-)
>
> --
> 2.17.1
>