mbox series

[0/6] S1G bootstrap and scan plumbing

Message ID cover.1759334464.git.james@teledatics.com
Headers show
Series S1G bootstrap and scan plumbing | expand

Message

James Ewing Oct. 1, 2025, 4:49 p.m. UTC
Initial S1G scaffolding for scan/assoc paths

Changelog:
 - Incorporated critique from Lachlan Hodges:
   * Dropped duplicate freq_khz/center_freq*_khz fields
   * Reused MHz<->kHz helper macros for offset math
   * Removed 5/10 MHz handling from S1G width path
   * Added S1G width helpers for clarity

James Ewing (6):
  tests: add S1G channel helpers
  tests: add S1G smoke harness
  common: add IEEE 802.11ah channel widths
  nl80211: propagate S1G widths and freq offsets
  wpa_supplicant: derive freq_khz from freq_offset
  tests: add S1G association coverage

 hostapd/ctrl_iface.c               |  15 +++++
 src/common/defs.h                  |  12 ++++
 src/common/hw_features_common.c    |   5 +-
 src/common/ieee802_11_common.c     |   7 ++
 src/drivers/driver.h               |  12 ++++
 src/drivers/driver_common.c        |  20 ++++++
 src/drivers/driver_nl80211.c       |  90 ++++++++++++++++++++++++-
 src/drivers/driver_nl80211_event.c |  20 ++++++
 src/drivers/driver_nl80211_scan.c  |  22 +++++++
 src/utils/common.h                 |  33 ++++++++++
 tests/hwsim/test_s1g_assoc.py      | 101 +++++++++++++++++++++++++++++
 tests/hwsim/test_s1g_smoke.py      |  40 ++++++++++++
 tests/hwsim/utils.py               |  63 ++++++++++++++++++
 wpa_supplicant/bss.c               |   1 +
 wpa_supplicant/bss.h               |   2 +
 wpa_supplicant/ctrl_iface.c        |  17 +++++
 wpa_supplicant/scan.c              |  32 +++++----
 wpa_supplicant/wpa_supplicant.c    |   3 +
 wpa_supplicant/wpa_supplicant_i.h  |   1 +
 19 files changed, 480 insertions(+), 16 deletions(-)
 create mode 100644 tests/hwsim/test_s1g_assoc.py
 create mode 100644 tests/hwsim/test_s1g_smoke.py

Comments

Lachlan Hodges Oct. 2, 2025, 1:09 a.m. UTC | #1
On Wed, Oct 01, 2025 at 12:49:55PM -0400, James Ewing wrote:
> Initial S1G scaffolding for scan/assoc paths
> 
> Changelog:
>  - Incorporated critique from Lachlan Hodges:
>    * Dropped duplicate freq_khz/center_freq*_khz fields
>    * Reused MHz<->kHz helper macros for offset math
>    * Removed 5/10 MHz handling from S1G width path
>    * Added S1G width helpers for clarity

Thanks for making the adjustments. Just for future reference its good to
include versioning in the subject (i.e. v2) so its clear when there is a new
patchset. Additionally, within each individual patch its good to include a list
of changes in that patch. So for example in patch 4 you'd have a list of things
that changed just in patch 4. Just makes it easier for people to review. This
would obviously be outside of the commit message though.

lachlan