diff mbox series

nscd: cleanup obsolete _FORTIFY_SOURCE setting

Message ID 20230725200432.953725-1-sam@gentoo.org
State New
Headers show
Series nscd: cleanup obsolete _FORTIFY_SOURCE setting | expand

Commit Message

Sam James July 25, 2023, 8:04 p.m. UTC
This was added in 233399bce2e79e5af3b344782e9943d5f1a9cdcb just for warn_if_unused
warnings rather than anything substantial.

Now that we have a proper configure argument for F_S (--enable-fortify-source),
just drop this entirely, to avoid conflicting with e.g. detected --enable-fortify-source
finding F_S=3, then nscd's Makefile setting F_S=2, resulting in a build-failure
because of the redefinition.

Signed-off-by: Sam James <sam@gentoo.org>
---
 nscd/Makefile | 2 --
 1 file changed, 2 deletions(-)

Comments

Siddhesh Poyarekar July 28, 2023, 7:02 p.m. UTC | #1
On 2023-07-25 16:04, Sam James via Libc-alpha wrote:
> This was added in 233399bce2e79e5af3b344782e9943d5f1a9cdcb just for warn_if_unused
> warnings rather than anything substantial.
> 
> Now that we have a proper configure argument for F_S (--enable-fortify-source),
> just drop this entirely, to avoid conflicting with e.g. detected --enable-fortify-source
> finding F_S=3, then nscd's Makefile setting F_S=2, resulting in a build-failure
> because of the redefinition.
> 
> Signed-off-by: Sam James <sam@gentoo.org>
> ---

LGTM.

Reviewed-by: Siddhesh Poyarekar <siddhesh@sourceware.org>

>   nscd/Makefile | 2 --
>   1 file changed, 2 deletions(-)
> 
> diff --git a/nscd/Makefile b/nscd/Makefile
> index c2e70d33b7..2a0489f4cf 100644
> --- a/nscd/Makefile
> +++ b/nscd/Makefile
> @@ -79,8 +79,6 @@ CFLAGS-nscd_gethst_r.c += -fexceptions
>   CFLAGS-nscd_getai.c += -fexceptions
>   CFLAGS-nscd_initgroups.c += -fexceptions
>   
> -CPPFLAGS-nscd += -D_FORTIFY_SOURCE=2
> -
>   ifeq (yesyes,$(have-fpie)$(build-shared))
>   CFLAGS-nscd += $(pie-ccflag)
>   endif
diff mbox series

Patch

diff --git a/nscd/Makefile b/nscd/Makefile
index c2e70d33b7..2a0489f4cf 100644
--- a/nscd/Makefile
+++ b/nscd/Makefile
@@ -79,8 +79,6 @@  CFLAGS-nscd_gethst_r.c += -fexceptions
 CFLAGS-nscd_getai.c += -fexceptions
 CFLAGS-nscd_initgroups.c += -fexceptions
 
-CPPFLAGS-nscd += -D_FORTIFY_SOURCE=2
-
 ifeq (yesyes,$(have-fpie)$(build-shared))
 CFLAGS-nscd += $(pie-ccflag)
 endif