@@ -1138,8 +1138,8 @@ do \
always make code faster, but eventually incurs high cost in
increased code size.
- Since we have a movmemsi pattern, the default MOVE_RATIO is 2, which
- is too low given that movmemsi will invoke a libcall. */
+ Since we have a cpymemsi pattern, the default MOVE_RATIO is 2, which
+ is too low given that cpymemsi will invoke a libcall. */
#define MOVE_RATIO(speed) ((speed) ? 9 : 3)
/* `CLEAR_RATIO (SPEED)`
@@ -3006,7 +3006,7 @@
;; Argument 2 is the length
;; Argument 3 is the alignment
-(define_expand "movmemsi"
+(define_expand "cpymemsi"
[(parallel [(set (match_operand:BLK 0 "memory_operand" "")
(match_operand:BLK 1 "memory_operand" ""))
(use (match_operand:SI 2 "general_operand" ""))
From: Aaron Sawdey <acsawdey@linux.ibm.com> * config/visium/visium.h: Change movmem to cpymem in comment. * config/visium/visium.md (movmemsi): Change name to cpymemsi. --- gcc/config/visium/visium.h | 4 ++-- gcc/config/visium/visium.md | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-)