diff mbox series

config: delete unused sim macros

Message ID 20210512042854.29596-1-vapier@gentoo.org
State New
Headers show
Series config: delete unused sim macros | expand

Commit Message

Mike Frysinger May 12, 2021, 4:28 a.m. UTC
Nothing in gcc or binutils or gdb or anything anywhere uses these.

config/

	* acinclude.m4 (CYG_AC_PATH_SIM, CYG_AC_PATH_DEVO): Delete.
---
 config/acinclude.m4 | 102 --------------------------------------------
 1 file changed, 102 deletions(-)

Comments

Jeff Law May 13, 2021, 3:24 p.m. UTC | #1
On 5/11/2021 10:28 PM, Mike Frysinger via Gcc-patches wrote:
> Nothing in gcc or binutils or gdb or anything anywhere uses these.
>
> config/
>
> 	* acinclude.m4 (CYG_AC_PATH_SIM, CYG_AC_PATH_DEVO): Delete.

"DEVO", yea, that's old.  I had a slight concern CYG might refer to 
Cygwin rather than Cygnus, but the comments reference old Cygnus 
projects (Foundry).  However, just to be sure, I checked the 
newlib-cygwin repo which has no references other than a clone of the 
code you're removing.

OK for the trunk.

jeff
Mike Frysinger May 18, 2021, 3:08 p.m. UTC | #2
On 13 May 2021 09:24, Jeff Law wrote:
> On 5/11/2021 10:28 PM, Mike Frysinger via Gcc-patches wrote:
> > Nothing in gcc or binutils or gdb or anything anywhere uses these.
> >
> > config/
> >
> > 	* acinclude.m4 (CYG_AC_PATH_SIM, CYG_AC_PATH_DEVO): Delete.
> 
> "DEVO", yea, that's old.  I had a slight concern CYG might refer to 
> Cygwin rather than Cygnus, but the comments reference old Cygnus 
> projects (Foundry).  However, just to be sure, I checked the 
> newlib-cygwin repo which has no references other than a clone of the 
> code you're removing.
> 
> OK for the trunk.

thanks.  did you happen to see this one too ?
https://gcc.gnu.org/pipermail/gcc-patches/2021-May/569894.html
-mike
Jeff Law May 18, 2021, 3:36 p.m. UTC | #3
On 5/18/2021 9:08 AM, Mike Frysinger wrote:
> On 13 May 2021 09:24, Jeff Law wrote:
>> On 5/11/2021 10:28 PM, Mike Frysinger via Gcc-patches wrote:
>>> Nothing in gcc or binutils or gdb or anything anywhere uses these.
>>>
>>> config/
>>>
>>> 	* acinclude.m4 (CYG_AC_PATH_SIM, CYG_AC_PATH_DEVO): Delete.
>> "DEVO", yea, that's old.  I had a slight concern CYG might refer to
>> Cygwin rather than Cygnus, but the comments reference old Cygnus
>> projects (Foundry).  However, just to be sure, I checked the
>> newlib-cygwin repo which has no references other than a clone of the
>> code you're removing.
>>
>> OK for the trunk.
> thanks.  did you happen to see this one too ?
> https://gcc.gnu.org/pipermail/gcc-patches/2021-May/569894.html

I don't recall seeing it, but it's OK as well.  I guess it hits GCC 
because we're upstream for Makefile.def/Makefile.in. Logically these 
bits are binutils, so if y'all are happy on the binutils side, then we 
shoudl just accept them on the GCC side.


jeff
diff mbox series

Patch

diff --git a/config/acinclude.m4 b/config/acinclude.m4
index 8242b2c7a8ac..0abccafa0353 100644
--- a/config/acinclude.m4
+++ b/config/acinclude.m4
@@ -373,88 +373,6 @@  fi
 AC_SUBST(INTLLIB)
 ])
 
-dnl ====================================================================
-dnl Find the simulator library.
-AC_DEFUN([CYG_AC_PATH_SIM], [
-dirlist=".. ../../ ../../../ ../../../../ ../../../../../ ../../../../../../ ../../../../../../.. ../../../../../../../.. ../../../../../../../../.. ../../../../../../../../../.. ../../../../../../../../../.."
-case "$target_cpu" in
-    powerpc)	target_dir=ppc ;;
-    sparc*)	target_dir=erc32 ;;
-    mips*)	target_dir=mips ;;
-    *)		target_dir=$target_cpu ;;
-esac
-dnl First look for the header file
-AC_MSG_CHECKING(for the simulator header file)
-AC_CACHE_VAL(ac_cv_c_simh,[
-for i in $dirlist; do
-    if test -f "${srcdir}/$i/include/remote-sim.h" ; then
-	ac_cv_c_simh=`(cd ${srcdir}/$i/include; ${PWDCMD-pwd})`
-	break
-    fi
-done
-])
-if test x"${ac_cv_c_simh}" != x; then
-    SIMHDIR="-I${ac_cv_c_simh}"
-    AC_MSG_RESULT(${ac_cv_c_simh})
-else
-    AC_MSG_RESULT(none)
-fi
-AC_SUBST(SIMHDIR)
-
-dnl See whether it's a devo or Foundry branch simulator
-AC_MSG_CHECKING(Whether this is a devo simulator )
-AC_CACHE_VAL(ac_cv_c_simdevo,[
-    CPPFLAGS="$CPPFLAGS $SIMHDIR"
-    AC_EGREP_HEADER([SIM_DESC sim_open.*struct _bfd], remote-sim.h,
-        ac_cv_c_simdevo=yes,
-        ac_cv_c_simdevo=no)
-])
-if test x"$ac_cv_c_simdevo" = x"yes" ; then
-    AC_DEFINE(HAVE_DEVO_SIM)
-fi
-AC_MSG_RESULT(${ac_cv_c_simdevo})
-AC_SUBST(HAVE_DEVO_SIM)
-
-dnl Next look for the library
-AC_MSG_CHECKING(for the simulator library)
-AC_CACHE_VAL(ac_cv_c_simlib,[
-for i in $dirlist; do
-    if test -f "$i/sim/$target_dir/Makefile" ; then
-	ac_cv_c_simlib=`(cd $i/sim/$target_dir; ${PWDCMD-pwd})`
-    fi
-done
-])
-if test x"${ac_cv_c_simlib}" != x; then
-    SIMLIB="-L${ac_cv_c_simlib}"
-else
-    AC_MSG_RESULT(none)
-    dnl FIXME: this is kinda bogus, cause umtimately the TM will build
-    dnl all the libraries for several architectures. But for now, this
-    dnl will work till then.
-dnl     AC_MSG_CHECKING(for the simulator installed with the compiler libraries)
-    dnl Transform the name of the compiler to it's cross variant, unless
-    dnl CXX is set. This is also what CXX gets set to in the generated
-    dnl Makefile.
-    CROSS_GCC=`echo gcc | sed -e "s/^/$target/"`
-
-    dnl Get G++'s full path to libgcc.a
-changequote(,)
-    gccpath=`${CROSS_GCC} --print-libgcc | sed -e 's:[a-z0-9A-Z\.\-]*/libgcc.a::' -e 's:lib/gcc-lib/::'`lib
-changequote([,])
-    if test -f $gccpath/libsim.a -o -f $gccpath/libsim.so ; then
-        ac_cv_c_simlib="$gccpath/"
-        SIMLIB="-L${ac_cv_c_simlib}"
-	AC_MSG_RESULT(${ac_cv_c_simlib})
-    else
-        AM_CONDITIONAL(PSIM, test x$psim = xno)
-	SIMLIB=""
-	AC_MSG_RESULT(none)
-dnl         ac_cv_c_simlib=none
-    fi
-fi
-AC_SUBST(SIMLIB)
-])
-
 dnl ====================================================================
 dnl Find the libiberty library.
 AC_DEFUN([CYG_AC_PATH_LIBIBERTY], [
@@ -476,26 +394,6 @@  fi
 AC_SUBST(LIBIBERTY)
 ])
 
-dnl ====================================================================
-AC_DEFUN([CYG_AC_PATH_DEVO], [
-AC_MSG_CHECKING(for devo headers in the source tree)
-dirlist=".. ../../ ../../../ ../../../../ ../../../../../ ../../../../../../ ../../../../../../.. ../../../../../../../.. ../../../../../../../../.. ../../../../../../../../../.."
-AC_CACHE_VAL(ac_cv_c_devoh,[
-for i in $dirlist; do
-    if test -f "${srcdir}/$i/include/remote-sim.h" ; then
-	ac_cv_c_devoh=`(cd ${srcdir}/$i/include; ${PWDCMD-pwd})`
-    fi
-done
-])
-if test x"${ac_cv_c_devoh}" != x; then
-    DEVOHDIR="-I${ac_cv_c_devoh}"
-    AC_MSG_RESULT(${ac_cv_c_devoh})
-else
-    AC_MSG_RESULT(none)
-fi
-AC_SUBST(DEVOHDIR)
-])
-
 dnl ====================================================================
 dnl Find all the ILU headers and libraries
 AC_DEFUN([CYG_AC_PATH_ILU], [