diff mbox

[1/3] Put a TARGET_LRA_P into every target

Message ID 20160914103510.GA24835@gate.crashing.org
State New
Headers show

Commit Message

Segher Boessenkool Sept. 14, 2016, 10:35 a.m. UTC
On Tue, Sep 13, 2016 at 02:38:54PM -0600, Jeff Law wrote:
> I believe a doc update of some kind is in order.  With the doc update 
> the entire series is OK.

Good catch, thanks.  My tests finished, all results identical.  I'll add
the following patch for the doc update (I hope the wording is strong enough).

Thanks,


Segher


2016-09-14  Segher Boessenkool  <segher@kernel.crashing.org>

	* target.def (lra_p): Change commentary (for the manual) for the
	new default.
	* doc/tm.texi: Regenerate.

---
 gcc/doc/tm.texi | 2 +-
 gcc/target.def  | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Peter Bergner Sept. 14, 2016, 12:46 p.m. UTC | #1
On 9/14/16 5:35 AM, Segher Boessenkool wrote:
> On Tue, Sep 13, 2016 at 02:38:54PM -0600, Jeff Law wrote:
>> I believe a doc update of some kind is in order.  With the doc update
>> the entire series is OK.
>
> Good catch, thanks.  My tests finished, all results identical.  I'll add
> the following patch for the doc update (I hope the wording is strong enough).

Maybe s/New ports should use LRA/New ports must use LRA/ ?



> + New ports  should use LRA, and existing ports are encouraged to convert.
              ^^
              extra space

Peter
Segher Boessenkool Sept. 14, 2016, 1:46 p.m. UTC | #2
On Wed, Sep 14, 2016 at 07:46:13AM -0500, Peter Bergner wrote:
> On 9/14/16 5:35 AM, Segher Boessenkool wrote:
> > (I hope the wording is strong enough).

> Maybe s/New ports should use LRA/New ports must use LRA/ ?

Yeah maybe.  Does anyone else have an opinion on this?  Cc:ing gcc@...

> >+ New ports  should use LRA, and existing ports are encouraged to convert.
>              ^^
>              extra space

That is auto-generated, and not new :-)  The various info backends do
not seem to care (TeX doesn't, do any others?)


Segher
Gerald Pfeifer Sept. 16, 2016, 10:26 a.m. UTC | #3
On Wed, 14 Sep 2016, Segher Boessenkool wrote:
> 2016-09-14  Segher Boessenkool  <segher@kernel.crashing.org>
> 
> 	* target.def (lra_p): Change commentary (for the manual) for the
> 	new default.
> 	* doc/tm.texi: Regenerate.

"returns always true" -> "always returns true" ?

(The former is how we'd say it in German, and hence might be common in 
Dutch as well?  In English, both probably are fine, the latter feeling 
more natural to me.  But then, I'm not a native speaker. ;-)

Gerald
Richard Kenner Sept. 16, 2016, 1:17 p.m. UTC | #4
> "returns always true" -> "always returns true" ?
> 
> (The former is how we'd say it in German, and hence might be common in 
> Dutch as well?  In English, both probably are fine, the latter feeling 
> more natural to me.  But then, I'm not a native speaker. ;-)

The former is unusual in English and borders on being "wrong".  It
would be parsed as saying that it returns something called "always
true", as if that were a construct.
Segher Boessenkool Sept. 16, 2016, 1:40 p.m. UTC | #5
On Fri, Sep 16, 2016 at 12:26:42PM +0200, Gerald Pfeifer wrote:
> On Wed, 14 Sep 2016, Segher Boessenkool wrote:
> > 2016-09-14  Segher Boessenkool  <segher@kernel.crashing.org>
> > 
> > 	* target.def (lra_p): Change commentary (for the manual) for the
> > 	new default.
> > 	* doc/tm.texi: Regenerate.
> 
> "returns always true" -> "always returns true" ?
> 
> (The former is how we'd say it in German, and hence might be common in 
> Dutch as well?  In English, both probably are fine, the latter feeling 
> more natural to me.  But then, I'm not a native speaker. ;-)

In Dutch we would do this altogether differently.  I did not change this
text at all though (except s/false/true/) ;-)

Does just "The default version of this target hook returns true." sound
better?  I.e. delete "always".


Segher
Mike Stump Sept. 16, 2016, 7:04 p.m. UTC | #6
On Sep 16, 2016, at 6:40 AM, Segher Boessenkool <segher@kernel.crashing.org> wrote:
> 
> Does just "The default version of this target hook returns true." sound
> better?  I.e. delete "always".

That is fine.
diff mbox

Patch

diff --git a/gcc/doc/tm.texi b/gcc/doc/tm.texi
index dc5bcd6..0ca00d2 100644
--- a/gcc/doc/tm.texi
+++ b/gcc/doc/tm.texi
@@ -2861,7 +2861,7 @@  A target hook which can change allocno class for given pseudo from
 @end deftypefn
 
 @deftypefn {Target Hook} bool TARGET_LRA_P (void)
-A target hook which returns true if we use LRA instead of reload pass.    The default version of this target hook returns always false, but new  ports should use LRA.
+A target hook which returns true if we use LRA instead of reload pass.    The default version of this target hook returns always true.  New ports  should use LRA, and existing ports are encouraged to convert.
 @end deftypefn
 
 @deftypefn {Target Hook} int TARGET_REGISTER_PRIORITY (int)
diff --git a/gcc/target.def b/gcc/target.def
index 8509e7d..a4e4cbb 100644
--- a/gcc/target.def
+++ b/gcc/target.def
@@ -4929,8 +4929,8 @@  DEFHOOK
 (lra_p,
  "A target hook which returns true if we use LRA instead of reload pass.\
   \
-  The default version of this target hook returns always false, but new\
-  ports should use LRA.",
+  The default version of this target hook returns always true.  New ports\
+  should use LRA, and existing ports are encouraged to convert.",
  bool, (void),
  default_lra_p)