diff mbox

[C++1y,4/4] Generate more intuitive name for 'auto' parameters.

Message ID 1379615867-21555-5-git-send-email-adam@jessamine.co.uk
State New
Headers show

Commit Message

Adam Butcher Sept. 19, 2013, 6:37 p.m. UTC
* parser.c (make_generic_type_name): Spell generic type names '<autoN>'
	rather than '__GenN'.
---
 gcc/cp/parser.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jason Merrill Sept. 20, 2013, 5:47 p.m. UTC | #1
OK.

Jason
diff mbox

Patch

diff --git a/gcc/cp/parser.c b/gcc/cp/parser.c
index 148e2f2..a54496a 100644
--- a/gcc/cp/parser.c
+++ b/gcc/cp/parser.c
@@ -28902,7 +28902,7 @@  make_generic_type_name ()
 {
   char buf[32];
   static int i = 0;
-  sprintf (buf, "__GenT%d", i);
+  sprintf (buf, "<auto%d>", ++i);
   return get_identifier (buf);
 }