diff mbox

[v2] configure: fix typos in help strings

Message ID 1290589606-13458-1-git-send-email-vapier@gentoo.org
State New
Headers show

Commit Message

Mike Frysinger Nov. 24, 2010, 9:06 a.m. UTC
Signed-off-by: Mike Frysinger <vapier@gentoo.org>

2010-11-24  Mike Frysinger  <vapier@gentoo.org>

	* configure.ac: Fix typos in help strings.
	* configure: Regenerate.
---
v2
	- rebase onto latest mainline
	- no feedback on last patch posted a few months ago ...

 configure.ac |   12 ++++++------
 1 files changed, 6 insertions(+), 6 deletions(-)

Comments

Ralf Wildenhues Nov. 25, 2010, 6:25 a.m. UTC | #1
Hi Mike,

* Mike Frysinger wrote on Wed, Nov 24, 2010 at 10:06:46AM CET:
> 2010-11-24  Mike Frysinger  <vapier@gentoo.org>
> 
> 	* configure.ac: Fix typos in help strings.
> 	* configure: Regenerate.
> ---
> v2
> 	- rebase onto latest mainline
> 	- no feedback on last patch posted a few months ago ...

Well, the patch certainly doesn't make things worse, but how about using
AS_HELP_STRING instead for automatic aligning of text?

Patch is preapproved for mainline with that change if you diff
'./configure --help' output from before and after to check for
errors.

The patch needs syncing to src.

Thanks,
Ralf
Mike Frysinger Nov. 25, 2010, 7:16 a.m. UTC | #2
On Thursday, November 25, 2010 01:25:30 Ralf Wildenhues wrote:
> * Mike Frysinger wrote on Wed, Nov 24, 2010 at 10:06:46AM CET:
> > 2010-11-24  Mike Frysinger  <vapier@gentoo.org>
> > 
> > 	* configure.ac: Fix typos in help strings.
> > 	* configure: Regenerate.
> > 
> > ---
> > v2
> > 
> > 	- rebase onto latest mainline
> > 	- no feedback on last patch posted a few months ago ...
> 
> Well, the patch certainly doesn't make things worse, but how about using
> AS_HELP_STRING instead for automatic aligning of text?

personally, i use it all the time, but i didnt see the top level using it at 
all, so i thought it might be preferred to not jump into that ...

> Patch is preapproved for mainline with that change if you diff
> './configure --help' output from before and after to check for
> errors.

that's how i was testing

> The patch needs syncing to src.

if you mean sourceware, i can do that.  but i dont think i have access to the 
gcc tree ... just sourceware.  at least, no one has told me as much.
-mike
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index 0a5c276..b9afe04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1275,12 +1275,12 @@  have_gmp=no
 
 # Specify a location for mpc
 # check for this first so it ends up on the link line before mpfr.
-AC_ARG_WITH(mpc, [  --with-mpc=PATH        specify prefix directory for installed MPC package.
+AC_ARG_WITH(mpc, [  --with-mpc=PATH         specify prefix directory for installed MPC package.
                           Equivalent to --with-mpc-include=PATH/include
                           plus --with-mpc-lib=PATH/lib])
 AC_ARG_WITH(mpc-include, [  --with-mpc-include=PATH
                           specify directory for installed MPC include files])
-AC_ARG_WITH(mpc-lib, [  --with-mpc-lib=PATH    specify directory for the installed MPC library])
+AC_ARG_WITH(mpc-lib, [  --with-mpc-lib=PATH     specify directory for the installed MPC library])
 
 if test "x$with_mpc" != x; then
   gmplibs="-L$with_mpc/lib $gmplibs"
@@ -1499,7 +1499,7 @@  AC_SUBST(stage1_ldflags)
 
 # Libraries to use for stage1 or when not bootstrapping.
 AC_ARG_WITH(stage1-libs,
-[  -with-stage1-libs=LIBS      Libraries for stage1],
+[  --with-stage1-libs=LIBS Libraries for stage1],
 [if test "$withval" = "no" -o "$withval" = "yes"; then
    stage1_libs=
  else
@@ -1511,7 +1511,7 @@  AC_SUBST(stage1_libs)
 # Libraries to use for stage2 and later builds.  This defaults to the
 # argument passed to --with-host-libstdcxx.
 AC_ARG_WITH(boot-libs,
-[  --with-boot-libs=LIBS     Libraries for stage2 and later],
+[  --with-boot-libs=LIBS   Libraries for stage2 and later],
 [if test "$withval" = "no" -o "$withval" = "yes"; then
    poststage1_libs=
  else
@@ -2117,7 +2117,7 @@  AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
 
 AC_ARG_WITH([debug-prefix-map],
   [  --with-debug-prefix-map='A=B C=D ...'
-                             map A to B, C to D ... in debug information],
+                          map A to B, C to D ... in debug information],
   [if test x"$withval" != x; then
      DEBUG_PREFIX_CFLAGS_FOR_TARGET=
      for debug_map in $withval; do
@@ -2615,7 +2615,7 @@  esac
 AC_MSG_CHECKING(for default BUILD_CONFIG)
 
 AC_ARG_WITH([build-config],
-  [--with-build-config='NAME NAME2...'
+  [  --with-build-config='NAME NAME2...'
                           Use config/NAME.mk build configuration],
   [case $with_build_config in
    yes) with_build_config= ;;