diff mbox

[v2,03/10] dt-bindings: msm/mdp: Fix up clock related bindings

Message ID 1465555600-25742-4-git-send-email-architt@codeaurora.org
State Not Applicable, archived
Headers show

Commit Message

Archit Taneja June 10, 2016, 10:46 a.m. UTC
MDP5:
- Don't ask for source clock

MDP4:
- Give a better name for MDP_TV_CLK
- Remove TV_SRC
- Add MDP_AXI_CLK

Signed-off-by: Archit Taneja <architt@codeaurora.org>
---
 Documentation/devicetree/bindings/display/msm/mdp.txt | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

Comments

Rob Herring (Arm) June 13, 2016, 7:03 p.m. UTC | #1
On Fri, Jun 10, 2016 at 04:16:33PM +0530, Archit Taneja wrote:
> MDP5:
> - Don't ask for source clock
> 
> MDP4:
> - Give a better name for MDP_TV_CLK
> - Remove TV_SRC
> - Add MDP_AXI_CLK

This could use the explanation in the commit msg why it is okay you are 
breaking compatibility.

With that,

Acked-by: Rob Herring <robh@kernel.org>
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Archit Taneja June 16, 2016, 5:08 a.m. UTC | #2
On 06/14/2016 12:33 AM, Rob Herring wrote:
> On Fri, Jun 10, 2016 at 04:16:33PM +0530, Archit Taneja wrote:
>> MDP5:
>> - Don't ask for source clock
>>
>> MDP4:
>> - Give a better name for MDP_TV_CLK
>> - Remove TV_SRC
>> - Add MDP_AXI_CLK
>
> This could use the explanation in the commit msg why it is okay you are
> breaking compatibility.

Sure, I'll do that. Thanks for the reviews.

Archit

>
> With that,
>
> Acked-by: Rob Herring <robh@kernel.org>
>
diff mbox

Patch

diff --git a/Documentation/devicetree/bindings/display/msm/mdp.txt b/Documentation/devicetree/bindings/display/msm/mdp.txt
index a214f6c..1d3d79d 100644
--- a/Documentation/devicetree/bindings/display/msm/mdp.txt
+++ b/Documentation/devicetree/bindings/display/msm/mdp.txt
@@ -13,14 +13,13 @@  Required properties:
   For MDP4:
    * "core_clk"
    * "iface_clk"
+   * "bus_clk"
    * "lut_clk"
-   * "src_clk"
    * "hdmi_clk"
-   * "mdp_clk"
+   * "tv_clk"
   For MDP5:
    * "bus_clk"
    * "iface_clk"
-   * "core_clk_src"
    * "core_clk"
    * "lut_clk" (some MDP5 versions may not need this)
    * "vsync_clk"
@@ -45,14 +44,13 @@  Example:
 		    "core_clk",
 		    "iface_clk",
 		    "lut_clk",
-		    "src_clk",
 		    "hdmi_clk",
 		    "mdp_clk";
 		clocks =
-		    <&mmcc MDP_SRC>,
+		    <&mmcc MDP_CLK>,
 		    <&mmcc MDP_AHB_CLK>,
+		    <&mmcc MDP_AXI_CLK>,
 		    <&mmcc MDP_LUT_CLK>,
-		    <&mmcc TV_SRC>,
 		    <&mmcc HDMI_TV_CLK>,
 		    <&mmcc MDP_TV_CLK>;
 	};