diff mbox

[2,of,2] make clean: remove redundant removal of STAGING_DIR

Message ID e4d1fd22ccc32a9c0ffc.1380539367@argentina
State Accepted
Commit 300eb6b751bc623a2446ead4c885bcfa84419744
Headers show

Commit Message

Thomas De Schampheleire Sept. 30, 2013, 11:09 a.m. UTC
Since STAGING_DIR is defined as (package/Makefile.in):

STAGING_SUBDIR = usr/$(GNU_TARGET_NAME)/sysroot
STAGING_DIR    = $(HOST_DIR)/$(STAGING_SUBDIR)

removing HOST_DIR will automatically remove STAGING_DIR. This patch updates
'make clean' based on this knowledge.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 Makefile |  2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Arnout Vandecappelle Oct. 1, 2013, 5:21 p.m. UTC | #1
On 09/30/13 13:09, Thomas De Schampheleire wrote:
> Since STAGING_DIR is defined as (package/Makefile.in):
>
> STAGING_SUBDIR = usr/$(GNU_TARGET_NAME)/sysroot
> STAGING_DIR    = $(HOST_DIR)/$(STAGING_SUBDIR)
>
> removing HOST_DIR will automatically remove STAGING_DIR. This patch updates
> 'make clean' based on this knowledge.
>
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

>
> ---
>   Makefile |  2 +-
>   1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/Makefile b/Makefile
> --- a/Makefile
> +++ b/Makefile
> @@ -748,7 +748,7 @@ printvars:
>   		$(info $V=$($V) ($(value $V)))))
>
>   clean:
> -	rm -rf $(STAGING_DIR) $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
> +	rm -rf $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
>   		$(STAMP_DIR) $(BUILD_DIR) $(BASE_DIR)/staging \
>   		$(LEGAL_INFO_DIR)
>
>
Peter Korsgaard Oct. 1, 2013, 7:59 p.m. UTC | #2
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 Thomas> Since STAGING_DIR is defined as (package/Makefile.in):
 Thomas> STAGING_SUBDIR = usr/$(GNU_TARGET_NAME)/sysroot
 Thomas> STAGING_DIR    = $(HOST_DIR)/$(STAGING_SUBDIR)

 Thomas> removing HOST_DIR will automatically remove STAGING_DIR. This
 Thomas> patch updates 'make clean' based on this knowledge.

 Thomas> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Committed, thanks.
diff mbox

Patch

diff --git a/Makefile b/Makefile
--- a/Makefile
+++ b/Makefile
@@ -748,7 +748,7 @@  printvars:
 		$(info $V=$($V) ($(value $V)))))
 
 clean:
-	rm -rf $(STAGING_DIR) $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
+	rm -rf $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
 		$(STAMP_DIR) $(BUILD_DIR) $(BASE_DIR)/staging \
 		$(LEGAL_INFO_DIR)