diff mbox

redis: fix build with ccache enabled

Message ID c0967e3e463dd286cb2b.1377697225@argentina
State Accepted
Commit e5088380d3aa475fe2457fc12a47353dd66c4c19
Headers show

Commit Message

Thomas De Schampheleire Aug. 28, 2013, 1:40 p.m. UTC
Some parts of redis fail to build when ccache is enabled, due to one of our
own patches. The construct
    make CC=$(CC) target1 target2
would result in
    make CC=ccache <tuple>-gcc target1 target2

and here <tuple>-gcc would be treated as a target and the compiler used
would be just 'ccache'.

Reported-by: Johan Sagaert <sagaert.johan@skynet.be>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
I think this should still be applied for 2013.08.

 package/redis/redis-001-uclibc.patch |  2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Peter Korsgaard Aug. 28, 2013, 2:20 p.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin+buildroot@gmail.com> writes:

 Thomas> Some parts of redis fail to build when ccache is enabled, due to one of our
 Thomas> own patches. The construct
 Thomas>     make CC=$(CC) target1 target2
 Thomas> would result in
 Thomas>     make CC=ccache <tuple>-gcc target1 target2

 Thomas> and here <tuple>-gcc would be treated as a target and the compiler used
 Thomas> would be just 'ccache'.

 Thomas> Reported-by: Johan Sagaert <sagaert.johan@skynet.be>
 Thomas> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

 Thomas> ---
 Thomas> I think this should still be applied for 2013.08.

Committed, thanks.
diff mbox

Patch

diff --git a/package/redis/redis-001-uclibc.patch b/package/redis/redis-001-uclibc.patch
--- a/package/redis/redis-001-uclibc.patch
+++ b/package/redis/redis-001-uclibc.patch
@@ -39,7 +39,7 @@  diff -ur old/src/Makefile new/src/Makefi
  	echo PREV_FINAL_CFLAGS=$(FINAL_CFLAGS) >> .make-settings
  	echo PREV_FINAL_LDFLAGS=$(FINAL_LDFLAGS) >> .make-settings
 -	-(cd ../deps && $(MAKE) $(DEPENDENCY_TARGETS))
-+	-(cd ../deps && $(MAKE) CC=$(CC) $(DEPENDENCY_TARGETS))
++	-(cd ../deps && $(MAKE) CC="$(CC)" $(DEPENDENCY_TARGETS))
  
  .PHONY: persist-settings