diff mbox

btrfs-progs: fix static build with gettext

Message ID be7f33ed40d541fb09ae8582b83f3b5c39d5dd27.1424175644.git.baruch@tkos.co.il
State Accepted
Headers show

Commit Message

Baruch Siach Feb. 17, 2015, 12:20 p.m. UTC
gettext needs -pthread. Incidentally this change was also made in the package
Makefile itself for a different reason.

Also, drop -lm to match upstream change.

Fixes:
http://autobuild.buildroot.net/results/a53/a53f31355e955c734010922b47084605e13708ef/
http://autobuild.buildroot.net/results/43d/43deeeda31d9750b37e1f1058c3313a387843bee/

and more.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/btrfs-progs/btrfs-progs.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 19, 2015, 9:58 p.m. UTC | #1
Dear Baruch Siach,

On Tue, 17 Feb 2015 14:20:44 +0200, Baruch Siach wrote:
> gettext needs -pthread. Incidentally this change was also made in the package
> Makefile itself for a different reason.
> 
> Also, drop -lm to match upstream change.
> 
> Fixes:
> http://autobuild.buildroot.net/results/a53/a53f31355e955c734010922b47084605e13708ef/
> http://autobuild.buildroot.net/results/43d/43deeeda31d9750b37e1f1058c3313a387843bee/
> 
> and more.
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/btrfs-progs/btrfs-progs.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks!

> -BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lm -lz -llzo2 -L. -lintl"
> +BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lz -llzo2 -L. -lintl -pthread"

This is really ugly, because we have to duplicate the lib_LIBS value
from the package Makefile, and whenever it gets changed in the package
Makefile, we need to remember to also change it here. Not great :-/

Thomas
Baruch Siach Feb. 19, 2015, 10:04 p.m. UTC | #2
Hi Thomas,

On Thu, Feb 19, 2015 at 10:58:18PM +0100, Thomas Petazzoni wrote:
> On Tue, 17 Feb 2015 14:20:44 +0200, Baruch Siach wrote:
> > gettext needs -pthread. Incidentally this change was also made in the package
> > Makefile itself for a different reason.
> > 
> > Also, drop -lm to match upstream change.
> > 
> > Fixes:
> > http://autobuild.buildroot.net/results/a53/a53f31355e955c734010922b47084605e13708ef/
> > http://autobuild.buildroot.net/results/43d/43deeeda31d9750b37e1f1058c3313a387843bee/
> > 
> > and more.
> > 
> > Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> > ---
> >  package/btrfs-progs/btrfs-progs.mk | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> Applied, thanks!
> 
> > -BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lm -lz -llzo2 -L. -lintl"
> > +BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lz -llzo2 -L. -lintl -pthread"
> 
> This is really ugly, because we have to duplicate the lib_LIBS value
> from the package Makefile, and whenever it gets changed in the package
> Makefile, we need to remember to also change it here. Not great :-/

This is temporary. Upstream switched to autotools for the next version (now at 
v3.19-rc2). Once we upgrade the usual LIBS= trick would be enough, I believe.

baruch
Thomas Petazzoni Feb. 19, 2015, 10:05 p.m. UTC | #3
Dear Baruch Siach,

On Fri, 20 Feb 2015 00:04:00 +0200, Baruch Siach wrote:

> > This is really ugly, because we have to duplicate the lib_LIBS value
> > from the package Makefile, and whenever it gets changed in the package
> > Makefile, we need to remember to also change it here. Not great :-/
> 
> This is temporary. Upstream switched to autotools for the next version (now at 
> v3.19-rc2). Once we upgrade the usual LIBS= trick would be enough, I believe.

Ah, ok, good to know! Thanks.

Thomas
diff mbox

Patch

diff --git a/package/btrfs-progs/btrfs-progs.mk b/package/btrfs-progs/btrfs-progs.mk
index c6c36cf1556c..768660d27c8f 100644
--- a/package/btrfs-progs/btrfs-progs.mk
+++ b/package/btrfs-progs/btrfs-progs.mk
@@ -18,7 +18,7 @@  BTRFS_PROGS_MAKE_TARGET = static
 BTRFS_PROGS_MAKE_INSTALL_TARGET = install-static
 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 # Add -lintl for libuuid
-BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lm -lz -llzo2 -L. -lintl"
+BTRFS_PROGS_MAKE_FLAGS += lib_LIBS="-luuid -lblkid -lz -llzo2 -L. -lintl -pthread"
 endif
 else
 BTRFS_PROGS_MAKE_TARGET = all