diff mbox series

[v2] package/asterisk: fix compile issue

Message ID ZjI4anypCjkVxtjO@waldemar-brodkorb.de
State Accepted
Headers show
Series [v2] package/asterisk: fix compile issue | expand

Commit Message

Waldemar Brodkorb May 1, 2024, 12:41 p.m. UTC
Fix a compile issue when libyuv and libjpeg is enabled.
Detection of following function fails:
checking for pjsip_dlg_create_uas_and_inc_lock in -lpjsip... no

In config.log you see that libjpeg is missing.

Fixes:
 http://autobuild.buildroot.net/results/7bed9fc68fc9331ad12942c3eab9742ee8a7a4c4

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 v1->v2: package libjpeg must be enabled, too
---
 package/asterisk/asterisk.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN May 1, 2024, 4:27 p.m. UTC | #1
Waldemar, All,

On 2024-05-01 14:41 +0200, Waldemar Brodkorb spake thusly:
> Fix a compile issue when libyuv and libjpeg is enabled.
> Detection of following function fails:
> checking for pjsip_dlg_create_uas_and_inc_lock in -lpjsip... no
> 
> In config.log you see that libjpeg is missing.
> 
> Fixes:
>  http://autobuild.buildroot.net/results/7bed9fc68fc9331ad12942c3eab9742ee8a7a4c4
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  v1->v2: package libjpeg must be enabled, too
> ---
>  package/asterisk/asterisk.mk | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
> index 33d2e78bcf..c37aa5ec9d 100644
> --- a/package/asterisk/asterisk.mk
> +++ b/package/asterisk/asterisk.mk
> @@ -113,9 +113,15 @@ ASTERISK_CONF_ENV = \
>  
>  # Uses __atomic_fetch_add_4
>  ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
> -ASTERISK_CONF_ENV += LIBS="-latomic"
> +ASTERISK_LIBS += -latomic
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBYUV)$(BR2_PACKAGE_JPEG),yy)
> +ASTERISK_LIBS += -ljpeg
> +endif
> +
> +ASTERISK_CONF_ENV += LIBS="$(ASTERISK_LIBS)"
> +
>  ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),y)
>  ASTERISK_CONF_OPTS += --with-execinfo
>  else
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
index 33d2e78bcf..c37aa5ec9d 100644
--- a/package/asterisk/asterisk.mk
+++ b/package/asterisk/asterisk.mk
@@ -113,9 +113,15 @@  ASTERISK_CONF_ENV = \
 
 # Uses __atomic_fetch_add_4
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
-ASTERISK_CONF_ENV += LIBS="-latomic"
+ASTERISK_LIBS += -latomic
 endif
 
+ifeq ($(BR2_PACKAGE_LIBYUV)$(BR2_PACKAGE_JPEG),yy)
+ASTERISK_LIBS += -ljpeg
+endif
+
+ASTERISK_CONF_ENV += LIBS="$(ASTERISK_LIBS)"
+
 ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),y)
 ASTERISK_CONF_OPTS += --with-execinfo
 else