diff mbox

portmap: fix static linking

Message ID F9C551623D2CBB4C9488801D14F864C68C8AD946@ex-mb3.corp.adtran.com
State Accepted
Headers show

Commit Message

ANDY KENNEDY Sept. 8, 2014, 9:43 p.m. UTC
Portmap builds and links, however, does not get built correctly when
BR2_PREFER_STATIC_LIB is selected.  There are no dynamic libraries in
rootfs.tar, however, portmap gets linked dynamically without regards to
the PREFER_STATIC_LIB tags.  LDFLAGS was not being passed into the build of
portmap.

Signed-off-by:  Andy Kennedy <andy.kennedy@adtran.com>
---
buildroot mailing list
buildroot@busybox.net
http://lists.busybox.net/mailman/listinfo/buildroot

Comments

Thomas Petazzoni Sept. 16, 2014, 8:07 p.m. UTC | #1
Dear ANDY KENNEDY,

On Mon, 8 Sep 2014 21:43:45 +0000, ANDY KENNEDY wrote:
> Portmap builds and links, however, does not get built correctly when
> BR2_PREFER_STATIC_LIB is selected.  There are no dynamic libraries in
> rootfs.tar, however, portmap gets linked dynamically without regards to
> the PREFER_STATIC_LIB tags.  LDFLAGS was not being passed into the build of
> portmap.
> 
> Signed-off-by:  Andy Kennedy <andy.kennedy@adtran.com>

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni Sept. 21, 2014, 8:08 p.m. UTC | #2
Dear ANDY KENNEDY,

On Mon, 8 Sep 2014 21:43:45 +0000, ANDY KENNEDY wrote:
> Portmap builds and links, however, does not get built correctly when
> BR2_PREFER_STATIC_LIB is selected.  There are no dynamic libraries in
> rootfs.tar, however, portmap gets linked dynamically without regards to
> the PREFER_STATIC_LIB tags.  LDFLAGS was not being passed into the build of
> portmap.
> 
> Signed-off-by:  Andy Kennedy <andy.kennedy@adtran.com>

Applied, thanks!

Thomas
diff mbox

Patch

diff -Naur a/package/portmap/portmap.mk b/package/portmap/portmap.mk
--- a/package/portmap/portmap.mk	2014-02-27 14:51:23.000000000 -0600
+++ b/package/portmap/portmap.mk	2014-09-08 16:39:13.715370478 -0500
@@ -15,8 +15,7 @@ 
 endif
 
 define PORTMAP_BUILD_CMDS
-	CFLAGS="$(TARGET_CFLAGS)" \
-	$(MAKE) CC="$(TARGET_CC)" -C $(@D) $(PORTMAP_FLAGS)
+	$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(PORTMAP_FLAGS)
 endef
 
_______________________________________________