diff mbox

[2/2] toolchain/gcc: the ARC version of gcc needs host-flex/host-bison

Message ID E6BF041E97966E4DB955F0DF883AD2D6339FF18A@de02wembxa.internal.synopsys.com
State Not Applicable
Headers show

Commit Message

Mischa Jonker May 10, 2013, 2:47 p.m. UTC
Dear Thomas,

Thank you for fixing this. Is there any way I can sort the autobuilder results so that I can see specific build problems for ARC?

Thanks,

Mischa

-----Original Message-----
From: Thomas Petazzoni [mailto:thomas.petazzoni@free-electrons.com] 
Sent: Thursday, May 09, 2013 5:53 PM
To: Buildroot List
Cc: Mischa Jonker
Subject: [PATCH 2/2] toolchain/gcc: the ARC version of gcc needs host-flex/host-bison

For some reason (probably because the ARC changes modify some lex/yacc files without updating their pre-generated variants, or because the date/time of the pre-generated files is not correct), building the ARC gcc requires host-flex and host-bison.

We have tested 4.2 for AVR, 4.3 and 4.4 for ARM, and none of those need host-flex or host-bison to be installed, so only the 4.4 for ARC seems to be affected.

Fixes the build failure visible at
http://autobuild.buildroot.org/results/673c6262e3dde8ee8dd28204d814097e6ba8f8e9/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 toolchain/gcc/gcc-uclibc-4.x.mk |    4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni May 10, 2013, 3:53 p.m. UTC | #1
Dear Mischa Jonker,

On Fri, 10 May 2013 14:47:56 +0000, Mischa Jonker wrote:

> Thank you for fixing this. Is there any way I can sort the autobuilder results so that I can see specific build problems for ARC?

Not as of today, you can't filter the results. I'm working on doing
this. I started doing something in Python/Django, but had some issues,
so I guess I'll continue with the PHP stuff we're already using, and
improve it to be able to sort things.

In the mean time, I often monitor the autobuilder results, so if
there's anything ARC related, I'll notify you.

Best regards,

Thomas
Thomas Petazzoni May 13, 2013, 9:40 p.m. UTC | #2
Dear Mischa Jonker,

On Fri, 10 May 2013 14:47:56 +0000, Mischa Jonker wrote:

> Thank you for fixing this. Is there any way I can sort the autobuilder results so that I can see specific build problems for ARC?

Build failures on the ARC architecture:

 * On the rt-tests package. See
   http://autobuild.buildroot.org/results/bfb/bfbd82224a80f4446c5f9c1a37b95e910c9f181a//
   for details. Looks like rt-tests want a NPTL toolchain.

 * On the OpenOCD package. See
   http://autobuild.buildroot.org/results/e18/e185b1ef573ddeca51ceb1d30298e611c6879b42//
   for details. It seems to be a toolchain problem: "{standard
   input}:449: Error: operand out of range (-514 is not between -512
   and 511)".

I've just put online a new version of http://autobuild.buildroot.org/,
which now uses a database. If you're interested, I can send you every
day a mail with the ARC build failures (and only the ARC ones), if any.

Best regards,

Thomas
diff mbox

Patch

diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk index 8cacc32..21679ef 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -180,6 +180,10 @@  endif
 GCC_HOST_PREREQ += host-mpc
 endif
 
+ifeq ($(BR2_GCC_VERSION_4_4_7_ARC),y)
+GCC_HOST_PREREQ += host-flex host-bison endif
+
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
 GCC_SHARED_LIBGCC:=--enable-shared
 else
--
1.7.9.5