diff mbox series

[05/11] package/compiler-rt: move to llvm-project subfolder

Message ID DB6P190MB048810AF47C511ED10E1B2C39F549@DB6P190MB0488.EURP190.PROD.OUTLOOK.COM
State Superseded
Headers show
Series group llvm projects and bump to version 15.0.1 | expand

Commit Message

Lang Daniel Sept. 28, 2022, 2:30 p.m. UTC
To make version bumping easier, move llvm to a new llvm-project subfolder
and specify site and version for the project.

Signed-off-by: Daniel Lang <d.lang@abatec.at>
---
 DEVELOPERS                                              | 2 +-
 package/Config.in                                       | 2 +-
 package/{ => llvm-project}/compiler-rt/Config.in        | 0
 package/{ => llvm-project}/compiler-rt/compiler-rt.hash | 0
 package/{ => llvm-project}/compiler-rt/compiler-rt.mk   | 6 ++----
 5 files changed, 4 insertions(+), 6 deletions(-)
 rename package/{ => llvm-project}/compiler-rt/Config.in (100%)
 rename package/{ => llvm-project}/compiler-rt/compiler-rt.hash (100%)
 rename package/{ => llvm-project}/compiler-rt/compiler-rt.mk (85%)
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 0acc1eef55..493c07acd4 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1966,7 +1966,6 @@  F:	package/bridge-utils/
 F:	package/checkpolicy/
 F:	package/checksec/
 F:	package/cgroupfs-mount/
-F:	package/compiler-rt/
 F:	package/crda/
 F:	package/cunit/
 F:	package/dacapo/
@@ -2004,6 +2003,7 @@  F:	package/libssh2/
 F:	package/libtalloc/
 F:	package/libqmi/
 F:	package/lighttpd/
+F:	package/llvm-project/compiler-rt/
 F:	package/logrotate/
 F:	package/makedevs/
 F:	package/memtester/
diff --git a/package/Config.in b/package/Config.in
index 15dd27796f..1d48b1448b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1972,7 +1972,7 @@  menu "Other"
 	source "package/cereal/Config.in"
 	source "package/llvm-project/clang/Config.in"
 	source "package/cmocka/Config.in"
-	source "package/compiler-rt/Config.in"
+	source "package/llvm-project/compiler-rt/Config.in"
 	source "package/cppcms/Config.in"
 	source "package/cracklib/Config.in"
 	source "package/dawgdic/Config.in"
diff --git a/package/compiler-rt/Config.in b/package/llvm-project/compiler-rt/Config.in
similarity index 100%
rename from package/compiler-rt/Config.in
rename to package/llvm-project/compiler-rt/Config.in
diff --git a/package/compiler-rt/compiler-rt.hash b/package/llvm-project/compiler-rt/compiler-rt.hash
similarity index 100%
rename from package/compiler-rt/compiler-rt.hash
rename to package/llvm-project/compiler-rt/compiler-rt.hash
diff --git a/package/compiler-rt/compiler-rt.mk b/package/llvm-project/compiler-rt/compiler-rt.mk
similarity index 85%
rename from package/compiler-rt/compiler-rt.mk
rename to package/llvm-project/compiler-rt/compiler-rt.mk
index c8ea86e899..84add60801 100644
--- a/package/compiler-rt/compiler-rt.mk
+++ b/package/llvm-project/compiler-rt/compiler-rt.mk
@@ -4,11 +4,9 @@ 
 #
 ################################################################################
 
-# Compiler-RT should be bumped together with LLVM and Clang as the run-time is
-# tied to the version of those tools
-COMPILER_RT_VERSION = 11.1.0
+COMPILER_RT_VERSION = $(LLVM_PROJECT_VERSION)
 COMPILER_RT_SOURCE = compiler-rt-$(COMPILER_RT_VERSION).src.tar.xz
-COMPILER_RT_SITE = https://github.com/llvm/llvm-project/releases/download/llvmorg-$(COMPILER_RT_VERSION)
+COMPILER_RT_SITE = $(LLVM_PROJECT_SITE)
 COMPILER_RT_LICENSE = NCSA MIT
 COMPILER_RT_LICENSE_FILES = LICENSE.TXT
 COMPILER_RT_DEPENDENCIES = host-clang llvm