diff mbox

usbip: new package

Message ID CAOPBCFULJTm7iooZ8=nnpMoooaRq=1PK11hhYyyGVr=DdM2e2w@mail.gmail.com
State Superseded
Headers show

Commit Message

Marcin Bis Dec. 26, 2012, 6:44 a.m. UTC
Hi

The following patch adds new package: usbip (tools for sharing USB
devices over network).
I have tested it under various ARM builds.

Please consider adding it to Buildroot.

Signed-off-by: Marcin Bis <marcin at bis.org.pl>
--
 package/Config.in       |    1 +
 package/usbip/Config.in |   13 +++++++++++++
 package/usbip/usbip.mk  |   15 +++++++++++++++
 3 files changed, 29 insertions(+), 0 deletions(-)

Comments

Baruch Siach Dec. 26, 2012, 7:06 a.m. UTC | #1
Hi Marcin,

On Wed, Dec 26, 2012 at 07:44:32AM +0100, Marcin Bis wrote:
> The following patch adds new package: usbip (tools for sharing USB
> devices over network).
> I have tested it under various ARM builds.
> 
> Please consider adding it to Buildroot.

This sentence is not part of the commit log. You can put it below...

> 
> Signed-off-by: Marcin Bis <marcin at bis.org.pl>
> --

here.

>  package/Config.in       |    1 +
>  package/usbip/Config.in |   13 +++++++++++++
>  package/usbip/usbip.mk  |   15 +++++++++++++++
>  3 files changed, 29 insertions(+), 0 deletions(-)
> 
> diff --git a/package/Config.in b/package/Config.in
> index 3d556b2..c773c46 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -684,6 +684,7 @@ source "package/transmission/Config.in"
>  source "package/ttcp/Config.in"
>  source "package/udpcast/Config.in"
>  source "package/ulogd/Config.in"
> +source "package/usbip/Config.in"
>  source "package/ushare/Config.in"
>  source "package/vde2/Config.in"
>  source "package/vpnc/Config.in"
> diff --git a/package/usbip/Config.in b/package/usbip/Config.in
> new file mode 100644
> index 0000000..3cdbbc7
> --- /dev/null
> +++ b/package/usbip/Config.in
> @@ -0,0 +1,13 @@
> +config BR2_PACKAGE_USBIP
> +	bool "usbip"
> +	select BR2_PACKAGE_LIBGLIB2
> +	select BR2_PACKAGE_LIBSYSFS

Please add a 'depends' for each dependency of these packages. glib2 depends on 
BR2_USE_WCHAR.

> +	help
> +	  Userspace tools for sharing USB devices over TCP/IP network.
> +
> +	  http://usbip.sourceforge.net/
> +
> +	  This package adds both: client and server support.

Letting the user select the client and server support independently from each 
other would be nice, but this can be done later.

> +	  Note: For exporting or connecting to exported USB devices
> +	  additional kernel drivers are needed (available since 2.6.28
> +	  under Stagging).
> diff --git a/package/usbip/usbip.mk b/package/usbip/usbip.mk
> new file mode 100644
> index 0000000..2ec3ce9
> --- /dev/null
> +++ b/package/usbip/usbip.mk
> @@ -0,0 +1,15 @@
> +#############################################################
> +#
> +# usbip
> +#
> +#############################################################
> +
> +USBIP_VERSION = 0.1.7
> +USBIP_SITE = http://downloads.sourceforge.net/project/usbip/usbip/$(USBIP_VERSION)
> +USBIP_LICENSE = GPLv2+
> +USBIP_LICENSE_FILES = COPYING
> +USBIP_CONF_OPT = --without-tcpwrappers
> +USBIP_SUBDIR = src
> +USBIP_AUTORECONF = YES

Why is this needed? Please add an explanation comment.

You also need to add a USBIP_DEPENDENCIES listing the packages that you select 
in Config.in, to ensure correct build order.

> +
> +$(eval $(autotools-package))

baruch
Thomas Petazzoni Dec. 26, 2012, 8:49 a.m. UTC | #2
On Wed, 26 Dec 2012 09:06:12 +0200, Baruch Siach wrote:
> Hi Marcin,
> 
> On Wed, Dec 26, 2012 at 07:44:32AM +0100, Marcin Bis wrote:
> > The following patch adds new package: usbip (tools for sharing USB
> > devices over network).
> > I have tested it under various ARM builds.
> > 
> > Please consider adding it to Buildroot.
> 
> This sentence is not part of the commit log. You can put it below...
> 
> > 
> > Signed-off-by: Marcin Bis <marcin at bis.org.pl>

Please use a real e-mail here, i.e marcin@bis.org.pl

> > --
> 
> here.

And the separator should be --- and not --, if I'm correct.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 3d556b2..c773c46 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -684,6 +684,7 @@  source "package/transmission/Config.in"
 source "package/ttcp/Config.in"
 source "package/udpcast/Config.in"
 source "package/ulogd/Config.in"
+source "package/usbip/Config.in"
 source "package/ushare/Config.in"
 source "package/vde2/Config.in"
 source "package/vpnc/Config.in"
diff --git a/package/usbip/Config.in b/package/usbip/Config.in
new file mode 100644
index 0000000..3cdbbc7
--- /dev/null
+++ b/package/usbip/Config.in
@@ -0,0 +1,13 @@ 
+config BR2_PACKAGE_USBIP
+	bool "usbip"
+	select BR2_PACKAGE_LIBGLIB2
+	select BR2_PACKAGE_LIBSYSFS
+	help
+	  Userspace tools for sharing USB devices over TCP/IP network.
+
+	  http://usbip.sourceforge.net/
+
+	  This package adds both: client and server support.
+	  Note: For exporting or connecting to exported USB devices
+	  additional kernel drivers are needed (available since 2.6.28
+	  under Stagging).
diff --git a/package/usbip/usbip.mk b/package/usbip/usbip.mk
new file mode 100644
index 0000000..2ec3ce9
--- /dev/null
+++ b/package/usbip/usbip.mk
@@ -0,0 +1,15 @@ 
+#############################################################
+#
+# usbip
+#
+#############################################################
+
+USBIP_VERSION = 0.1.7
+USBIP_SITE = http://downloads.sourceforge.net/project/usbip/usbip/$(USBIP_VERSION)
+USBIP_LICENSE = GPLv2+
+USBIP_LICENSE_FILES = COPYING
+USBIP_CONF_OPT = --without-tcpwrappers
+USBIP_SUBDIR = src
+USBIP_AUTORECONF = YES
+
+$(eval $(autotools-package))