diff mbox

[v2] Revert "boot/uboot: allow to build multiple U-Boot images"

Message ID CAOMZO5D9_1g0WiTgz-TPT0w1QwP3Bonu4Lkotvw1Em4+M7Z4cQ@mail.gmail.com
State Superseded
Headers show

Commit Message

Fabio Estevam Oct. 7, 2016, 2:39 p.m. UTC
Hi Thomas,

On Fri, Oct 7, 2016 at 11:05 AM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:

> I don't think we want to revert this patch. Instead, we want to call
> "make all" unconditionally.

Like this?
diff mbox

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 7379a4d..86e5b84 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -48,6 +48,9 @@  UBOOT_MAKE_TARGET += mdbtrick
 endif
 endif

+# Call 'make all' unconditionally
+UBOOT_MAKE_TARGET += all
+
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
 UBOOT_BINS += u-boot.kwb
 UBOOT_MAKE_TARGET += u-boot.kwb
@@ -68,7 +71,7 @@  endif

 ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
 UBOOT_BINS += u-boot-dtb.img
-UBOOT_MAKE_TARGET += all u-boot-dtb.img
+UBOOT_MAKE_TARGET += u-boot-dtb.img
 endif

 ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)