diff mbox

[2/2,v8] pkg-download: silence downloads if make is silent

Message ID CAHkwnC9W6r9NqSWzF09uAKbj8xjyMFDArDeFgwNYdE7HVyjc0A@mail.gmail.com
State Deferred
Headers show

Commit Message

Fabio Porcedda Jan. 1, 2015, 6:03 p.m. UTC
On Thu, Jan 1, 2015 at 6:58 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> Fabio, All,
>
> On 2015-01-01 18:54 +0100, Fabio Porcedda spake thusly:
>> On Thu, Jan 1, 2015 at 5:50 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>> > From: Fabio Porcedda <fabio.porcedda@gmail.com>
>> >
>> > If it is a silent build (make -s -> QUIET=-q) silence all downloads, as
>> > well as the check-hash. Only stdout is redirected, stderr is still
>> > visible, for errors and warning.
>>
>> Hi Yann,
>> nice idea, i tried this patch but even if it works for check-hash and
>> svn it does not works for the git backend (e.g. libubox) and the wget
>> bakend (try it without the QUIET flags in the WGET variable).
>>
>> I don't understand the reason for this behavior.
>> Do you have an idea for this strange behavior?
>
> Damn, no. I'll have look.

Thank, i think that it must works even when the QUIET variables is not
added to the environment variables:

 diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index 9c782fe..5e74519 100644

BR

Comments

Yann E. MORIN Jan. 1, 2015, 6:08 p.m. UTC | #1
Fabio, All,

On 2015-01-01 19:03 +0100, Fabio Porcedda spake thusly:
> On Thu, Jan 1, 2015 at 6:58 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > Fabio, All,
> >
> > On 2015-01-01 18:54 +0100, Fabio Porcedda spake thusly:
> >> On Thu, Jan 1, 2015 at 5:50 PM, Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> >> > From: Fabio Porcedda <fabio.porcedda@gmail.com>
> >> >
> >> > If it is a silent build (make -s -> QUIET=-q) silence all downloads, as
> >> > well as the check-hash. Only stdout is redirected, stderr is still
> >> > visible, for errors and warning.
> >>
> >> Hi Yann,
> >> nice idea, i tried this patch but even if it works for check-hash and
> >> svn it does not works for the git backend (e.g. libubox) and the wget
> >> bakend (try it without the QUIET flags in the WGET variable).
> >>
> >> I don't understand the reason for this behavior.
> >> Do you have an idea for this strange behavior?
> >
> > Damn, no. I'll have look.
> 
> Thank, i think that it must works even when the QUIET variables is not
> added to the environment variables:

Yes, that's right.

Regards,
Yann E. MORIN.

>  diff --git a/package/pkg-download.mk b/package/pkg-download.mk
> index 9c782fe..5e74519 100644
> --- a/package/pkg-download.mk
> +++ b/package/pkg-download.mk
> @@ -8,14 +8,14 @@
>  ################################################################################
> 
>  # Download method commands
> -export WGET := $(call qstrip,$(BR2_WGET)) $(QUIET)
> +export WGET := $(call qstrip,$(BR2_WGET))
>  export SVN := $(call qstrip,$(BR2_SVN))
>  export CVS := $(call qstrip,$(BR2_CVS))
>  export BZR := $(call qstrip,$(BR2_BZR))
>  export GIT := $(call qstrip,$(BR2_GIT))
> -export HG := $(call qstrip,$(BR2_HG)) $(QUIET)
> -export SCP := $(call qstrip,$(BR2_SCP)) $(QUIET)
> -SSH := $(call qstrip,$(BR2_SSH)) $(QUIET)
> +export HG := $(call qstrip,$(BR2_HG))
> +export SCP := $(call qstrip,$(BR2_SCP))
> +SSH := $(call qstrip,$(BR2_SSH))
>  export LOCALFILES := $(call qstrip,$(BR2_LOCALFILES))
> 
>  DL_WRAPPER = support/download/dl-wrapper
> 
> BR
> -- 
> Fabio Porcedda
diff mbox

Patch

--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -8,14 +8,14 @@ 
 ################################################################################

 # Download method commands
-export WGET := $(call qstrip,$(BR2_WGET)) $(QUIET)
+export WGET := $(call qstrip,$(BR2_WGET))
 export SVN := $(call qstrip,$(BR2_SVN))
 export CVS := $(call qstrip,$(BR2_CVS))
 export BZR := $(call qstrip,$(BR2_BZR))
 export GIT := $(call qstrip,$(BR2_GIT))
-export HG := $(call qstrip,$(BR2_HG)) $(QUIET)
-export SCP := $(call qstrip,$(BR2_SCP)) $(QUIET)
-SSH := $(call qstrip,$(BR2_SSH)) $(QUIET)
+export HG := $(call qstrip,$(BR2_HG))
+export SCP := $(call qstrip,$(BR2_SCP))
+SSH := $(call qstrip,$(BR2_SSH))
 export LOCALFILES := $(call qstrip,$(BR2_LOCALFILES))

 DL_WRAPPER = support/download/dl-wrapper