diff mbox

libxml-parser-perl: Pass USE_MM_LD_RUN_PATH to MakeMaker.

Message ID CAFbHwiS6diQ_fskroM0bDEqHgxCvy2w3jP2-s7o1RcrK9mzhcA@mail.gmail.com
State Accepted, archived
Headers show

Commit Message

Will Newton March 30, 2012, 8:04 a.m. UTC
Red Hat versions of perl do not honour the setting of LD_RUN_PATH
without this option. This leads to perl shared objects being installed
without an rpath set which causes problems for target tools when
searching for dependant shared libraries.

Signed-off-by: Will Newton <will.newton@imgtec.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/libxml-parser-perl/libxml-parser-perl.mk |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

Comments

Peter Korsgaard March 30, 2012, 8:15 a.m. UTC | #1
>>>>> "Will" == Will Newton <will.newton@gmail.com> writes:

Hi,

 Will> Red Hat versions of perl do not honour the setting of LD_RUN_PATH
 Will> without this option. This leads to perl shared objects being installed
 Will> without an rpath set which causes problems for target tools when
 Will> searching for dependant shared libraries.

 Will> Signed-off-by: Will Newton <will.newton@imgtec.com>
 Will> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 Will> ---
 Will>  package/libxml-parser-perl/libxml-parser-perl.mk |    1 +
 Will>  1 files changed, 1 insertions(+), 0 deletions(-)

 Will> diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk
 Will> b/package/libxml-parser-perl/libxml-parser-perl.mk
 Will> index 9e6f2ec..70d0918 100644
 Will> --- a/package/libxml-parser-perl/libxml-parser-perl.mk
 Will> +++ b/package/libxml-parser-perl/libxml-parser-perl.mk
 Will> @@ -18,6 +18,7 @@ define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
 Will>          INSTALLDIRS=site \
 Will>          INSTALLSITELIB=$(HOST_DIR)/usr/lib/perl \
 Will>          INSTALLSITEARCH=$(HOST_DIR)/usr/lib/perl \
 Will> +	USE_MM_LD_RUN_PATH=1 \

Indentation is wrong (spaces vs tabs), but I fixed that and committed,
thanks.
diff mbox

Patch

diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk
b/package/libxml-parser-perl/libxml-parser-perl.mk
index 9e6f2ec..70d0918 100644
--- a/package/libxml-parser-perl/libxml-parser-perl.mk
+++ b/package/libxml-parser-perl/libxml-parser-perl.mk
@@ -18,6 +18,7 @@  define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
         INSTALLDIRS=site \
         INSTALLSITELIB=$(HOST_DIR)/usr/lib/perl \
         INSTALLSITEARCH=$(HOST_DIR)/usr/lib/perl \
+	USE_MM_LD_RUN_PATH=1 \
  )
 endef