@@ -778,6 +778,7 @@ source "package/fftw/Config.in"
source "package/flann/Config.in"
source "package/glibmm/Config.in"
source "package/gmp/Config.in"
+source "package/isl/Config.in"
source "package/gsl/Config.in"
source "package/gtest/Config.in"
source "package/libargtable2/Config.in"
new file mode 100644
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_ISL
+ bool "isl"
+ select BR2_PACKAGE_GMP
+ help
+ Library for manipulating sets and relations of integer points bounded by linear constraints.
+
+ http://www.multiprecision.org/
new file mode 100644
@@ -0,0 +1,28 @@
+--- a/ltmain.sh 2014-04-23 23:52:39.104640815 +0000
++++ b/ltmain.sh 2014-04-23 23:56:59.818000038 +0000
+@@ -2583,8 +2583,8 @@
+ # was found and let the user know that the "--tag" command
+ # line option must be used.
+ if test -z "$tagname"; then
+- func_echo "unable to infer tagged configuration"
+- func_fatal_error "specify a tag with '--tag'"
++ func_echo "defaulting to \`CC'"
++ func_echo "if this is not correct, specify a tag with \`--tag'"
+ # else
+ # func_verbose "using $tagname tagged configuration"
+ fi
+@@ -4172,8 +4172,12 @@
+ # At present, this check doesn't affect windows .dll's that
+ # are installed into $libdir/../bin (currently, that works fine)
+ # but it's something to keep an eye on.
+- test "$inst_prefix_dir" = "$destdir" && \
+- func_fatal_error "error: cannot install '$file' to a directory not ending in $libdir"
++ #
++ # This breaks install into our staging area. -PB
++ #
++ # test "$inst_prefix_dir" = "$destdir" && \
++ # func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
++
+
+ if test -n "$inst_prefix_dir"; then
+ # Stick the inst_prefix_dir data into the link command.
new file mode 100644
@@ -0,0 +1,17 @@
+################################################################################
+#
+# isl
+#
+################################################################################
+
+ISL_VERSION = 0.13
+ISL_SITE = http://isl.gforge.inria.fr/
+ISL_LICENSE = MIT
+ISL_LICENSE_FILES = MIT
+ISL_INSTALL_STAGING = YES
+ISL_DEPENDENCIES = gmp
+
+ISL_LIBTOOL_PATCH = NO
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))
Signed-off-by: Steve Thomas <scjthm@live.com> --- package/Config.in | 1 + package/isl/Config.in | 7 +++++++ package/isl/isl-000-libtool.patch | 28 ++++++++++++++++++++++++++++ package/isl/isl.mk | 17 +++++++++++++++++ 4 files changed, 53 insertions(+) create mode 100644 package/isl/Config.in create mode 100644 package/isl/isl-000-libtool.patch create mode 100644 package/isl/isl.mk