diff mbox series

[1/2] br2-external: make the list of external trees public

Message ID 912929d06f13459e472f6badf7e9251792b272fe.1676112761.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series br2-external: export list and versions of used extrenal trees (branch yem/br2-ext-name-ver) | expand

Commit Message

Yann E. MORIN Feb. 11, 2023, 10:52 a.m. UTC
Currently, the list of external trees is a private variable, but for
debugging or compliance, one may need to get that list.

Add a Kconfig option so that the list appears in the .config file, and
export the already existing .mk variable in the environment, so that
post-build or post-image scripts can use it.

Reported-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
 support/scripts/br2-external | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN May 13, 2023, 10:06 a.m. UTC | #1
All,

On 2023-02-11 11:52 +0100, Yann E. MORIN spake thusly:
> Currently, the list of external trees is a private variable, but for
> debugging or compliance, one may need to get that list.
> 
> Add a Kconfig option so that the list appears in the .config file, and
> export the already existing .mk variable in the environment, so that
> post-build or post-image scripts can use it.
> 
> Reported-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  support/scripts/br2-external | 10 +++++++++-
>  1 file changed, 9 insertions(+), 1 deletion(-)
> 
> diff --git a/support/scripts/br2-external b/support/scripts/br2-external
> index 2c33e6eacc..5815c6ded0 100755
> --- a/support/scripts/br2-external
> +++ b/support/scripts/br2-external
> @@ -126,7 +126,7 @@ do_mk() {
>          done
>          printf '\n'
>  
> -        printf 'BR2_EXTERNAL_NAMES = \n'
> +        printf 'export BR2_EXTERNAL_NAMES = \n'
>          printf 'BR2_EXTERNAL_DIRS = \n'
>          printf 'BR2_EXTERNAL_MKS = \n'
>  
> @@ -181,6 +181,14 @@ do_kconfig() {
>  
>      printf 'menu "External options"\n\n' >>"${outputdir}/.br2-external.in.menus"
>  
> +    {
> +        printf 'config BR2_EXTERNAL_NAMES\n'
> +        printf '\tstring\n'
> +        # Use star-expansion: we really one a single arg.
> +        printf '\tdefault "%s"\n' "${BR2_EXT_NAMES[*]}"
> +        printf '\n'
> +    } >>"${outputdir}/.br2-external.in.paths"
> +
>      for br2_name in "${BR2_EXT_NAMES[@]}"; do
>          eval br2_desc="\"\${BR2_EXT_DESCS_${br2_name}}\""
>          eval br2_ext="\"\${BR2_EXT_PATHS_${br2_name}}\""
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/support/scripts/br2-external b/support/scripts/br2-external
index 2c33e6eacc..5815c6ded0 100755
--- a/support/scripts/br2-external
+++ b/support/scripts/br2-external
@@ -126,7 +126,7 @@  do_mk() {
         done
         printf '\n'
 
-        printf 'BR2_EXTERNAL_NAMES = \n'
+        printf 'export BR2_EXTERNAL_NAMES = \n'
         printf 'BR2_EXTERNAL_DIRS = \n'
         printf 'BR2_EXTERNAL_MKS = \n'
 
@@ -181,6 +181,14 @@  do_kconfig() {
 
     printf 'menu "External options"\n\n' >>"${outputdir}/.br2-external.in.menus"
 
+    {
+        printf 'config BR2_EXTERNAL_NAMES\n'
+        printf '\tstring\n'
+        # Use star-expansion: we really one a single arg.
+        printf '\tdefault "%s"\n' "${BR2_EXT_NAMES[*]}"
+        printf '\n'
+    } >>"${outputdir}/.br2-external.in.paths"
+
     for br2_name in "${BR2_EXT_NAMES[@]}"; do
         eval br2_desc="\"\${BR2_EXT_DESCS_${br2_name}}\""
         eval br2_ext="\"\${BR2_EXT_PATHS_${br2_name}}\""