diff mbox

[01/30] package/matchbox: make matchbox-lib a real package

Message ID 8beb050842a9ca88e919dae89b382bfe7a1701ff.1429725549.git.yann.morin.1998@free.fr
State Changes Requested
Headers show

Commit Message

Yann E. MORIN April 22, 2015, 6:09 p.m. UTC
Currently, the matchbox package is using weird, legacy constrcuts to
build its different parts.

Notably, it adds matchbox-lib to the list of packages to build, even
though it is not a real package since it does not have a Kconfig entry.

Fix that:
  - add a Kconfig entry for matchbox-lib
  - select it from the top-level matchbox package

Note that matchbox-common already depends on matchbox-lib.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/matchbox/Config.in              | 3 +++
 package/matchbox/matchbox-lib/Config.in | 2 ++
 package/matchbox/matchbox.mk            | 2 +-
 3 files changed, 6 insertions(+), 1 deletion(-)
 create mode 100644 package/matchbox/matchbox-lib/Config.in

Comments

Arnout Vandecappelle April 23, 2015, 9:29 p.m. UTC | #1
On 04/22/15 20:09, Yann E. MORIN wrote:
> Currently, the matchbox package is using weird, legacy constrcuts to
> build its different parts.
> 
> Notably, it adds matchbox-lib to the list of packages to build, even
> though it is not a real package since it does not have a Kconfig entry.
> 
> Fix that:
>   - add a Kconfig entry for matchbox-lib
>   - select it from the top-level matchbox package
> 
> Note that matchbox-common already depends on matchbox-lib.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Some suggestions below for handling the one-level-less approach.

> ---
>  package/matchbox/Config.in              | 3 +++
>  package/matchbox/matchbox-lib/Config.in | 2 ++
>  package/matchbox/matchbox.mk            | 2 +-
>  3 files changed, 6 insertions(+), 1 deletion(-)
>  create mode 100644 package/matchbox/matchbox-lib/Config.in
> 
> diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
> index 7867ae3..70cc168 100644
> --- a/package/matchbox/Config.in
> +++ b/package/matchbox/Config.in
> @@ -7,6 +7,7 @@ config BR2_PACKAGE_MATCHBOX
>  	select BR2_PACKAGE_XLIB_LIBXEXT
>  	select BR2_PACKAGE_XLIB_LIBXDAMAGE
>  	select BR2_PACKAGE_XLIB_LIBXCURSOR
> +	select BR2_PACKAGE_MATCHBOX_LIB
>  	help
>  	  Matchbox is an Open Source base environment for the X Window
>  	  System running on non-desktop embedded platforms such as
> @@ -17,6 +18,8 @@ config BR2_PACKAGE_MATCHBOX
>  
>  if BR2_PACKAGE_MATCHBOX
>  
> +source "package/matchbox/matchbox-lib/Config.in"

 This should obviously move to package/Config.in, and the condition should be
copied.


 Regards,
 Arnout

> +
>  config BR2_PACKAGE_MATCHBOX_PANEL
>  	bool "Matchbox Panel"
>  	help
> diff --git a/package/matchbox/matchbox-lib/Config.in b/package/matchbox/matchbox-lib/Config.in
> new file mode 100644
> index 0000000..480e6fe
> --- /dev/null
> +++ b/package/matchbox/matchbox-lib/Config.in
> @@ -0,0 +1,2 @@
> +config BR2_PACKAGE_MATCHBOX_LIB
> +	bool
> diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
> index fe1a7db..e367df2 100644
> --- a/package/matchbox/matchbox.mk
> +++ b/package/matchbox/matchbox.mk
> @@ -1,4 +1,4 @@
>  ifeq ($(BR2_PACKAGE_MATCHBOX),y)
>  include $(sort $(wildcard package/matchbox/*/*.mk))
> -PACKAGES += matchbox-lib matchbox-wm
> +PACKAGES += matchbox-wm
>  endif
>
diff mbox

Patch

diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
index 7867ae3..70cc168 100644
--- a/package/matchbox/Config.in
+++ b/package/matchbox/Config.in
@@ -7,6 +7,7 @@  config BR2_PACKAGE_MATCHBOX
 	select BR2_PACKAGE_XLIB_LIBXEXT
 	select BR2_PACKAGE_XLIB_LIBXDAMAGE
 	select BR2_PACKAGE_XLIB_LIBXCURSOR
+	select BR2_PACKAGE_MATCHBOX_LIB
 	help
 	  Matchbox is an Open Source base environment for the X Window
 	  System running on non-desktop embedded platforms such as
@@ -17,6 +18,8 @@  config BR2_PACKAGE_MATCHBOX
 
 if BR2_PACKAGE_MATCHBOX
 
+source "package/matchbox/matchbox-lib/Config.in"
+
 config BR2_PACKAGE_MATCHBOX_PANEL
 	bool "Matchbox Panel"
 	help
diff --git a/package/matchbox/matchbox-lib/Config.in b/package/matchbox/matchbox-lib/Config.in
new file mode 100644
index 0000000..480e6fe
--- /dev/null
+++ b/package/matchbox/matchbox-lib/Config.in
@@ -0,0 +1,2 @@ 
+config BR2_PACKAGE_MATCHBOX_LIB
+	bool
diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
index fe1a7db..e367df2 100644
--- a/package/matchbox/matchbox.mk
+++ b/package/matchbox/matchbox.mk
@@ -1,4 +1,4 @@ 
 ifeq ($(BR2_PACKAGE_MATCHBOX),y)
 include $(sort $(wildcard package/matchbox/*/*.mk))
-PACKAGES += matchbox-lib matchbox-wm
+PACKAGES += matchbox-wm
 endif