diff mbox series

package/libcurl: fix crypto backend selection

Message ID 7568ca93d2d360efc2c6096406b8d9af533dec86.1667154015.git.baruch@tkos.co.il
State Accepted
Headers show
Series package/libcurl: fix crypto backend selection | expand

Commit Message

Baruch Siach Oct. 30, 2022, 6:20 p.m. UTC
Since version 7.77 --with-ssl that used to select OpenSSL renamed to
--with-openssl. --without-ssl changed to mean no crypto backend.

Only in version 7.86 setting both --without-ssl and some other crypto
parameter became a hard configure error.

Update OpenSSL selection parameter, and add --without-ssl explicitly for
the case of no selected crypto backend.

Fixes:
http://autobuild.buildroot.net/results/05e9cb71619e640849c27b2984d0df671a9f86c5/
http://autobuild.buildroot.net/results/5a4a905de2a232a38916f03278d0a3cbd8a29711/
http://autobuild.buildroot.net/results/4432314aa13d4acc8fce27f79177f82298ae0626/

Cc: Matt Weber <matthew.weber@collins.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/libcurl/libcurl.mk | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Oct. 30, 2022, 6:34 p.m. UTC | #1
Baruch, All,

On 2022-10-30 20:20 +0200, Baruch Siach via buildroot spake thusly:
> Since version 7.77 --with-ssl that used to select OpenSSL renamed to
> --with-openssl. --without-ssl changed to mean no crypto backend.
> 
> Only in version 7.86 setting both --without-ssl and some other crypto
> parameter became a hard configure error.
> 
> Update OpenSSL selection parameter, and add --without-ssl explicitly for
> the case of no selected crypto backend.
> 
> Fixes:
> http://autobuild.buildroot.net/results/05e9cb71619e640849c27b2984d0df671a9f86c5/
> http://autobuild.buildroot.net/results/5a4a905de2a232a38916f03278d0a3cbd8a29711/
> http://autobuild.buildroot.net/results/4432314aa13d4acc8fce27f79177f82298ae0626/
> 
> Cc: Matt Weber <matthew.weber@collins.com>
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libcurl/libcurl.mk | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
> index 3c3ad082fc65..8de43581073d 100644
> --- a/package/libcurl/libcurl.mk
> +++ b/package/libcurl/libcurl.mk
> @@ -50,6 +50,10 @@ endif
>  
>  LIBCURL_CONFIG_SCRIPTS = curl-config
>  
> +ifeq ($(BR2_PACKAGE_LIBCURL_TLS_NONE),y)
> +LIBCURL_CONF_OPTS += --without-ssl
> +endif
> +
>  ifeq ($(BR2_PACKAGE_LIBCURL_OPENSSL),y)
>  LIBCURL_DEPENDENCIES += openssl
>  # configure adds the cross openssl dir to LD_LIBRARY_PATH which screws up
> @@ -57,10 +61,10 @@ LIBCURL_DEPENDENCIES += openssl
>  # Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
>  # are found first.
>  LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)/lib:/usr/lib
> -LIBCURL_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr \
> +LIBCURL_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr \
>  	--with-ca-path=/etc/ssl/certs
>  else
> -LIBCURL_CONF_OPTS += --without-ssl
> +LIBCURL_CONF_OPTS += --without-openssl
>  endif
>  
>  ifeq ($(BR2_PACKAGE_LIBCURL_BEARSSL),y)
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Nov. 8, 2022, 7:48 p.m. UTC | #2
>>>>> "Baruch" == Baruch Siach via buildroot <buildroot@buildroot.org> writes:

 > Since version 7.77 --with-ssl that used to select OpenSSL renamed to
 > --with-openssl. --without-ssl changed to mean no crypto backend.

 > Only in version 7.86 setting both --without-ssl and some other crypto
 > parameter became a hard configure error.

 > Update OpenSSL selection parameter, and add --without-ssl explicitly for
 > the case of no selected crypto backend.

 > Fixes:
 > http://autobuild.buildroot.net/results/05e9cb71619e640849c27b2984d0df671a9f86c5/
 > http://autobuild.buildroot.net/results/5a4a905de2a232a38916f03278d0a3cbd8a29711/
 > http://autobuild.buildroot.net/results/4432314aa13d4acc8fce27f79177f82298ae0626/

 > Cc: Matt Weber <matthew.weber@collins.com>
 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2022.08.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 3c3ad082fc65..8de43581073d 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -50,6 +50,10 @@  endif
 
 LIBCURL_CONFIG_SCRIPTS = curl-config
 
+ifeq ($(BR2_PACKAGE_LIBCURL_TLS_NONE),y)
+LIBCURL_CONF_OPTS += --without-ssl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCURL_OPENSSL),y)
 LIBCURL_DEPENDENCIES += openssl
 # configure adds the cross openssl dir to LD_LIBRARY_PATH which screws up
@@ -57,10 +61,10 @@  LIBCURL_DEPENDENCIES += openssl
 # Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
 # are found first.
 LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)/lib:/usr/lib
-LIBCURL_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr \
+LIBCURL_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr \
 	--with-ca-path=/etc/ssl/certs
 else
-LIBCURL_CONF_OPTS += --without-ssl
+LIBCURL_CONF_OPTS += --without-openssl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL_BEARSSL),y)