diff mbox series

linux: add a comment about CONFIG_EXTRA_FIRMWARE requirement

Message ID 6b4488278264afdbe3614a452671c3a89220e2f8.1651720827.git.baruch@tkos.co.il
State Accepted
Headers show
Series linux: add a comment about CONFIG_EXTRA_FIRMWARE requirement | expand

Commit Message

Baruch Siach May 5, 2022, 3:20 a.m. UTC
Explain why the kernel needs firmware packages as build time
dependencies.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 linux/linux.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle May 5, 2022, 9 p.m. UTC | #1
On 05/05/2022 05:20, Baruch Siach via buildroot wrote:
> Explain why the kernel needs firmware packages as build time
> dependencies.
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   linux/linux.mk | 6 +++++-
>   1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index 7ff7b05042e4..e0a1ff74f998 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -70,7 +70,11 @@ LINUX_MAKE_ENV = \
>   	BR_BINARIES_DIR=$(BINARIES_DIR)
>   
>   LINUX_INSTALL_IMAGES = YES
> -LINUX_DEPENDENCIES = host-kmod \
> +LINUX_DEPENDENCIES = host-kmod
> +
> +# The kernel CONFIG_EXTRA_FIRMWARE feature requires firmware files at build
> +# time. Make sure they are available before the kernel builds.
> +LINUX_DEPENDENCIES += \
>   	$(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode) \
>   	$(if $(BR2_PACKAGE_LINUX_FIRMWARE),linux-firmware) \
>   	$(if $(BR2_PACKAGE_WIRELESS_REGDB),wireless-regdb)
Peter Korsgaard May 28, 2022, 9:03 a.m. UTC | #2
>>>>> "Baruch" == Baruch Siach via buildroot <buildroot@buildroot.org> writes:

 > Explain why the kernel needs firmware packages as build time
 > dependencies.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 7ff7b05042e4..e0a1ff74f998 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -70,7 +70,11 @@  LINUX_MAKE_ENV = \
 	BR_BINARIES_DIR=$(BINARIES_DIR)
 
 LINUX_INSTALL_IMAGES = YES
-LINUX_DEPENDENCIES = host-kmod \
+LINUX_DEPENDENCIES = host-kmod
+
+# The kernel CONFIG_EXTRA_FIRMWARE feature requires firmware files at build
+# time. Make sure they are available before the kernel builds.
+LINUX_DEPENDENCIES += \
 	$(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode) \
 	$(if $(BR2_PACKAGE_LINUX_FIRMWARE),linux-firmware) \
 	$(if $(BR2_PACKAGE_WIRELESS_REGDB),wireless-regdb)