diff mbox

[try,4] wine: New package

Message ID 54BED214.6080601@dawncrow.de
State Superseded
Headers show

Commit Message

André Zwing Jan. 20, 2015, 10:09 p.m. UTC
Adds new package: wine

  Wine is a compatibility layer capable of running Windows applications on Linux.

Signed-off-by: André Hentschel <nerv@dawncrow.de>
---
I hope i addressed all the comments in the correct manner
try 2: Fix issue spotted by baruch
try 3: Added comments, added hash file, fixed X11 check, depend on internal toolchain, added bison and flex to host dependencies
try 4: instead of depending on internal toolchains add the expected tuple via --host

 package/Config.in      |   1 +
 package/wine/Config.in |  21 ++++
 package/wine/wine.hash |   2 +
 package/wine/wine.mk   | 270 +++++++++++++++++++++++++++++++++++++++++++++++++
 4 files changed, 294 insertions(+)

Comments

Romain Naour Jan. 21, 2015, 11:07 p.m. UTC | #1
Hi André,

Le 20/01/2015 23:09, André Hentschel a écrit :
> Adds new package: wine
> 
>   Wine is a compatibility layer capable of running Windows applications on Linux.
> 
> Signed-off-by: André Hentschel <nerv@dawncrow.de>
> ---
> I hope i addressed all the comments in the correct manner
> try 2: Fix issue spotted by baruch
> try 3: Added comments, added hash file, fixed X11 check, depend on internal toolchain, added bison and flex to host dependencies
> try 4: instead of depending on internal toolchains add the expected tuple via --host
> 
>  package/Config.in      |   1 +
>  package/wine/Config.in |  21 ++++
>  package/wine/wine.hash |   2 +
>  package/wine/wine.mk   | 270 +++++++++++++++++++++++++++++++++++++++++++++++++
>  4 files changed, 294 insertions(+)
> 

[...]

> +
> +# To support freetype in wine we also need freetype in host-wine for the cross compiling tools
> +ifeq ($(BR2_PACKAGE_FREETYPE),y)
> +	WINE_CONF_OPTS += --with-freetype
> +	HOST_WINE_CONF_OPTS += --with-freetype
> +	WINE_DEPENDENCIES += freetype
> +	HOST_WINE_DEPENDENCIES += host-freetype
> +else
> +	WINE_CONF_OPTS += --without-freetype
> +	HOST_WINE_CONF_OPTS += --without-freetype
> +endif

I'm building your wine package on my 64bits host and the build fail
because freetype library in HOST_DIR is build for it, but wine is
build for 32bits host.

see my config.log output:
configure:10886: checking for -lfreetype
configure:10911: /usr/bin/gcc -m32 -o conftest -O2 -I/home/naourr/git/buildroot/test/wine/host/usr/include -I/home/naourr/git/buildroot/test/wine/host/usr/include -I/home/naourr/git/buildroot/test/wine/host/usr/include/freetype2   -L/home/naourr/git/buildroot/test/wine/host/lib -L/home/naourr/git/buildroot/test/wine/host/usr/lib -Wl,-rpath,/home/naourr/git/buildroot/test/wine/host/usr/lib conftest.c -lfreetype -L/home/naourr/git/buildroot/test/wine/host/usr/lib -lfreetype    >&5
/usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /usr/lib64/libfreetype.so when searching for -lfreetype
/usr/bin/ld: cannot find -lfreetype
/usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /usr/lib64/libfreetype.so when searching for -lfreetype
/usr/bin/ld: cannot find -lfreetype
collect2: error: ld returned 1 exit status

It seems that --enable-win64 must be added to HOST_WINE_CONF_OPTS
for 64bits host.

Best regards,
Romain Naour

[...]
André Zwing Jan. 21, 2015, 11:20 p.m. UTC | #2
Am 22.01.2015 um 00:07 schrieb Romain Naour:
> I'm building your wine package on my 64bits host and the build fail
> because freetype library in HOST_DIR is build for it, but wine is
> build for 32bits host.
> 
> see my config.log output:
> configure:10886: checking for -lfreetype
> configure:10911: /usr/bin/gcc -m32 -o conftest -O2 -I/home/naourr/git/buildroot/test/wine/host/usr/include -I/home/naourr/git/buildroot/test/wine/host/usr/include -I/home/naourr/git/buildroot/test/wine/host/usr/include/freetype2   -L/home/naourr/git/buildroot/test/wine/host/lib -L/home/naourr/git/buildroot/test/wine/host/usr/lib -Wl,-rpath,/home/naourr/git/buildroot/test/wine/host/usr/lib conftest.c -lfreetype -L/home/naourr/git/buildroot/test/wine/host/usr/lib -lfreetype    >&5
> /usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: skipping incompatible /usr/lib64/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: cannot find -lfreetype
> /usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: skipping incompatible /home/naourr/git/buildroot/test/wine/host/usr/lib/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: skipping incompatible /usr/lib64/libfreetype.so when searching for -lfreetype
> /usr/bin/ld: cannot find -lfreetype
> collect2: error: ld returned 1 exit status
> 
> It seems that --enable-win64 must be added to HOST_WINE_CONF_OPTS
> for 64bits host.

Wow, good catch, thanks!
Guess it didn't failed on my machine because i also have 32-bit freetype installed on the host.
Yann E. MORIN Jan. 21, 2015, 11:35 p.m. UTC | #3
André, All,

On 2015-01-20 23:09 +0100, André Hentschel spake thusly:
> Adds new package: wine

Sorry for jumoing late in the wagon, but here are some minor comments...

[--SNIP--]
> diff --git a/package/wine/Config.in b/package/wine/Config.in
> new file mode 100644
> index 0000000..e8e2091
> --- /dev/null
> +++ b/package/wine/Config.in
> @@ -0,0 +1,21 @@
> +config BR2_PACKAGE_WINE
> +	bool "wine"
> +	depends on BR2_INET_IPV6
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
> +	depends on BR2_TOOLCHAIN_USES_GLIBC
> +	# Wine has much CPU specific code
> +	depends on BR2_i386 || BR2_x86_64
> +	help
> +	  Wine is a compatibility layer capable of running
> +	  Windows applications on Linux. Instead of simulating internal
> +	  Windows logic like a virtual machine or emulator,
> +	  Wine translates Windows API calls into POSIX calls on-the-fly,
> +	  eliminating the performance and memory penalties of other methods.
> +
> +	  http://www.winehq.org
> +
> +comment "wine needs a (e)glibc toolchain w/ IPv6, threads"
> +	depends on BR2_i386 || BR2_x86_64
> +	depends on BR2_TOOLCHAIN_BUILDROOT

Did you forget to remove that dependency for the comment?

> +	depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
> +	depends on !BR2_TOOLCHAIN_USES_GLIBC
> diff --git a/package/wine/wine.hash b/package/wine/wine.hash
> new file mode 100644
> index 0000000..7ffc45e
> --- /dev/null
> +++ b/package/wine/wine.hash
> @@ -0,0 +1,2 @@
> +# Locally computed
> +sha256 0f46dd29b278a3352206b49680f0ac3bfa107e65cb40cb4af51c137f0ebeb271 wine-1.6.2.tar.bz2
> diff --git a/package/wine/wine.mk b/package/wine/wine.mk
> new file mode 100644
> index 0000000..96afcb6
> --- /dev/null
> +++ b/package/wine/wine.mk
> @@ -0,0 +1,270 @@
> +################################################################################
> +#
> +# wine
> +#
> +################################################################################
> +
> +WINE_VERSION = 1.6.2
> +WINE_SOURCE = wine-$(WINE_VERSION).tar.bz2
> +WINE_SITE = http://source.winehq.org/git/wine.git/snapshot/
> +WINE_LICENSE = LGPLv2.1+
> +WINE_LICENSE_FILES = COPYING.LIB
> +WINE_INSTALL_TARGET = YES
> +WINE_DEPENDENCIES = host-wine
> +HOST_WINE_DEPENDENCIES = host-bison host-flex
> +
> +# Wine needs its own directory structure and tools for cross compiling
> +WINE_CONF_OPTS = \
> +	--with-wine-tools=../host-wine-$(WINE_VERSION) \
> +	--disable-tests \
> +	--without-opengl \
> +	$(if $(BR2_ARCH_IS_64),--enable-win64)
> +
> +# Wine needs the host tupel of the external toolchain for cross compiling
> +ifeq ($(BR2_TOOLCHAIN_BUILDROOT),)
> +	WINE_CONF_OPTS += --host=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
> +endif

I know this has already been discussed at length on the list, but it
really warrants a bit more explanations here.

> +ifeq ($(BR2_PACKAGE_CUPS),y)
> +	WINE_CONF_OPTS += --with-cups
> +	WINE_DEPENDENCIES += cups
> +else
> +	WINE_CONF_OPTS += --without-cups
> +endif

I do appreciate that you did all that work to enable/disable optional
features. That's a great work! :-)

However, for very complex packages, my opinion is that it is much
simpler to review and test (and write!) a new complex package with
everything disabled. It makes for smaller patches to review, and faster
builds to test. Then, new features can be added one by one in subsequent
patches, once the core has been upstreamed.

Note that I do not ask you to remove that, jsut keep it. Just suggesting
that in case you're fool^Wbold enough to try packaging some other big
stuff  in the future! Hehe! ;-)

[--SNIP--]
> +HOST_WINE_CONF_OPTS += \
> +	--disable-tests \
> +	--disable-win16 \
[--SNIP--]
> +	--without-xxf86vm \
> +	--without-zlib

Like you disabled everthing here.

> +$(eval $(autotools-package))
> +$(eval $(host-autotools-package))

I haven't much more to say, I'll try to have some time this WE to have a
further look.

Thanks! :-)

Regards,
Yann E. MORIN.
André Zwing Jan. 22, 2015, 10:13 p.m. UTC | #4
Am 22.01.2015 um 00:35 schrieb Yann E. MORIN:
> André, All,
> 
> On 2015-01-20 23:09 +0100, André Hentschel spake thusly:
>> Adds new package: wine
> 
> Sorry for jumoing late in the wagon, but here are some minor comments...

Hi Yann,

Thx for the review!

>> +comment "wine needs a (e)glibc toolchain w/ IPv6, threads"
>> +	depends on BR2_i386 || BR2_x86_64
>> +	depends on BR2_TOOLCHAIN_BUILDROOT
> 
> Did you forget to remove that dependency for the comment?

yes, thx

>> +# Wine needs the host tupel of the external toolchain for cross compiling
>> +ifeq ($(BR2_TOOLCHAIN_BUILDROOT),)
>> +	WINE_CONF_OPTS += --host=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
>> +endif
> 
> I know this has already been discussed at length on the list, but it
> really warrants a bit more explanations here.

sure, done

>> +ifeq ($(BR2_PACKAGE_CUPS),y)
>> +	WINE_CONF_OPTS += --with-cups
>> +	WINE_DEPENDENCIES += cups
>> +else
>> +	WINE_CONF_OPTS += --without-cups
>> +endif
> 
> I do appreciate that you did all that work to enable/disable optional
> features. That's a great work! :-)
> 
> However, for very complex packages, my opinion is that it is much
> simpler to review and test (and write!) a new complex package with
> everything disabled. It makes for smaller patches to review, and faster
> builds to test. Then, new features can be added one by one in subsequent
> patches, once the core has been upstreamed.
> 
> Note that I do not ask you to remove that, jsut keep it. Just suggesting
> that in case you're fool^Wbold enough to try packaging some other big
> stuff  in the future! Hehe! ;-)

:D
honestly i'd have a project in mind...

> [--SNIP--]
>> +HOST_WINE_CONF_OPTS += \
>> +	--disable-tests \
>> +	--disable-win16 \
> [--SNIP--]
>> +	--without-xxf86vm \
>> +	--without-zlib
> 
> Like you disabled everthing here.

added a comment for this now, too. as it has its reason.


>> +$(eval $(autotools-package))
>> +$(eval $(host-autotools-package))
> 
> I haven't much more to say, I'll try to have some time this WE to have a
> further look.

cool, i'll send try 5 as soon as i tested it
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 266de13..fd262ad 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1013,6 +1013,7 @@  menu "Miscellaneous"
 	source "package/snowball-init/Config.in"
 	source "package/sound-theme-borealis/Config.in"
 	source "package/sound-theme-freedesktop/Config.in"
+	source "package/wine/Config.in"
 endmenu

 menu "Networking applications"
diff --git a/package/wine/Config.in b/package/wine/Config.in
new file mode 100644
index 0000000..e8e2091
--- /dev/null
+++ b/package/wine/Config.in
@@ -0,0 +1,21 @@ 
+config BR2_PACKAGE_WINE
+	bool "wine"
+	depends on BR2_INET_IPV6
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	depends on BR2_TOOLCHAIN_USES_GLIBC
+	# Wine has much CPU specific code
+	depends on BR2_i386 || BR2_x86_64
+	help
+	  Wine is a compatibility layer capable of running
+	  Windows applications on Linux. Instead of simulating internal
+	  Windows logic like a virtual machine or emulator,
+	  Wine translates Windows API calls into POSIX calls on-the-fly,
+	  eliminating the performance and memory penalties of other methods.
+
+	  http://www.winehq.org
+
+comment "wine needs a (e)glibc toolchain w/ IPv6, threads"
+	depends on BR2_i386 || BR2_x86_64
+	depends on BR2_TOOLCHAIN_BUILDROOT
+	depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+	depends on !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/wine/wine.hash b/package/wine/wine.hash
new file mode 100644
index 0000000..7ffc45e
--- /dev/null
+++ b/package/wine/wine.hash
@@ -0,0 +1,2 @@ 
+# Locally computed
+sha256 0f46dd29b278a3352206b49680f0ac3bfa107e65cb40cb4af51c137f0ebeb271 wine-1.6.2.tar.bz2
diff --git a/package/wine/wine.mk b/package/wine/wine.mk
new file mode 100644
index 0000000..96afcb6
--- /dev/null
+++ b/package/wine/wine.mk
@@ -0,0 +1,270 @@ 
+################################################################################
+#
+# wine
+#
+################################################################################
+
+WINE_VERSION = 1.6.2
+WINE_SOURCE = wine-$(WINE_VERSION).tar.bz2
+WINE_SITE = http://source.winehq.org/git/wine.git/snapshot/
+WINE_LICENSE = LGPLv2.1+
+WINE_LICENSE_FILES = COPYING.LIB
+WINE_INSTALL_TARGET = YES
+WINE_DEPENDENCIES = host-wine
+HOST_WINE_DEPENDENCIES = host-bison host-flex
+
+# Wine needs its own directory structure and tools for cross compiling
+WINE_CONF_OPTS = \
+	--with-wine-tools=../host-wine-$(WINE_VERSION) \
+	--disable-tests \
+	--without-opengl \
+	$(if $(BR2_ARCH_IS_64),--enable-win64)
+
+# Wine needs the host tupel of the external toolchain for cross compiling
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),)
+	WINE_CONF_OPTS += --host=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
+endif
+
+ifeq ($(BR2_PACKAGE_CUPS),y)
+	WINE_CONF_OPTS += --with-cups
+	WINE_DEPENDENCIES += cups
+else
+	WINE_CONF_OPTS += --without-cups
+endif
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+	WINE_CONF_OPTS += --with-dbus
+	WINE_DEPENDENCIES += dbus
+else
+	WINE_CONF_OPTS += --without-dbus
+endif
+
+ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
+	WINE_CONF_OPTS += --with-fontconfig
+	WINE_DEPENDENCIES += fontconfig
+else
+	WINE_CONF_OPTS += --without-fontconfig
+endif
+
+# To support freetype in wine we also need freetype in host-wine for the cross compiling tools
+ifeq ($(BR2_PACKAGE_FREETYPE),y)
+	WINE_CONF_OPTS += --with-freetype
+	HOST_WINE_CONF_OPTS += --with-freetype
+	WINE_DEPENDENCIES += freetype
+	HOST_WINE_DEPENDENCIES += host-freetype
+else
+	WINE_CONF_OPTS += --without-freetype
+	HOST_WINE_CONF_OPTS += --without-freetype
+endif
+
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+	WINE_CONF_OPTS += --with-gnutls
+	WINE_DEPENDENCIES += gnutls
+else
+	WINE_CONF_OPTS += --without-gnutls
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+	WINE_CONF_OPTS += --with-gstreamer
+	WINE_DEPENDENCIES += gst-plugins-base
+else
+	WINE_CONF_OPTS += --without-gstreamer
+endif
+
+ifeq ($(BR2_PACKAGE_JPEG),y)
+	WINE_CONF_OPTS += --with-jpeg
+	WINE_DEPENDENCIES += jpeg
+else
+	WINE_CONF_OPTS += --without-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+	WINE_CONF_OPTS += --with-cms
+	WINE_DEPENDENCIES += lcms2
+else
+	WINE_CONF_OPTS += --without-cms
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLU),y)
+	WINE_CONF_OPTS += --with-glu
+	WINE_DEPENDENCIES += libglu
+else
+	WINE_CONF_OPTS += --without-glu
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPCAP),y)
+	WINE_CONF_OPTS += --with-pcap
+	WINE_DEPENDENCIES += libpcap
+else
+	WINE_CONF_OPTS += --without-pcap
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+	WINE_CONF_OPTS += --with-png
+	WINE_DEPENDENCIES += libpng
+else
+	WINE_CONF_OPTS += --without-png
+endif
+
+ifeq ($(BR2_PACKAGE_LIBV4L),y)
+	WINE_CONF_OPTS += --with-v4l
+	WINE_DEPENDENCIES += libv4l
+else
+	WINE_CONF_OPTS += --without-v4l
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+	WINE_CONF_OPTS += --with-xml
+	WINE_DEPENDENCIES += libxml2
+else
+	WINE_CONF_OPTS += --without-xml
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXSLT),y)
+	WINE_CONF_OPTS += --with-xslt
+	WINE_DEPENDENCIES += libxslt
+else
+	WINE_CONF_OPTS += --without-xslt
+endif
+
+ifeq ($(BR2_PACKAGE_MPG123),y)
+	WINE_CONF_OPTS += --with-mpg123
+	WINE_DEPENDENCIES += mpg123
+else
+	WINE_CONF_OPTS += --without-mpg123
+endif
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+	WINE_CONF_OPTS += --with-curses
+	WINE_DEPENDENCIES += ncurses
+else
+	WINE_CONF_OPTS += --without-curses
+endif
+
+ifeq ($(BR2_PACKAGE_SANE_BACKENDS),y)
+	WINE_CONF_OPTS += --with-sane
+	WINE_DEPENDENCIES += sane-backends
+else
+	WINE_CONF_OPTS += --without-sane
+endif
+
+ifeq ($(BR2_PACKAGE_TIFF),y)
+	WINE_CONF_OPTS += --with-tiff
+	WINE_DEPENDENCIES += tiff
+else
+	WINE_CONF_OPTS += --without-tiff
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
+	WINE_CONF_OPTS += --with-x
+	WINE_DEPENDENCIES += xlib_libX11
+else
+	WINE_CONF_OPTS += --without-x
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXCOMPOSITE),y)
+	WINE_CONF_OPTS += --with-xcomposite
+	WINE_DEPENDENCIES += xlib_libXcomposite
+else
+	WINE_CONF_OPTS += --without-xcomposite
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR),y)
+	WINE_CONF_OPTS += --with-xcursor
+	WINE_DEPENDENCIES += xlib_libXcursor
+else
+	WINE_CONF_OPTS += --without-xcursor
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXI),y)
+	WINE_CONF_OPTS += --with-xinput --with-xinput2
+	WINE_DEPENDENCIES += xlib_libXi
+else
+	WINE_CONF_OPTS += --without-xinput --without-xinput2
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
+	WINE_CONF_OPTS += --with-xinerama
+	WINE_DEPENDENCIES += xlib_libXinerama
+else
+	WINE_CONF_OPTS += --without-xinerama
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
+	WINE_CONF_OPTS += --with-xrandr
+	WINE_DEPENDENCIES += xlib_libXrandr
+else
+	WINE_CONF_OPTS += --without-xrandr
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXRENDER),y)
+	WINE_CONF_OPTS += --with-xrender
+	WINE_DEPENDENCIES += xlib_libXrender
+else
+	WINE_CONF_OPTS += --without-xrender
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXXF86VM),y)
+	WINE_CONF_OPTS += --with-xxf86vm
+	WINE_DEPENDENCIES += xlib_libXxf86vm
+else
+	WINE_CONF_OPTS += --without-xxf86vm
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+	WINE_CONF_OPTS += --with-zlib
+	WINE_DEPENDENCIES += zlib
+else
+	WINE_CONF_OPTS += --without-zlib
+endif
+
+HOST_WINE_CONF_OPTS += \
+	--disable-tests \
+	--disable-win16 \
+	--without-alsa \
+	--without-capi \
+	--without-cms \
+	--without-coreaudio \
+	--without-cups \
+	--without-curses \
+	--without-dbus \
+	--without-fontconfig \
+	--without-gettext \
+	--without-gettextpo \
+	--without-gphoto \
+	--without-glu \
+	--without-gnutls \
+	--without-gsm \
+	--without-gstreamer \
+	--without-hal \
+	--without-jpeg \
+	--without-ldap \
+	--without-mpg123 \
+	--without-netapi \
+	--without-openal \
+	--without-opencl \
+	--without-opengl \
+	--without-osmesa \
+	--without-oss \
+	--without-pcap \
+	--without-png \
+	--without-sane \
+	--without-tiff \
+	--without-v4l \
+	--without-x \
+	--without-xcomposite \
+	--without-xcursor \
+	--without-xinerama \
+	--without-xinput \
+	--without-xinput2 \
+	--without-xml \
+	--without-xrandr \
+	--without-xrender \
+	--without-xshape \
+	--without-xshm \
+	--without-xslt \
+	--without-xxf86vm \
+	--without-zlib
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))