diff mbox

[[PATCH,REDO,New,Pkg:,szip] 1/1] Adding New Package: szip

Message ID 54A55FD6.2020206@slac.stanford.edu
State Superseded
Headers show

Commit Message

Ernest L Williams Jan. 1, 2015, 2:55 p.m. UTC
Signed-off-by: Ernesto L. Williams Jr <ernesto@slac.stanford.edu>
---
  package/Config.in      |  1 +
  package/szip/Config.in | 14 ++++++++++++++
  package/szip/szip.mk   | 13 +++++++++++++
  3 files changed, 28 insertions(+)
  create mode 100644 package/szip/Config.in
  create mode 100644 package/szip/szip.mk

Comments

Thomas Petazzoni Jan. 1, 2015, 3:29 p.m. UTC | #1
Dear Ernest L Williams,

Thanks! This looks a lot better! I could apply your patch and fix the
issues, but let's try to bring it up to the good state to merge it with
no change!

The first thing you could improve is the commit title, it should be
just:

	szip: new package

And then when generating the patch, do:

	git format-patch --subject-prefix="PATCHvX"

where X is the version of your patch. There's no need to have something
complicated like [[PATCH][REDO][New Pkg:szip] 1/1].

See below for some more comments.

On Thu, 1 Jan 2015 06:55:18 -0800, Ernest L Williams wrote:
> Signed-off-by: Ernesto L. Williams Jr <ernesto@slac.stanford.edu>
> ---
>   package/Config.in      |  1 +
>   package/szip/Config.in | 14 ++++++++++++++
>   package/szip/szip.mk   | 13 +++++++++++++
>   3 files changed, 28 insertions(+)
>   create mode 100644 package/szip/Config.in
>   create mode 100644 package/szip/szip.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index 43b2b61..b92a6dd 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -599,6 +599,7 @@ menu "Compression and decompression"
>   	source "package/lzo/Config.in"
>   	source "package/snappy/Config.in"
>   	source "package/zlib/Config.in"
> +	source "package/szip/Config.in"

Entries should be sorted alphabetically.

> diff --git a/package/szip/Config.in b/package/szip/Config.in
> new file mode 100644
> index 0000000..9883977
> --- /dev/null
> +++ b/package/szip/Config.in
> @@ -0,0 +1,14 @@
> +config BR2_PACKAGE_SZIP
> +  bool "szip"

Indentation should be one tab.

> +  help
> +    Szip is an implementation of the extended-Rice lossless + 
> compression algorithm. +    The Consultative Committee on Space Data 
> Systems (CCSDS) has
> +    adopted the extended-Rice algorithm for international standards
> +    for space applications[1,6,7]. Szip is reported to provide + 
> fast and effective compression, specifically for the EOS data + 
> generated by the NASA Earth Observatory System (EOS)[1]. +    It was 
> originally developed at University of New Mexico (UNM)
> +    and integrated with HDF4 by UNM researchers and developers.
> +    +    http://www.hdfgroup.org/doc_resource/SZIP

Please send your patch with 'git send-email' and not with your e-mail
client. Your e-mail wraps the lines, which is good for normal text, but
doesn't work at all for patches.

Also the indentation for the help text is one tab + two spaces.

> \ No newline at end of file

Make sure to add an ending new line to this file.

> diff --git a/package/szip/szip.mk b/package/szip/szip.mk
> new file mode 100644
> index 0000000..f3a4758
> --- /dev/null
> +++ b/package/szip/szip.mk
> @@ -0,0 +1,13 @@
> +################################################################################
> +#
> +# szip
> +#
> +################################################################################
> +
> +SZIP_VERSION = 2.1
> +SZIP_SITE = http://www.hdfgroup.org/ftp/lib-external/szip/2.1/src
> +SZIP_LICENSE = szip license
> +SZIP_LICENSE_FILES = COPYING
> +SZIP_INSTALL_STAGING = YES
> +
> +$(eval $(autotools-package))

You could also improve this by adding a hash file, see
http://buildroot.org/downloads/manual/manual.html#adding-packages-hash.

Could you fix those issues and resend an updated version?

Thanks!

Thomas
Ernest L Williams Jan. 1, 2015, 3:50 p.m. UTC | #2
Hi Thomas,

Sent from my iPhone

> On Jan 1, 2015, at 7:29 AM, Thomas Petazzoni <thomas.petazzoni@free-electrons.com> wrote:
> 
> Dear Ernest L Williams,
> 
> Thanks! This looks a lot better! I could apply your patch and fix the
> issues, but let's try to bring it up to the good state to merge it with
> no change!
> 
> The first thing you could improve is the commit title, it should be
> just:
> 
>    szip: new package
> 
> And then when generating the patch, do:
> 
>    git format-patch --subject-prefix="PATCHvX"
> 
> where X is the version of your patch.

Sounds good
Will do,

> There's no need to have something
> complicated like [[PATCH][REDO][New Pkg:szip] 1/1].
> 
> See below for some more comments.
> 
>> On Thu, 1 Jan 2015 06:55:18 -0800, Ernest L Williams wrote:
>> Signed-off-by: Ernesto L. Williams Jr <ernesto@slac.stanford.edu>
>> ---
>>  package/Config.in      |  1 +
>>  package/szip/Config.in | 14 ++++++++++++++
>>  package/szip/szip.mk   | 13 +++++++++++++
>>  3 files changed, 28 insertions(+)
>>  create mode 100644 package/szip/Config.in
>>  create mode 100644 package/szip/szip.mk
>> 
>> diff --git a/package/Config.in b/package/Config.in
>> index 43b2b61..b92a6dd 100644
>> --- a/package/Config.in
>> +++ b/package/Config.in
>> @@ -599,6 +599,7 @@ menu "Compression and decompression"
>>      source "package/lzo/Config.in"
>>      source "package/snappy/Config.in"
>>      source "package/zlib/Config.in"
>> +    source "package/szip/Config.in"
> 
> Entries should be sorted alphabetically.
Ah, you are referring to
"package/Config.in"

Will do

> 
>> diff --git a/package/szip/Config.in b/package/szip/Config.in
>> new file mode 100644
>> index 0000000..9883977
>> --- /dev/null
>> +++ b/package/szip/Config.in
>> @@ -0,0 +1,14 @@
>> +config BR2_PACKAGE_SZIP
>> +  bool "szip"
> 
> Indentation should be one tab.
The file indeed has correct indentation but my email client destroys my formatting. :(

I will fix this
> 
>> +  help
>> +    Szip is an implementation of the extended-Rice lossless + 
>> compression algorithm. +    The Consultative Committee on Space Data 
>> Systems (CCSDS) has
>> +    adopted the extended-Rice algorithm for international standards
>> +    for space applications[1,6,7]. Szip is reported to provide + 
>> fast and effective compression, specifically for the EOS data + 
>> generated by the NASA Earth Observatory System (EOS)[1]. +    It was 
>> originally developed at University of New Mexico (UNM)
>> +    and integrated with HDF4 by UNM researchers and developers.
>> +    +    http://www.hdfgroup.org/doc_resource/SZIP
> 
> Please send your patch with 'git send-email' and not with your e-mail
> client. Your e-mail wraps the lines, which is good for normal text, but
> doesn't work at all for patches.
My email client also screws up the 
"Indentation". :(

Okay, I give in; I will setup send mail on my Fedora Box :)

> 
> Also the indentation for the help text is one tab + two spaces.

Using git send-email will resolve this

> 
>> \ No newline at end of file
> 
> Make sure to add an ending new line to this file.

Will do
> 
>> diff --git a/package/szip/szip.mk b/package/szip/szip.mk
>> new file mode 100644
>> index 0000000..f3a4758
>> --- /dev/null
>> +++ b/package/szip/szip.mk
>> @@ -0,0 +1,13 @@
>> +################################################################################
>> +#
>> +# szip
>> +#
>> +################################################################################
>> +
>> +SZIP_VERSION = 2.1
>> +SZIP_SITE = http://www.hdfgroup.org/ftp/lib-external/szip/2.1/src
>> +SZIP_LICENSE = szip license
>> +SZIP_LICENSE_FILES = COPYING
>> +SZIP_INSTALL_STAGING = YES
>> +
>> +$(eval $(autotools-package))
> 
> You could also improve this by adding a hash file, see
> http://buildroot.org/downloads/manual/manual.html#adding-packages-hash.
Will do

> 
> Could you fix those issues and resend an updated version?

Sure, sounds good

Thanks for your help

Cheers
Ernesto

> 
> Thanks!
> 
> Thomas
> -- 
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 43b2b61..b92a6dd 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -599,6 +599,7 @@  menu "Compression and decompression"
  	source "package/lzo/Config.in"
  	source "package/snappy/Config.in"
  	source "package/zlib/Config.in"
+	source "package/szip/Config.in"
  endmenu
   menu "Crypto"
diff --git a/package/szip/Config.in b/package/szip/Config.in
new file mode 100644
index 0000000..9883977
--- /dev/null
+++ b/package/szip/Config.in
@@ -0,0 +1,14 @@ 
+config BR2_PACKAGE_SZIP
+  bool "szip"
+  help
+    Szip is an implementation of the extended-Rice lossless + 
compression algorithm. +    The Consultative Committee on Space Data 
Systems (CCSDS) has
+    adopted the extended-Rice algorithm for international standards
+    for space applications[1,6,7]. Szip is reported to provide + 
fast and effective compression, specifically for the EOS data + 
generated by the NASA Earth Observatory System (EOS)[1]. +    It was 
originally developed at University of New Mexico (UNM)
+    and integrated with HDF4 by UNM researchers and developers.
+    +    http://www.hdfgroup.org/doc_resource/SZIP
\ No newline at end of file
diff --git a/package/szip/szip.mk b/package/szip/szip.mk
new file mode 100644
index 0000000..f3a4758
--- /dev/null
+++ b/package/szip/szip.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# szip
+#
+################################################################################
+
+SZIP_VERSION = 2.1
+SZIP_SITE = http://www.hdfgroup.org/ftp/lib-external/szip/2.1/src
+SZIP_LICENSE = szip license
+SZIP_LICENSE_FILES = COPYING
+SZIP_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))