diff mbox

Broken generation of locales

Message ID 523A9508.7040403@wanadoo.fr
State Changes Requested
Headers show

Commit Message

Thierry Bultel Sept. 19, 2013, 6:09 a.m. UTC
Hi,

When setting BR2_GENERATE_LOCALE, for instance like that:
BR2_GENERATE_LOCALE="fr_FR en_US es_ES es_ES.ISO-8859-1 hu_HU"

nothing is generated.

next patch fixes that issue:



Cheers
Thierry

Comments

Thomas Petazzoni Sept. 19, 2013, 3:04 p.m. UTC | #1
Dear Thierry Bultel,

On Thu, 19 Sep 2013 08:09:12 +0200, Thierry Bultel wrote:

> When setting BR2_GENERATE_LOCALE, for instance like that:
> BR2_GENERATE_LOCALE="fr_FR en_US es_ES es_ES.ISO-8859-1 hu_HU"
> 
> nothing is generated.
> 
> next patch fixes that issue:
> 
> diff --git a/Makefile b/Makefile
> index 7997e3b..98afd7e 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -543,8 +543,8 @@ ifneq ($(GENERATE_LOCALE),)
>   target-generatelocales: host-localedef
>          $(Q)mkdir -p $(TARGET_DIR)/usr/lib/locale/
>          $(Q)for locale in $(GENERATE_LOCALE) ; do \
> -               inputfile=`echo $${locale} | cut -f1 -d'.' -s` ; \
> -               charmap=`echo $${locale} | cut -f2 -d'.' -s` ; \
> +               inputfile=`echo $${locale} | cut -f1 -d'.'` ; \
> +               charmap=`echo $${locale} | cut -s -f2 -d'.'` ; \
>                  if test -z "$${charmap}" ; then \
>                          charmap="UTF-8" ; \
>                  fi ; \

This exactly reverts commit 8e2696eab6a781727c09408528678d4d29edd7a3
which was merged in August. I've added Arnout in Cc so that you can
discuss the issue together and decide who wins :-)

Thanks,

Thomas
Thierry Bultel Sept. 19, 2013, 3:28 p.m. UTC | #2
Hi Thomas,

This does not exactly revert the named commit, that
added 's' for both inputfile and charmap.

I pretend that the 's' option is mandatory for charmap only,
else inputfile is always empty:

inputfile:

thierry@thierry-desktop:~$ echo fr_FR | cut -f1 -d '.'
fr_FR
thierry@thierry-desktop:~$ echo fr_FR | cut -f1 -d '.' -s
thierry@thierry-desktop:~$

charmap:

thierry@thierry-desktop:~$ echo fr_FR.utf8 | cut -f2 -d '.'
utf8
thierry@thierry-desktop:~$ echo fr_FR.utf8 | cut -f2 -d '.' -s
utf8

thierry@thierry-desktop:~$ cut --version
cut (GNU coreutils) 7.4


Cheers
Thierry

Le 19/09/2013 17:04, Thomas Petazzoni a écrit :
> Dear Thierry Bultel,
>
> On Thu, 19 Sep 2013 08:09:12 +0200, Thierry Bultel wrote:
>
>> When setting BR2_GENERATE_LOCALE, for instance like that:
>> BR2_GENERATE_LOCALE="fr_FR en_US es_ES es_ES.ISO-8859-1 hu_HU"
>>
>> nothing is generated.
>>
>> next patch fixes that issue:
>>
>> diff --git a/Makefile b/Makefile
>> index 7997e3b..98afd7e 100644
>> --- a/Makefile
>> +++ b/Makefile
>> @@ -543,8 +543,8 @@ ifneq ($(GENERATE_LOCALE),)
>>    target-generatelocales: host-localedef
>>           $(Q)mkdir -p $(TARGET_DIR)/usr/lib/locale/
>>           $(Q)for locale in $(GENERATE_LOCALE) ; do \
>> -               inputfile=`echo $${locale} | cut -f1 -d'.' -s` ; \
>> -               charmap=`echo $${locale} | cut -f2 -d'.' -s` ; \
>> +               inputfile=`echo $${locale} | cut -f1 -d'.'` ; \
>> +               charmap=`echo $${locale} | cut -s -f2 -d'.'` ; \
>>                   if test -z "$${charmap}" ; then \
>>                           charmap="UTF-8" ; \
>>                   fi ; \
> This exactly reverts commit 8e2696eab6a781727c09408528678d4d29edd7a3
> which was merged in August. I've added Arnout in Cc so that you can
> discuss the issue together and decide who wins :-)
>
> Thanks,
>
> Thomas
Arnout Vandecappelle Sept. 19, 2013, 7:12 p.m. UTC | #3
On 19/09/13 17:28, Thierry Bultel wrote:
> Hi Thomas,
>
> This does not exactly revert the named commit, that
> added 's' for both inputfile and charmap.
>
> I pretend that the 's' option is mandatory for charmap only,
> else inputfile is always empty:
>
> inputfile:
>
> thierry@thierry-desktop:~$ echo fr_FR | cut -f1 -d '.'
> fr_FR
> thierry@thierry-desktop:~$ echo fr_FR | cut -f1 -d '.' -s
> thierry@thierry-desktop:~$
>
> charmap:
>
> thierry@thierry-desktop:~$ echo fr_FR.utf8 | cut -f2 -d '.'
> utf8
> thierry@thierry-desktop:~$ echo fr_FR.utf8 | cut -f2 -d '.' -s
> utf8

  Ack that.

  So this patch gets

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

  Note that you've caused Thomas's confusion by unnecessarily moving the 
-s option in the charmap line.


  Regards,
  Arnout

[snip]
Thomas Petazzoni Sept. 19, 2013, 7:30 p.m. UTC | #4
Dear Arnout Vandecappelle,

On Thu, 19 Sep 2013 21:12:17 +0200, Arnout Vandecappelle wrote:

>   Note that you've caused Thomas's confusion by unnecessarily moving the 
> -s option in the charmap line.

Ah, yes. Thierry, can you resend a proper patch (i.e without moving the
-s option in the charmap line, and with a proper description and
Signed-off-by line) ?

Thanks!

Thomas
Arnout Vandecappelle Sept. 19, 2013, 8:32 p.m. UTC | #5
On 19/09/13 21:30, Thomas Petazzoni wrote:
> Dear Arnout Vandecappelle,
>
> On Thu, 19 Sep 2013 21:12:17 +0200, Arnout Vandecappelle wrote:
>
>>    Note that you've caused Thomas's confusion by unnecessarily moving the
>> -s option in the charmap line.
>
> Ah, yes. Thierry, can you resend a proper patch (i.e without moving the
> -s option in the charmap line, and with a proper description and
> Signed-off-by line) ?

  And don't forget to add my

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

  :-)

  Regards,
  Arnout
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 7997e3b..98afd7e 100644
--- a/Makefile
+++ b/Makefile
@@ -543,8 +543,8 @@  ifneq ($(GENERATE_LOCALE),)
  target-generatelocales: host-localedef
         $(Q)mkdir -p $(TARGET_DIR)/usr/lib/locale/
         $(Q)for locale in $(GENERATE_LOCALE) ; do \
-               inputfile=`echo $${locale} | cut -f1 -d'.' -s` ; \
-               charmap=`echo $${locale} | cut -f2 -d'.' -s` ; \
+               inputfile=`echo $${locale} | cut -f1 -d'.'` ; \
+               charmap=`echo $${locale} | cut -s -f2 -d'.'` ; \
                 if test -z "$${charmap}" ; then \
                         charmap="UTF-8" ; \
                 fi ; \