diff mbox series

[5/6] package/libksba: Add host package

Message ID 50b8003c4466222765fa343b71bcad2da8478a37.1712957992.git.ben.hutchings@mind.be
State New
Headers show
Series Add host packages of gnupg2 and its dependencies | expand

Commit Message

Ben Hutchings April 12, 2024, 9:43 p.m. UTC
This is needed to support a host build of gnupg2.  It is not directly
selectable.

Signed-off-by: Ben Hutchings <ben.hutchings@mind.be>
---
 package/libksba/libksba.mk | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/package/libksba/libksba.mk b/package/libksba/libksba.mk
index 52ad5fbeec..dc4ad8d241 100644
--- a/package/libksba/libksba.mk
+++ b/package/libksba/libksba.mk
@@ -13,9 +13,13 @@  LIBKSBA_CPE_ID_VENDOR = gnupg
 LIBKSBA_INSTALL_STAGING = YES
 LIBKSBA_DEPENDENCIES = libgpg-error
 LIBKSBA_CONF_OPTS = --with-gpg-error-prefix=$(STAGING_DIR)/usr
+HOST_LIBKSBA_DEPENDENCIES = host-libgpg-error
+HOST_LIBKSBA_CONF_OPTS = --with-gpg-error-prefix=$(HOST_DIR)
 
 # Force the path to "gpgrt-config" (from the libgpg-error package) to
 # avoid using the one on host, if present.
 LIBKSBA_CONF_ENV += GPGRT_CONFIG=$(STAGING_DIR)/usr/bin/gpgrt-config
+HOST_LIBKSBA_CONF_ENV += GPGRT_CONFIG=$(HOST_DIR)/bin/gpgrt-config
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))