diff mbox

[3/9] package/wayland: install wayland-scanner to $(HOST)

Message ID 448f7432fc0b7c091413dd494e6b9d838cf51527.1381354867.git.yann.morin.1998@free.fr
State Changes Requested
Headers show

Commit Message

Yann E. MORIN Oct. 9, 2013, 9:44 p.m. UTC
From: "Yann E. MORIN" <yann.morin.1998@free.fr>

wayland-scanner is needed by weston.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/wayland/wayland.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 10, 2013, 7:05 a.m. UTC | #1
Dear Yann E. MORIN,

On Wed,  9 Oct 2013 23:44:19 +0200, Yann E. MORIN wrote:
> +	 install -m 0755 -D wayland-scanner $(HOST_DIR)/usr/bin/wayland-scanner )

	$(INSTALL)

Also, that's nitpicking, but we generally don't have a space between
the end of the command and the closing parenthesis.

Thomas
Yann E. MORIN Oct. 10, 2013, 5:20 p.m. UTC | #2
Thomas, All,

On 2013-10-10 09:05 +0200, Thomas Petazzoni spake thusly:
> On Wed,  9 Oct 2013 23:44:19 +0200, Yann E. MORIN wrote:
> > +	 install -m 0755 -D wayland-scanner $(HOST_DIR)/usr/bin/wayland-scanner )
> 
> 	$(INSTALL)
> 
> Also, that's nitpicking, but we generally don't have a space between
> the end of the command and the closing parenthesis.

OK, will fix both. Thanks.

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/wayland/wayland.mk b/package/wayland/wayland.mk
index 0810536..739971b 100644
--- a/package/wayland/wayland.mk
+++ b/package/wayland/wayland.mk
@@ -22,7 +22,8 @@  WAYLAND_CONF_OPT = --disable-scanner
 define WAYLAND_BUILD_SCANNER
 	(cd $(@D)/src/; \
 		$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
-			-o wayland-scanner scanner.c wayland-util.c -lexpat)
+			-o wayland-scanner scanner.c wayland-util.c -lexpat; \
+	 install -m 0755 -D wayland-scanner $(HOST_DIR)/usr/bin/wayland-scanner )
 endef
 
 WAYLAND_POST_CONFIGURE_HOOKS += WAYLAND_BUILD_SCANNER