diff mbox series

problem compiling host-tiff-4.6.0

Message ID 40ae9b7a-21fb-4462-a891-eb1326bc7d56@lindra.de
State Not Applicable
Headers show
Series problem compiling host-tiff-4.6.0 | expand

Commit Message

Ralf Dragon April 1, 2024, 7:58 a.m. UTC
Dear all,

for me in current master and 2024.02.x branches, the package 
host-tiff-4.6.0 fails to compile with:

...

libtool: link: /usr/bin/gcc -O2 
-I/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/include 
-Wall -W -Wl,-rpath 
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib 
-o tiffcp tiffcp.o 
-L/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib 
../libtiff/.libs/libtiff.so ../port/.libs/libport.a -lLerc -ljbig -lm 
-Wl,-rpath 
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/build/host-tiff-4.6.0/libtiff/.libs 
-Wl,-rpath 
-Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to 
`deflateInit_'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `deflate'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to 
`deflateEnd'
/usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `inflate'
...


It seems that the following diff fixes the problem, but I guess that the 
HOST_TIFF_CONF_OPTS were added in 91b16f for a reason and that the 
problem is a different.


Could someone advise what to do?

Ralf

Comments

Peter Korsgaard April 4, 2024, 3:37 p.m. UTC | #1
>>>>> "Ralf" == Ralf Dragon <hypnotoad@lindra.de> writes:

 > Dear all,
 > for me in current master and 2024.02.x branches, the package
 > host-tiff-4.6.0 fails to compile with:

Thanks for the heads up, reproduced here.

 > ...

 > libtool: link: /usr/bin/gcc -O2
 > -I/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/include
 > -Wall -W -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > -o tiffcp tiffcp.o
 > -L/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > ../libtiff/.libs/libtiff.so ../port/.libs/libport.a -lLerc -ljbig -lm
 > -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/build/host-tiff-4.6.0/libtiff/.libs
 > -Wl,-rpath
 > -Wl,/home/dragon/src/ft/ftcommunity-TXT/output/build/rootfs/per-package/host-tiff/host/lib
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
 > `deflateInit_'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `deflate'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to
 > `deflateEnd'
 > /usr/bin/ld: ../libtiff/.libs/libtiff.so: undefined reference to `inflate'
 > ...


 > It seems that the following diff fixes the problem, but I guess that
 > the HOST_TIFF_CONF_OPTS were added in 91b16f for a reason and that the
 > problem is a different.

Indeed. If you look closely to the failing line you see that you are
linking host-tiff with -lLerc and -ljbig. Presumably you have the
development packages for those libraries installed on your build host?

I have sent a series to explicitly disable lerc and jbig support in
tiff, which should fix the issue:

https://patchwork.ozlabs.org/project/buildroot/list/?series=401697
diff mbox series

Patch

--- a/package/tiff/tiff.mk
+++ b/package/tiff/tiff.mk
@@ -23,7 +23,6 @@  TIFF_DEPENDENCIES = host-pkgconf

  HOST_TIFF_CONF_OPTS = \
         --disable-cxx \
-       --disable-zlib \
         --disable-libdeflate \
         --disable-lzma \
         --disable-jpeg \