diff mbox series

package/socat: support OpenSSL only

Message ID 3e8e93e9eed117bc7e49580fd77e254eee237a99.1668060990.git.baruch@tkos.co.il
State Accepted
Headers show
Series package/socat: support OpenSSL only | expand

Commit Message

Baruch Siach Nov. 10, 2022, 6:16 a.m. UTC
socat is not compatible with libressl.

Fixes:
http://autobuild.buildroot.net/results/6f0204004c52f762d6e3cb3064238d7eb3646038/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/socat/socat.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Baruch Siach Nov. 10, 2022, 10:15 a.m. UTC | #1
Hi Buildroot list,

On Thu, Nov 10 2022, Baruch Siach wrote:
> socat is not compatible with libressl.
>
> Fixes:
> http://autobuild.buildroot.net/results/6f0204004c52f762d6e3cb3064238d7eb3646038/

This issue only shows up in the 'next' branch where we have socat
version 1.7.4.4 which includes upstream commit 15e38be2f52 ("Fixed
SIGSEGV of OpenSSL on exit()") that exposes the issue. The (unused)
reference to OPENSSL_INIT_SETTINGS is there even in the previous 1.7.4.3
version that is in 'master'.

Note though that this patch applies to 'next', but conflicts with commit
934ec83e9d0 ("package/socat: disable openssl for static build") in
'master'. If this patch is applied to 'next' it will cause conflict when
'next' merges into 'master'.

Let me know if you want a patch against 'master' instead.

baruch

>
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/socat/socat.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/socat/socat.mk b/package/socat/socat.mk
> index 0414c8adc855..639b3d302847 100644
> --- a/package/socat/socat.mk
> +++ b/package/socat/socat.mk
> @@ -31,7 +31,7 @@ SOCAT_DEPENDENCIES = host-autoconf
>  # incompatibile license (GPL-3.0+)
>  SOCAT_CONF_OPTS = --disable-readline
>  
> -ifeq ($(BR2_PACKAGE_OPENSSL),y)
> +ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
>  SOCAT_DEPENDENCIES += openssl
>  else
>  SOCAT_CONF_OPTS += --disable-openssl
Thomas Petazzoni Nov. 11, 2022, 10:50 p.m. UTC | #2
On Thu, 10 Nov 2022 08:16:30 +0200
Baruch Siach via buildroot <buildroot@buildroot.org> wrote:

> socat is not compatible with libressl.
> 
> Fixes:
> http://autobuild.buildroot.net/results/6f0204004c52f762d6e3cb3064238d7eb3646038/
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/socat/socat.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

I've applied to next, but after cherry-picking from master the change
in socat disabling the use of OpenSSL with static configurations. This
way, I resolved the conflict right away, while the topic is fresh. I
also expanded your commit log, which forgot to indicate since when the
problem occurs (it was in your follow-up e-mail).

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/socat/socat.mk b/package/socat/socat.mk
index 0414c8adc855..639b3d302847 100644
--- a/package/socat/socat.mk
+++ b/package/socat/socat.mk
@@ -31,7 +31,7 @@  SOCAT_DEPENDENCIES = host-autoconf
 # incompatibile license (GPL-3.0+)
 SOCAT_CONF_OPTS = --disable-readline
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
 SOCAT_DEPENDENCIES += openssl
 else
 SOCAT_CONF_OPTS += --disable-openssl