diff mbox series

package/zeromq: force detection of more features

Message ID 3aa0ac234bc829d21b0a2c3fcafa0bf3a19cb210.1658328437.git.baruch@tkos.co.il
State Accepted
Headers show
Series package/zeromq: force detection of more features | expand

Commit Message

Baruch Siach July 20, 2022, 2:47 p.m. UTC
ZeroMQ added SO_PRIORITY in version 4.3.4, SO_BINDTODEVICE in 4.2.3, and
O_CLOEXEC since before 2.1.11. Checks for these feature are incompatible
with cross compilation. Linux supports SO_PRIORITY, and SO_BINDTODEVICE
since before 2.6. O_CLOEXEC is supported since 2.6.23. Keep them always
enabled.

Cc: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/zeromq/zeromq.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni July 20, 2022, 4:40 p.m. UTC | #1
On Wed, 20 Jul 2022 17:47:17 +0300
Baruch Siach via buildroot <buildroot@buildroot.org> wrote:

> ZeroMQ added SO_PRIORITY in version 4.3.4, SO_BINDTODEVICE in 4.2.3, and
> O_CLOEXEC since before 2.1.11. Checks for these feature are incompatible
> with cross compilation. Linux supports SO_PRIORITY, and SO_BINDTODEVICE
> since before 2.6. O_CLOEXEC is supported since 2.6.23. Keep them always
> enabled.
> 
> Cc: Asaf Kahlon <asafka7@gmail.com>
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/zeromq/zeromq.mk | 3 +++
>  1 file changed, 3 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 11, 2022, 11:47 a.m. UTC | #2
>>>>> "Baruch" == Baruch Siach via buildroot <buildroot@buildroot.org> writes:

 > ZeroMQ added SO_PRIORITY in version 4.3.4, SO_BINDTODEVICE in 4.2.3, and
 > O_CLOEXEC since before 2.1.11. Checks for these feature are incompatible
 > with cross compilation. Linux supports SO_PRIORITY, and SO_BINDTODEVICE
 > since before 2.6. O_CLOEXEC is supported since 2.6.23. Keep them always
 > enabled.

 > Cc: Asaf Kahlon <asafka7@gmail.com>
 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/zeromq/zeromq.mk b/package/zeromq/zeromq.mk
index c22f69ec66c1..452c5f429171 100644
--- a/package/zeromq/zeromq.mk
+++ b/package/zeromq/zeromq.mk
@@ -17,7 +17,10 @@  ZEROMQ_CPE_ID_PRODUCT = libzmq
 # SOCK_CLOEXEC, since linux v2.6.27.
 # Note: the flag TCP_KEEPALIVE is NOT available so we do not include it.
 ZEROMQ_CONF_ENV = libzmq_cv_sock_cloexec=yes \
+	libzmq_cv_o_cloexec=yes \
 	libzmq_cv_so_keepalive=yes \
+	libzmq_cv_so_priority=yes \
+	libzmq_cv_so_bindtodevice=yes \
 	libzmq_cv_tcp_keepcnt=yes \
 	libzmq_cv_tcp_keepidle=yes \
 	libzmq_cv_tcp_keepintvl=yes