diff mbox series

[1/1] package/gr-osmosdr: add host-python-six dependency needed for generating Python bindings

Message ID 299860002.1258357262.1712837263439.JavaMail.zimbra@free.fr
State New
Headers show
Series [1/1] package/gr-osmosdr: add host-python-six dependency needed for generating Python bindings | expand

Commit Message

jmfriedt April 11, 2024, 12:07 p.m. UTC
Compiling gr-osmosdr when Python3 support is active fails with

ModuleNotFoundError: No module named 'six' 
make[3]: *** [python/bindings/CMakeFiles/osmosdr_docstrings.dir/build.make:73: python/bindings/docstring_status] Error 1

when generating the Python bindings. The following patch solves the problem.


Signed-off-by: Jean-Michel Friedt <jmfriedt@femto-st.fr>
---
 package/gr-osmosdr/gr-osmosdr.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/gr-osmosdr/gr-osmosdr.mk b/package/gr-osmosdr/gr-osmosdr.mk
index 8491c005d8..316ed80887 100644
--- a/package/gr-osmosdr/gr-osmosdr.mk
+++ b/package/gr-osmosdr/gr-osmosdr.mk
@@ -24,7 +24,7 @@  GR_OSMOSDR_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_GNURADIO_PYTHON),y)
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=ON
-GR_OSMOSDR_DEPENDENCIES += python3
+GR_OSMOSDR_DEPENDENCIES += python3 host-python-six
 else
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=OFF
 endif