diff mbox

[02/14,v4] package/libudev: new virtual package

Message ID 25285_1406798022_53DA08C6_25285_352_1_D1B3145249B37145BFF7A03F8FC244500F67A78C@PEXCVZYM11.corporate.adroot.infra.ftgroup
State Not Applicable
Headers show

Commit Message

cedric.chedaleux@orange.com July 31, 2014, 9:13 a.m. UTC
[ Compiled for x86 target with glibc 2.18 and Kernel headers 3.15.x ]
Tested-by: Cedric Chedaleux <cedric.chedaleux@orange.com>

Regards,
Cédric CHEDALEUX

-----Message d'origine-----
De : buildroot-bounces@busybox.net [mailto:buildroot-bounces@busybox.net] De la part de Yann E. MORIN
Envoyé : jeudi 31 juillet 2014 02:17
À : buildroot@buildroot.org
Cc : Bernd Kuhls; Yann E. MORIN
Objet : [Buildroot] [PATCH 02/14 v4] package/libudev: new virtual package

Not all packages that currently depend on udev really need an udev
daemon; most may only require a libudev.so to be available. For
example, libcec, mesa3d...

Currently, we conflate udev and libudev into a single virtual package.

Introduce a new virtual package 'libudev' that packages can select if
they provide libudev.so (obviously, systemd and eudev are such packages)
and which packages can depend on if they just need libudev.so and not an
udev daemon.

Note: only the virtual package is added for now, providers and users
will be converted in followup patches.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/Config.in          | 1 +
 package/libudev/Config.in  | 6 ++++++
 package/libudev/libudev.mk | 7 +++++++
 3 files changed, 14 insertions(+)
 create mode 100644 package/libudev/Config.in
 create mode 100644 package/libudev/libudev.mk
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 29b8e6b..230bcf4 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -673,6 +673,7 @@  menu "Hardware handling"
 	source "package/librtlsdr/Config.in"
 	source "package/libserial/Config.in"
 	source "package/libsoc/Config.in"
+	source "package/libudev/Config.in"
 	source "package/libusb/Config.in"
 	source "package/libusb-compat/Config.in"
 	source "package/libv4l/Config.in"
diff --git a/package/libudev/Config.in b/package/libudev/Config.in
new file mode 100644
index 0000000..2745fcc
--- /dev/null
+++ b/package/libudev/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_HAS_LIBUDEV
+	bool
+
+config BR2_PACKAGE_PROVIDES_LIBUDEV
+	depends on BR2_PACKAGE_HAS_LIBUDEV
+	string
diff --git a/package/libudev/libudev.mk b/package/libudev/libudev.mk
new file mode 100644
index 0000000..af1b3dd
--- /dev/null
+++ b/package/libudev/libudev.mk
@@ -0,0 +1,7 @@ 
+################################################################################
+#
+# libudev
+#
+################################################################################
+
+$(eval $(virtual-package))