diff mbox series

[1/1] package/systemd: enable tmpfs kernel option

Message ID 20250226090108.1007137-1-adam.duskett@amarulasolutions.com
State Accepted
Delegated to: Julien Olivain
Headers show
Series [1/1] package/systemd: enable tmpfs kernel option | expand

Commit Message

Adam Duskett Feb. 26, 2025, 9:01 a.m. UTC
systemd automatically creates tmpfs mounts for /tmp, /run, /dev/shm, and
others. If tmpfs is not enabled in the kernel, systemd crashes with an
unknown filesystem error on boot. This hasn't manifested itself during
tests with defconfigs such as pc_x86_64_efi_defconfig for a few reasons:

  - No defconfig uses systemd as the init system by default
  - Even if a user does use pc_x86_64_efi_defconfig and changes to systemd,
    the board/pc/linux.config file enables CONFIG_PCI, which selects
    CONFIG_TMPFS.
  - The systemd init tests use a prebuilt kernel with tmpfs enabled.

Enable tmpfs unconditionally to ensure that systemd always boots, even with
a minimal kernel built.

Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
---
 package/systemd/systemd.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Julien Olivain March 5, 2025, 9:17 p.m. UTC | #1
On 26/02/2025 10:01, Adam Duskett wrote:
> systemd automatically creates tmpfs mounts for /tmp, /run, /dev/shm, 
> and
> others. If tmpfs is not enabled in the kernel, systemd crashes with an
> unknown filesystem error on boot. This hasn't manifested itself during
> tests with defconfigs such as pc_x86_64_efi_defconfig for a few 
> reasons:
> 
>   - No defconfig uses systemd as the init system by default
>   - Even if a user does use pc_x86_64_efi_defconfig and changes to 
> systemd,
>     the board/pc/linux.config file enables CONFIG_PCI, which selects
>     CONFIG_TMPFS.
>   - The systemd init tests use a prebuilt kernel with tmpfs enabled.
> 
> Enable tmpfs unconditionally to ensure that systemd always boots, even 
> with
> a minimal kernel built.
> 
> Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>

Applied to master, thanks.
Peter Korsgaard March 16, 2025, 7:59 p.m. UTC | #2
>>>>> "Adam" == Adam Duskett <adam.duskett@amarulasolutions.com> writes:

 > systemd automatically creates tmpfs mounts for /tmp, /run, /dev/shm, and
 > others. If tmpfs is not enabled in the kernel, systemd crashes with an
 > unknown filesystem error on boot. This hasn't manifested itself during
 > tests with defconfigs such as pc_x86_64_efi_defconfig for a few reasons:

 >   - No defconfig uses systemd as the init system by default
 >   - Even if a user does use pc_x86_64_efi_defconfig and changes to systemd,
 >     the board/pc/linux.config file enables CONFIG_PCI, which selects
 >     CONFIG_TMPFS.
 >   - The systemd init tests use a prebuilt kernel with tmpfs enabled.

 > Enable tmpfs unconditionally to ensure that systemd always boots, even with
 > a minimal kernel built.

 > Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>

Committed to 2024.02.x and 2024.11.x, thanks.
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 28091a72a6..337d52b1f2 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -847,6 +847,7 @@  SYSTEMD_CONF_ENV = $(HOST_UTF8_LOCALE_ENV)
 SYSTEMD_NINJA_ENV = $(HOST_UTF8_LOCALE_ENV)
 
 define SYSTEMD_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_TMPFS)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_CGROUPS)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER)