diff mbox series

package/cloop: bump to 3.14.1.3+nmu1

Message ID 20241226211143.2507882-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/cloop: bump to 3.14.1.3+nmu1 | expand

Commit Message

Thomas Petazzoni Dec. 26, 2024, 9:11 p.m. UTC
This is the latest version available in Debian (which is our upstream
for this package). The changelog is:

   [ Ben Hutchings ]
   * Fix FTBFS with gcc 11 (Closes: #1005413):
     - Remove exception specifications
   * Fix module build for recent kernel versions (Closes: #1005414):
     - Stop generating module vermagic in cloop.c. This has always been handled
       by modpost and doing it here now results in build failure.
     - Avoid using inode::i_bdev, which was removed in Linux 5.11.
     - Use set_disk_ro() instead of set_device_ro(). The latter was not meant to
       be used by device drivers and was removed in Linux 5.11.
     - Use blk_{mq_alloc,cleanup}_disk() instead of separate queue and disk
       allocation and cleanup on Linux 5.15+, since alloc_disk() was removed.
     - Handle potential failure of add_disk() on Linux 5.15+.
     - Use kernel_read() instead of vfs_read() and set_fs(). set_fs() is no
       longer defined on some architectures, and kernel_read() has had large
       file support since Linux 2.6.31.
 .
   [ Vagrant Cascadian ]
   * debian/rules: Build tarball reproducibly, using consistent time, uid,
     gid and sort order. Thanks to Dhole for the initial patch.

The "Fix FTBFS with gcc 11" allows us to remove the -std=c++14
workaround added in commit
7e147e778fc3397cd2a069c8127fa4d2cc6c0355 ("package/cloop: fix build
with gcc >= 9").

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/cloop/cloop.hash | 4 ++--
 package/cloop/cloop.mk   | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)

Comments

Julien Olivain Dec. 27, 2024, 10:57 a.m. UTC | #1
Hi Thomas,

On 26/12/2024 22:11, Thomas Petazzoni via buildroot wrote:
> This is the latest version available in Debian (which is our upstream
> for this package). The changelog is:
> 
>    [ Ben Hutchings ]
>    * Fix FTBFS with gcc 11 (Closes: #1005413):
>      - Remove exception specifications
>    * Fix module build for recent kernel versions (Closes: #1005414):
>      - Stop generating module vermagic in cloop.c. This has always been 
> handled
>        by modpost and doing it here now results in build failure.
>      - Avoid using inode::i_bdev, which was removed in Linux 5.11.
>      - Use set_disk_ro() instead of set_device_ro(). The latter was not 
> meant to
>        be used by device drivers and was removed in Linux 5.11.
>      - Use blk_{mq_alloc,cleanup}_disk() instead of separate queue and 
> disk
>        allocation and cleanup on Linux 5.15+, since alloc_disk() was 
> removed.
>      - Handle potential failure of add_disk() on Linux 5.15+.
>      - Use kernel_read() instead of vfs_read() and set_fs(). set_fs() 
> is no
>        longer defined on some architectures, and kernel_read() has had 
> large
>        file support since Linux 2.6.31.
>  .
>    [ Vagrant Cascadian ]
>    * debian/rules: Build tarball reproducibly, using consistent time, 
> uid,
>      gid and sort order. Thanks to Dhole for the initial patch.
> 
> The "Fix FTBFS with gcc 11" allows us to remove the -std=c++14
> workaround added in commit
> 7e147e778fc3397cd2a069c8127fa4d2cc6c0355 ("package/cloop: fix build
> with gcc >= 9").
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/cloop/cloop.hash | 4 ++--
>  package/cloop/cloop.mk   | 6 +++---
>  2 files changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/package/cloop/cloop.hash b/package/cloop/cloop.hash
> index eb922764bb..a4f7056049 100644
> --- a/package/cloop/cloop.hash
> +++ b/package/cloop/cloop.hash
> @@ -1,5 +1,5 @@
> -# From 
> http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop/cloop_3.14.1.3.dsc
> -sha256  
> e3079e70f9edae8ed1ac64694af08f6c7dc710ca65a56e4770dcb1325a293193  
> cloop_3.14.1.3.tar.xz
> +# From 
> http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop/cloop_3.14.1.3%2Bnmu1.dsc

Is there any specific reason for switching to the "-debug" archive?
The same file seems to be present in the main debian archive:
https://snapshot.debian.org/archive/debian/20221223T031011Z/pool/main/c/cloop/cloop_3.14.1.3%2Bnmu1.dsc

> +sha256  
> 04060d88231208b0db8ae8c3b54b0a46ee12139b617ebfc80b03d2ddd2cdb6ba  
> cloop_3.14.1.3+nmu1.tar.xz
> 
>  # Hash for license files
>  sha256  
> 91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad  
> advancecomp-1.15/COPYING
> diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
> index 6f6d5fe6a8..f42edee28b 100644
> --- a/package/cloop/cloop.mk
> +++ b/package/cloop/cloop.mk
> @@ -4,9 +4,9 @@
>  #
>  
> ################################################################################
> 
> -CLOOP_VERSION = 3.14.1.3
> +CLOOP_VERSION = 3.14.1.3+nmu1
>  CLOOP_SOURCE = cloop_$(CLOOP_VERSION).tar.xz
> -CLOOP_SITE = 
> http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop
> +CLOOP_SITE = 
> http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop

Same question here. Should we use:
https://snapshot.debian.org/archive/debian/20221223T031011Z/pool/main/c/cloop
instead?

Best regards,

Julien.
Arnout Vandecappelle Feb. 4, 2025, 3:02 p.m. UTC | #2
On 26/12/2024 22:11, Thomas Petazzoni via buildroot wrote:
> This is the latest version available in Debian (which is our upstream
> for this package). The changelog is:
> 
>     [ Ben Hutchings ]
>     * Fix FTBFS with gcc 11 (Closes: #1005413):
>       - Remove exception specifications
>     * Fix module build for recent kernel versions (Closes: #1005414):
>       - Stop generating module vermagic in cloop.c. This has always been handled
>         by modpost and doing it here now results in build failure.
>       - Avoid using inode::i_bdev, which was removed in Linux 5.11.
>       - Use set_disk_ro() instead of set_device_ro(). The latter was not meant to
>         be used by device drivers and was removed in Linux 5.11.
>       - Use blk_{mq_alloc,cleanup}_disk() instead of separate queue and disk
>         allocation and cleanup on Linux 5.15+, since alloc_disk() was removed.
>       - Handle potential failure of add_disk() on Linux 5.15+.
>       - Use kernel_read() instead of vfs_read() and set_fs(). set_fs() is no
>         longer defined on some architectures, and kernel_read() has had large
>         file support since Linux 2.6.31.
>   .
>     [ Vagrant Cascadian ]
>     * debian/rules: Build tarball reproducibly, using consistent time, uid,
>       gid and sort order. Thanks to Dhole for the initial patch.
> 
> The "Fix FTBFS with gcc 11" allows us to remove the -std=c++14
> workaround added in commit
> 7e147e778fc3397cd2a069c8127fa4d2cc6c0355 ("package/cloop: fix build
> with gcc >= 9").
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

  Applied to master, thanks, after fixing the URL as suggested by Juju.

  We could also have removed this package and cloopfs :-)

  Regards,
  Arnout

> ---
>   package/cloop/cloop.hash | 4 ++--
>   package/cloop/cloop.mk   | 6 +++---
>   2 files changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/package/cloop/cloop.hash b/package/cloop/cloop.hash
> index eb922764bb..a4f7056049 100644
> --- a/package/cloop/cloop.hash
> +++ b/package/cloop/cloop.hash
> @@ -1,5 +1,5 @@
> -# From http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop/cloop_3.14.1.3.dsc
> -sha256  e3079e70f9edae8ed1ac64694af08f6c7dc710ca65a56e4770dcb1325a293193  cloop_3.14.1.3.tar.xz
> +# From http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop/cloop_3.14.1.3%2Bnmu1.dsc
> +sha256  04060d88231208b0db8ae8c3b54b0a46ee12139b617ebfc80b03d2ddd2cdb6ba  cloop_3.14.1.3+nmu1.tar.xz
>   
>   # Hash for license files
>   sha256  91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad  advancecomp-1.15/COPYING
> diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
> index 6f6d5fe6a8..f42edee28b 100644
> --- a/package/cloop/cloop.mk
> +++ b/package/cloop/cloop.mk
> @@ -4,9 +4,9 @@
>   #
>   ################################################################################
>   
> -CLOOP_VERSION = 3.14.1.3
> +CLOOP_VERSION = 3.14.1.3+nmu1
>   CLOOP_SOURCE = cloop_$(CLOOP_VERSION).tar.xz
> -CLOOP_SITE = http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop
> +CLOOP_SITE = http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop
>   CLOOP_LICENSE = GPL-2.0 (module), GPL-2.0+ (advancecomp)
>   CLOOP_LICENSE_FILES = README advancecomp-1.15/COPYING
>   
> @@ -14,7 +14,7 @@ HOST_CLOOP_DEPENDENCIES = host-zlib
>   
>   define HOST_CLOOP_BUILD_CMDS
>   	$(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes \
> -		CFLAGS="$(HOST_CFLAGS) -D_GNU_SOURCE" CPPFLAGS="-std=c++14"
> +		CFLAGS="$(HOST_CFLAGS) -D_GNU_SOURCE"
>   endef
>   
>   define HOST_CLOOP_INSTALL_CMDS
diff mbox series

Patch

diff --git a/package/cloop/cloop.hash b/package/cloop/cloop.hash
index eb922764bb..a4f7056049 100644
--- a/package/cloop/cloop.hash
+++ b/package/cloop/cloop.hash
@@ -1,5 +1,5 @@ 
-# From http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop/cloop_3.14.1.3.dsc
-sha256  e3079e70f9edae8ed1ac64694af08f6c7dc710ca65a56e4770dcb1325a293193  cloop_3.14.1.3.tar.xz
+# From http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop/cloop_3.14.1.3%2Bnmu1.dsc
+sha256  04060d88231208b0db8ae8c3b54b0a46ee12139b617ebfc80b03d2ddd2cdb6ba  cloop_3.14.1.3+nmu1.tar.xz
 
 # Hash for license files
 sha256  91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad  advancecomp-1.15/COPYING
diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
index 6f6d5fe6a8..f42edee28b 100644
--- a/package/cloop/cloop.mk
+++ b/package/cloop/cloop.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-CLOOP_VERSION = 3.14.1.3
+CLOOP_VERSION = 3.14.1.3+nmu1
 CLOOP_SOURCE = cloop_$(CLOOP_VERSION).tar.xz
-CLOOP_SITE = http://snapshot.debian.org/archive/debian/20200419T152225Z/pool/main/c/cloop
+CLOOP_SITE = http://snapshot.debian.org/archive/debian-debug/20221223T030115Z/pool/main/c/cloop
 CLOOP_LICENSE = GPL-2.0 (module), GPL-2.0+ (advancecomp)
 CLOOP_LICENSE_FILES = README advancecomp-1.15/COPYING
 
@@ -14,7 +14,7 @@  HOST_CLOOP_DEPENDENCIES = host-zlib
 
 define HOST_CLOOP_BUILD_CMDS
 	$(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes \
-		CFLAGS="$(HOST_CFLAGS) -D_GNU_SOURCE" CPPFLAGS="-std=c++14"
+		CFLAGS="$(HOST_CFLAGS) -D_GNU_SOURCE"
 endef
 
 define HOST_CLOOP_INSTALL_CMDS