diff mbox series

[v3] package/procps-ng: fix typos in config option and help text

Message ID 20241029141125.1065482-1-fancp2007@gmail.com
State Accepted
Headers show
Series [v3] package/procps-ng: fix typos in config option and help text | expand

Commit Message

Scott Fan Oct. 29, 2024, 2:11 p.m. UTC
The option has been renamed, so add an entry in the
Config.in.legacy file for the old option name.

Signed-off-by: Scott Fan <fancp2007@gmail.com>

---
Changes v1 -> v2:
  - add an entry in the Config.in.legacy file

Changes v2 -> v3:
  - update the entry in the Config.in.legacy file
---
 Config.in.legacy               | 8 ++++++++
 package/procps-ng/Config.in    | 4 ++--
 package/procps-ng/procps-ng.mk | 2 +-
 3 files changed, 11 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Oct. 29, 2024, 5:49 p.m. UTC | #1
On Tue, 29 Oct 2024 22:11:24 +0800
Scott Fan <fancp2007@gmail.com> wrote:

> The option has been renamed, so add an entry in the
> Config.in.legacy file for the old option name.
> 
> Signed-off-by: Scott Fan <fancp2007@gmail.com>
> 
> ---
> Changes v1 -> v2:
>   - add an entry in the Config.in.legacy file

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index a041d4da42..30179add23 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,14 @@  endif
 
 comment "Legacy options removed in 2024.11"
 
+config BR2_PACKAGE_PROCPS_NS_ORIGINAL_TOP
+	bool "BR2_PACKAGE_PROCPS_NS_ORIGINAL_TOP has been renamed"
+	select BR2_LEGACY
+	select BR2_PACKAGE_PROCPS_NG_ORIGINAL_TOP
+	help
+	  The option has been renamed to
+	  BR2_PACKAGE_PROCPS_NG_ORIGINAL_TOP.
+
 config BR2_PACKAGE_QEMU_TARGET_NIOS2
 	bool "qemu nios2 support has been removed"
 	select BR2_LEGACY
diff --git a/package/procps-ng/Config.in b/package/procps-ng/Config.in
index 4afd01699b..7af0e97fb4 100644
--- a/package/procps-ng/Config.in
+++ b/package/procps-ng/Config.in
@@ -11,10 +11,10 @@  config BR2_PACKAGE_PROCPS_NG
 
 if BR2_PACKAGE_PROCPS_NG
 
-config BR2_PACKAGE_PROCPS_NS_ORIGINAL_TOP
+config BR2_PACKAGE_PROCPS_NG_ORIGINAL_TOP
 	bool "Use original top layout"
 	help
 	  Disable modern top layout, return to original top with
-	  detail cpu usage.
+	  detailed cpu usage.
 
 endif
diff --git a/package/procps-ng/procps-ng.mk b/package/procps-ng/procps-ng.mk
index 4ac82cf6f9..c5185c2c8a 100644
--- a/package/procps-ng/procps-ng.mk
+++ b/package/procps-ng/procps-ng.mk
@@ -56,7 +56,7 @@  else
 PROCPS_NG_CONF_OPTS += --enable-w
 endif
 
-ifeq ($(BR2_PACKAGE_PROCPS_NS_ORIGINAL_TOP),y)
+ifeq ($(BR2_PACKAGE_PROCPS_NG_ORIGINAL_TOP),y)
 PROCPS_NG_CONF_OPTS += --disable-modern-top
 endif