diff mbox series

[7/7] package/mesa3d: remove the dependency on Clover and build it in ICD mode

Message ID 20240713093700.13981-8-antoine.coutant@smile.fr
State Not Applicable
Headers show
Series Adding RustiCL | expand

Commit Message

Antoine Coutant July 13, 2024, 9:37 a.m. UTC
RustiCL can't be built in standalone mode. That shows that we can rely
on icd mode for Clover too.

This change adds more consistency between the two OpenCL
implementations.

Signed-off-by: Antoine Coutant <antoine.coutant@smile.fr>
---
 package/mesa3d/mesa3d.mk | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
index 7b1fc93a26..22ea19f401 100644
--- a/package/mesa3d/mesa3d.mk
+++ b/package/mesa3d/mesa3d.mk
@@ -54,14 +54,9 @@  ifeq ($(BR2_PACKAGE_MESA3D_OPENCL),y)
 MESA3D_PROVIDES += libopencl
 MESA3D_DEPENDENCIES += clang libclc opencl-headers
 ifeq ($(BR2_PACKAGE_MESA3D_CLOVER),y)
-ifeq ($(BR2_PACKAGE_OPENCL_ICD_LOADER),y)
 MESA3D_CONF_OPTS += -Dgallium-opencl=icd
 MESA3D_DEPENDENCIES +=  opencl-icd-loader
-else
-# Disable opencl-icd: OpenCL lib will be named libOpenCL instead of
-# libMesaOpenCL and CL headers are installed
-MESA3D_CONF_OPTS += -Dgallium-opencl=standalone
-endif
+# Always build clover in icd as it is done for RustiCL
 else
 MESA3D_CONF_OPTS += -Dgallium-opencl=disabled
 endif