diff mbox series

[1/1] package/octave: add optional libsndfile support

Message ID 20240712214838.446517-1-ju.o@free.fr
State Accepted
Headers show
Series [1/1] package/octave: add optional libsndfile support | expand

Commit Message

Julien Olivain July 12, 2024, 9:48 p.m. UTC
GNU Octave supports the --with-sndfile configure option since v4.0.0.

For reference, commit 40ea68b4b2 "package/octave: new package"
introduced the package at v7.1.0.

This commits adds this optional support.

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/octave/octave.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni July 12, 2024, 10:09 p.m. UTC | #1
On Fri, 12 Jul 2024 23:48:38 +0200
Julien Olivain <ju.o@free.fr> wrote:

> GNU Octave supports the --with-sndfile configure option since v4.0.0.
> 
> For reference, commit 40ea68b4b2 "package/octave: new package"
> introduced the package at v7.1.0.
> 
> This commits adds this optional support.
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
>  package/octave/octave.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 9, 2024, 11:40 a.m. UTC | #2
>>>>> "Julien" == Julien Olivain <ju.o@free.fr> writes:

 > GNU Octave supports the --with-sndfile configure option since v4.0.0.
 > For reference, commit 40ea68b4b2 "package/octave: new package"
 > introduced the package at v7.1.0.

 > This commits adds this optional support.

 > Signed-off-by: Julien Olivain <ju.o@free.fr>

Committed to 2024.02.x and 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/octave/octave.mk b/package/octave/octave.mk
index 0c7c411692..2e2fe0f989 100644
--- a/package/octave/octave.mk
+++ b/package/octave/octave.mk
@@ -43,6 +43,13 @@  else
 OCTAVE_CONF_OPTS += --without-curl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
+OCTAVE_CONF_OPTS += --with-sndfile
+OCTAVE_DEPENDENCIES += libsndfile
+else
+OCTAVE_CONF_OPTS += --without-sndfile
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 OCTAVE_CONF_OPTS += --with-openssl=yes
 OCTAVE_DEPENDENCIES += openssl