diff mbox series

[v2,02/18] board/pine64/rock64: make the patches to be applied with fuzz 0

Message ID 20240522070238.3282121-3-dario.binacchi@amarulasolutions.com
State New
Headers show
Series apply patches with fuzz factor 0 | expand

Commit Message

Dario Binacchi May 22, 2024, 7:02 a.m. UTC
This commit allows the U-Boot patch to be applied with fuzz factor 0.
The fuzz factor specifies how many lines of the patch can be inexactly
matched, so the value 0 requires all lines to be exactly matched.

Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
---
 ...3328-needs-itb-image-to-boot-properly.patch | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/board/pine64/rock64/patches/uboot/0001-Makefile-rk3328-needs-itb-image-to-boot-properly.patch b/board/pine64/rock64/patches/uboot/0001-Makefile-rk3328-needs-itb-image-to-boot-properly.patch
index 2d35b78daaf2..7c8473603457 100644
--- a/board/pine64/rock64/patches/uboot/0001-Makefile-rk3328-needs-itb-image-to-boot-properly.patch
+++ b/board/pine64/rock64/patches/uboot/0001-Makefile-rk3328-needs-itb-image-to-boot-properly.patch
@@ -1,4 +1,4 @@ 
-From 211bf049084e6e374dac253138fa813682910146 Mon Sep 17 00:00:00 2001
+From d312c4e40bf816823bdcfd066dd2511b23e83c9c Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Micha=C5=82=20=C5=81yszczek?= <michal.lyszczek@bofc.pl>
 Date: Tue, 5 Feb 2019 22:08:54 +0100
 Subject: [PATCH] Makefile: rk3328 needs itb image to boot properly
@@ -7,16 +7,18 @@  Content-Type: text/plain; charset=UTF-8
 Content-Transfer-Encoding: 8bit
 
 Signed-off-by: Michał Łyszczek <michal.lyszczek@bofc.pl>
+[Dario: make the patch to be applied with fuzz factor 0]
+Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
 ---
  Makefile | 5 +++++
  1 file changed, 5 insertions(+)
 
 diff --git a/Makefile b/Makefile
-index 8086f3c93e..a6425b5b03 100644
+index 149f83994814..ebbdf2596b9b 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -799,6 +799,11 @@ ifneq ($(BUILD_ROM),)
- ALL-$(CONFIG_X86_RESET_VECTOR) += u-boot.rom
+@@ -923,6 +923,11 @@ ifeq ($(CONFIG_SYS_COREBOOT)$(CONFIG_SPL),yy)
+ ALL-$(CONFIG_BINMAN) += u-boot-x86-with-spl.bin
  endif
  
 +# rk3328 needs itb image to boot properly
@@ -24,9 +26,9 @@  index 8086f3c93e..a6425b5b03 100644
 +ALL-y += u-boot.itb
 +endif
 +
- # enable combined SPL/u-boot/dtb rules for tegra
- ifeq ($(CONFIG_TEGRA)$(CONFIG_SPL),yy)
- ALL-y += u-boot-tegra.bin u-boot-nodtb-tegra.bin
+ # Build a combined spl + u-boot image for sunxi
+ ifeq ($(CONFIG_ARCH_SUNXI)$(CONFIG_SPL),yy)
+ ALL-y += u-boot-sunxi-with-spl.bin
 -- 
-2.18.1
+2.43.0