diff mbox series

[1/5] configs/orangepi_pc_defconfig: bump U-boot to v2024.01 to fix compatibility with setuptools >= 69

Message ID 20240520111730.1231889-1-peter@korsgaard.com
State Superseded
Headers show
Series [1/5] configs/orangepi_pc_defconfig: bump U-boot to v2024.01 to fix compatibility with setuptools >= 69 | expand

Commit Message

Peter Korsgaard May 20, 2024, 11:17 a.m. UTC
Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/6865597706

setuptools.extern.packaging.version.InvalidVersion: Invalid version: 'u-boot-2020.10'
make[5]: *** [scripts/dtc/pylibfdt/Makefile:30: scripts/dtc/pylibfdt/_libfdt.so] Error 1
make[4]: *** [scripts/Makefile.build:419: scripts/dtc/pylibfdt] Error 2
make[4]: *** Waiting for unfinished jobs....
make[3]: *** [scripts/Makefile.build:419: scripts/dtc] Error 2
make[2]: *** [Makefile:577: scripts] Error 2
make[1]: *** [package/pkg-generic.mk:283: /builds/buildroot.org/buildroot/output/build/uboot-2020.10/.stamp_built] Error 2

Commit 6b62384e3d2a9e1 (package/python-setuptools: bump to version 69.0.3)
bumped setuptools, which now errors out when passed a version with a prefix
string.  This u-boot- prefix string is dropped since U-Boot 2023.01 with
commit c977b1843504 (libfdt: Fix invalid version warning), so bump U-Boot to
v2024.01 to fix this issue.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 configs/orangepi_pc_defconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard May 24, 2024, 12:54 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/6865597706
 > setuptools.extern.packaging.version.InvalidVersion: Invalid version: 'u-boot-2020.10'
 > make[5]: *** [scripts/dtc/pylibfdt/Makefile:30: scripts/dtc/pylibfdt/_libfdt.so] Error 1
 > make[4]: *** [scripts/Makefile.build:419: scripts/dtc/pylibfdt] Error 2
 > make[4]: *** Waiting for unfinished jobs....
 > make[3]: *** [scripts/Makefile.build:419: scripts/dtc] Error 2
 > make[2]: *** [Makefile:577: scripts] Error 2
 > make[1]: *** [package/pkg-generic.mk:283: /builds/buildroot.org/buildroot/output/build/uboot-2020.10/.stamp_built] Error 2

 > Commit 6b62384e3d2a9e1 (package/python-setuptools: bump to version 69.0.3)
 > bumped setuptools, which now errors out when passed a version with a prefix
 > string.  This u-boot- prefix string is dropped since U-Boot 2023.01 with
 > commit c977b1843504 (libfdt: Fix invalid version warning), so bump U-Boot to
 > v2024.01 to fix this issue.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed series, thanks.
diff mbox series

Patch

diff --git a/configs/orangepi_pc_defconfig b/configs/orangepi_pc_defconfig
index fd0f64e0e6..0464de5619 100644
--- a/configs/orangepi_pc_defconfig
+++ b/configs/orangepi_pc_defconfig
@@ -22,7 +22,7 @@  BR2_TARGET_ROOTFS_EXT2_4=y
 BR2_TARGET_UBOOT=y
 BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG=y
 BR2_TARGET_UBOOT_CUSTOM_VERSION=y
-BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE="2020.10"
+BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE="2024.01"
 BR2_TARGET_UBOOT_BOARD_DEFCONFIG="orangepi_pc"
 BR2_TARGET_UBOOT_NEEDS_DTC=y
 BR2_TARGET_UBOOT_NEEDS_PYTHON3=y